1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IPKG, MMC/SD card Mod and read only filesystem?

Discussion in 'DD-WRT Firmware' started by oninous, May 5, 2008.

  1. oninous

    oninous Addicted to LI Member

    I installed the SD-Card Mod last night with a 1GB card. I downloaded and after a few hiccups managed to get DD-WRT installed on my router. Problem I'm having is in the DD-WRT web management page is says "Total / Free Size 2,816.00 KB / 0" under MMC/SD Card Support. So0mething goofy there... I used the tutorial at http://www.the-mesh.org/tiki-index.php?page=LinksysSDCard
    to install the MOD so I referred back to there to check on issues. It mentioned a different driver so I gave that a shot. I got hung up immediately on editing the ipkg.conf file. It resides on a read only filesystem.. I figured I was doing something wrong yet again so I referred to;
    http://www.dd-wrt.com/wiki/index.php/Ipkg
    I tried to use the direct URL's to install from examples and manual finds and compares. No dice.. they all fail and say returning.. This dumps me back onto a prompt. i can't use mkdir in /jffs.. it doesn't do anything.. i have it enabled also. Any ideas, help, or enlightenment is greatly appreciated! Last thought, I get a bunch of errors when i run ipkg update then ipkg list.. It says all the lists are not found....

    My hardware;
    Linksys WRT54GL v1.1 w/ SD Card MOD + DD-WRT v24 RC-7 (04/24/08) std

    Here are messages I recieved via the syslog server (from the router) If they will help!

    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:57 kernel: mmc: error in mmc_init (-1)
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:57 kernel: mmc: this board has no MMC mod installed!
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:57 kernel: mmc: starting module with: SD_DI=0x4, SD_DO=0x10, SD_CLK=0x8, SD_CS=0x80
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:57 kernel: VFS: Mounted root (squashfs filesystem) readonly.
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:57 kernel: ipt_IPV4OPTSSTRIP loaded
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:57 kernel: netfilter PSD loaded - (c) astaro AG
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: ipt_random match loaded
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: ip_tables: (C) 2000-2002 Netfilter core team
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: ip_conntrack version 2.1 (512 buckets, 4096 max) - 336 bytes per conntrack
    05-04-2008 05:57:09 User.Error 192.168.0.1 Jan 1 00:33:56 kernel: sflash not supported on this router
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: Physically mapped flash: Filesystem type: squashfs, size=0x2b6cc7
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: bootloader size: 262144
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: Flash device: 0x400000 at 0x1c000000
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: sb_doattach: incoming bus is PCI but it's a lie, switching to SB devid:0x4320
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: Broadcom Watchdog Timer: 0.05, timer margin: 30 sec
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: pty: 256 Unix98 ptys configured
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: Starting kswapd
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: Initializing RT netlink socket
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: PCI: Fixing up bus 0
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: PCI: no core
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: POSIX conformance testing by UNIFIX
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: Checking for 'wait' instruction... unavailable.
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: Page-cache hash table entries: 4096 (order: 2, 16384 bytes)
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: Calibrating delay loop... 249.03 BogoMIPS
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: Using 125.000 MHz high precision timer.
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: CPU: BCM5352 rev 0 at 250 MHz
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: zone(2): 0 pages.
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: zone(1): 0 pages.
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: zone(0): 4096 pages.
    05-04-2008 05:57:09 User.Emerg 192.168.0.1 Jan 1 00:33:56 kernel: On node 0 totalpages: 4096
     
  2. oninous

    oninous Addicted to LI Member

    I checked my wires today and made sure all the connections were correct and well soldered, formated the SD Card with an Ubuntu live CD to ext2 before inserting it. I verified that the manual config was right in case the auto didn't work. I then disabled the MMC support, saved, applied, and rebooted the router, then I re-enabled MMC support, saved, applied changes, and rebooted the router. Still not showing the appropriate size. I logged in with Putty and found out my tmp directory is writable via mkdir and rmdir. still can't edit ipkg.conf or wget files. I'm wondering if the fact that I'm using a release candidate might be the problem! I changed the version to a smaller generic version but it's still the same RC-7... I'm at a loss and I've been doing research on this non-stop... Any ideas would be greatly appreciated!

    mmc: starting module with: SD_DI=0x4, SD_DO=0x10, SD_CLK=0x8, SD_CS=0x80
    mmc: this board has no MMC mod installed!
    mmc: error in mmc_init (-1)
     
  3. oninous

    oninous Addicted to LI Member

    I forgot to mention the above error I get when I use putty to type "insmod mmc"....
     
  4. oninous

    oninous Addicted to LI Member

    OK.. So finally.....

    I actually figured out why my card wasn't working and replaced the dumb MMC/SD SOCKET! I messed up the connections bad! This problem is solved for me and hope it helps others to figure out where they went wrong!

    Verify your connections on the Card SOCKET! Thank you all for reading!
     

Share This Page