1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.


Discussion in 'Tomato Firmware' started by clarknova, Aug 4, 2013.

  1. clarknova

    clarknova Networkin' Nut Member

    Tomato Firmware 1.28.0000 MIPSR2-112 K26 USB AIO-64K

    I use PPPoE currently. My ISP recently announced support for IPv6CP, which appears to be a way to configure IPv6 over PPP.

    So I'm looking at the IPv6 options in Tomato, and none of them are obviously PPP related. I've tried a couple of options. "Native IPv6 from ISP" gets me a v6 address on the WAN and LAN as reported by Tomato, but test-ipv6.com gives me a score of 0/10.

    I tried "DHCPv6 with prefix delegation", and again Tomato reports a v6 address on WAN and LAN, but test-ipv6.com still shows a score of 0, although this time the text seems to indicate that I have a v6 address via teredo. The address it reports does not match those reported by Tomato, nor that of my Windows computer I'm testing from. The test also indicates that "Your IPv6 connection appears to be using Teredo, a type of IPv4/IPv6 gateway; currently it connects only to direct IP's. Your browser will not be able to go to IPv6 sites by name".

    None of the other IPv6 options in Tomato look like what I need, although I haven't tried them. I did notice that all of these options allow manual entry of DNS servers. Is that optional? My ISP did not give me v6 DNS addresses, so I'm expecting them to be assigned automatically.

    Any suggestions? Is ipv6cp supported in Tomato? Am I doing it wrong? Do I need more info from my ISP?
  2. xorglub

    xorglub Addicted to LI Member

    If you router gets an ipv6 address then it's fine.
    Do computers behind it get assigned an address ? Have you enabled RA on the LAN side ?
  3. clarknova

    clarknova Networkin' Nut Member

    My router's LAN has a "Link Local IPv6" address that is much shorter than the WAN's address. At least one LAN host has an IPv6 address and can ping -6 the router's LAN v6 address, but I don't appear to have v6 name resolution, and ping -6 attempts to the router's WAN address from a LAN host are unreplied.
  4. Lorenceo

    Lorenceo Networkin' Nut Member

    I'm in a similar situation. My ISP requires VLAN tagged, 1492 MTU PPPoE to authenticate and provides IPv6 through DHCP-PD.
    The most recent versions of TomatoUSB from Shibby and Toastman break IPv6 connectivity for me.
    The router will obtain its prefix from my ISP, the router itself can traceroute and ping v6 hosts.
    The prefix is announced to the LAN, however the MTU on the router advertisements is incorrect, and all clients report Destination net unreachable when attempting to connect to any v6 hosts.

    I was able to get IPv6 working on Toastman 1.28.0501.3 by disabling router advertisements and starting radvd with a custom config file written to NVRAM.
    I also have a script running every 2 minutes that checks whether radvd is still running, and if it isn't it will restart it.
    I've had to do this since Toastman 1.28.0501.3 ignores the MTU of the WAN and announces 1500MTU in the router advertisements, which breaks traffic to many sites as IPv6 does not support packet fragmentation.
    I have also had to write the script to restart radvd as it will often crash without warning, and not restart which breaks v6 connectivity.

    IPv6 works properly on the stock Asus firmware, however I'd much rather be using Tomato for the QoS, monitoring and interface.

Share This Page