1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

is this a bug of the vpn mod?

Discussion in 'Tomato Firmware' started by lyrebird, May 9, 2010.

  1. lyrebird

    lyrebird Networkin' Nut Member

    I tried to setup the vpn connection in the latest teddy bear's tomato with vpn. then i found that whenever i want to save a change, the tomato says:

    "Invalid number. Valid range: -1-2147483647"

    Then i figure out it is due to the entry "TLS Renegotiation Time", according to the specification, -1 is for default. however, tomato does not take it -- can't save my changes made to other entries.

    See the attached picture.

    Attached Files:

  2. teddy_bear

    teddy_bear Network Guru Member

    It's a bug in the beta 11 of my mod.
    Please see this post for a temporary workaround.
  3. lyrebird

    lyrebird Networkin' Nut Member

    Hi Teddy,

    I copied the scirpts to the init field, and rebooted the router. but it does not change --> still won't take the default -1, same error message.

    i guess i am ok for now as i set to 60, and it can be saved. the vpn runs fine though i need more test when I go to office on Monday. Any good value to suggest?
  4. teddy_bear

    teddy_bear Network Guru Member

    You probably did something wrong with the script, as others confirmed it is working...

    Anyway, using a value other than "-1" should work too (but I wouldn't know which value to suggest)...
  5. meazz1

    meazz1 Addicted to LI Member

    After copying the script and rebooting, i was able to save my settings but Status would not poll anything.
    Any idea?

Share This Page