1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Is VLAN tagging finicky on RT-N66R? (shibby build)

Discussion in 'Tomato Firmware' started by VirtualNobody, Mar 27, 2014.

  1. VirtualNobody

    VirtualNobody Reformed Router Member

    I have Shibby tomato-RT-N66U_RT-AC6x--116-AIO-64K on an RT-N66R. I am trying to configure physical port 1 as a trunked port to support the native VLAN and a trunked VLAN (VLANID 15) for a guest network.

    I have created this configuration on two E4200 with the same version of Shibby and it's working just fine. I have gone over my configuration with a fine toothed comb and I can't see what I've done wrong on the N66R.

    In all of these configurations, the E4200 and the N66R are being configured as simple APs. The DHCP/routing, etc, is being handled by a dedicated router.

    I installed tomato-RT-N66U_RT-AC6x--116-AIO-64K and immediately did a clear NVRAM.

    I created a bridge, br1 with an IP address on the trunked network. Then I went to the Advanced tab and added the VLAN ID 15 to port 1 as a tagged port, and then of course it made be tag VLAN 1 as well. I then clicked the VLAN experimental box.

    I then created WL0.1 and attached it to BR1.

    I made sure everything was saved and rebooted. Tried to ping the bridge and no response. Rechecked everything, verified the config against one of my E4200, and they appear identical.

    I dumped the NVRAM config and compared them, and they seem identical as well.

    The one difference I noted is that on the working E4200, vlan_trunk_so=1 and it's not on the N66R. What does this setting do? And what triggers setting it to 1?
  2. Victek

    Victek Network Guru Member

    That mean that this model is not listed in vlan capable devices, enter tag 1 in nvram value ant it will work.
  3. VirtualNobody

    VirtualNobody Reformed Router Member

    I actually tried that, nvram commit, and reboot, and it still didn't work. I then went back and tagged every port to VLAN1 and 15, saved, rebooted. When the router came back up, I could suddenly ping the VLAN 15 IP, but not the default.

    I logged in, NVRAM reset, and tried again. Configured everything the same, this time trunk_vlan_so was =1. But again, I could not ping the tagged IP.

    I again went over my working E4200 config and my N66 and they appear the same, just that the N66 doesn't work with trunking. In frustration, I installed DD-WRT, configured it like my AC66R that I have running DD-WRT, and the trunk is working fine!

    Really confused and frustrated as I've got this exact config working on E4200, so I know my procedure is proven.
  4. Victek

    Victek Network Guru Member

    besides nvram settings internal code must be modified too... just sent me the CFE.bin to include network map and model id in source code.
  5. VirtualNobody

    VirtualNobody Reformed Router Member

  6. Victek

    Victek Network Guru Member

    Please read with attention his post, he wrote.. RT-N66R ...;) .. as far I saw in other asus models the CFE for U and R version have small changes..
  7. VirtualNobody

    VirtualNobody Reformed Router Member

    Sent the cfe.bin from my router to your gmail.


Share This Page