1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

JTAG flash question

Discussion in 'Cisco/Linksys Wireless Routers' started by renzov01, Jun 30, 2006.

  1. renzov01

    renzov01 LI Guru Member

    as my router was bricked i thought lest get it alive again via JTAG......so I build a JTAG cable and connected that one to the pc......downloaded the hairydairy stuff and started te flash......but now I got the following everytime and it looks like it hangs..

    ====================================
    WRT54G/GS EJTAG Debrick Utility v4.5
    ====================================

    Probing bus ... Done

    Instruction Length set to 8

    CPU Chip ID: 00000101001101010010000101111111 (0535217F)
    *** Found a Broadcom BCM5352 Rev 1 CPU chip ***

    - EJTAG IMPCODE ....... : 00000000100000000000100100000100 (00800904)
    - EJTAG Version ....... : 1 or 2.0
    - EJTAG DMA Support ... : Yes

    Issuing Processor / Peripheral Reset ... Skipped
    Enabling Memory Writes ... Done
    Halting Processor ... (Processor did NOT enter Debug Mode!) Skipped
    Clearing Watchdog ... Done

    Probing Flash at (Flash Window: 0x1fc00000) ...

    does anybody knows how long this flash takes?
    or is it really hanging? if so what can I do to resolve this?
    and
     
  2. renzov01

    renzov01 LI Guru Member

    i tryed also to erase the nvram as the power led is flashing and the lan leds are on, but no luck........


    ====================================
    WRT54G/GS EJTAG Debrick Utility v4.5
    ====================================

    Probing bus ... Done

    Instruction Length set to 8

    CPU Chip ID: 00000101001101010010000101111111 (0535217F)
    *** Found a Broadcom BCM5352 Rev 1 CPU chip ***

    - EJTAG IMPCODE ....... : 00000000100000000000100100000100 (00800904)
    - EJTAG Version ....... : 1 or 2.0
    - EJTAG DMA Support ... : Yes

    Issuing Processor / Peripheral Reset ... Done
    Enabling Memory Writes ...

    it hangs here as mentioned above..........what is wrong, please help???
     
  3. renzov01

    renzov01 LI Guru Member

    solved the issue with hanging....
    did the following

    WRT54G -erase:nvram /noerase /noemw
    and then
    WRT54G -flash:cfe /noreset /noemw

    unit is currently flashing ......now at 35%
    hoop it finish completely now
     
  4. renzov01

    renzov01 LI Guru Member

    cfe.bin has been flashed to the unit, but still the same issue..........power led is flashing and the lan leds are on....

    somebody any idea??
     
  5. reber

    reber Network Guru Member

  6. dbcch

    dbcch LI Guru Member

    I dunno that /noerase is a good idea, but maybe it will work with it. I always have to use /noemw, but I think having to use /noerase may indicate a problem with your JTAG cable or flash ROM.

    You might try backing up the CFE and doing a file compare to make sure it matches the one you flashed. Noise, a bad cable, or other problems can cause the flash to get corrupted, or not actually get written.

    Especially if you tried to short pins, your flash chip may be damaged.
     
  7. reber

    reber Network Guru Member

    Oh, yeah
    /noreset is what you want!
    Not /noerase.
    I copied the instructions above without reading closely. :clap:
     
  8. renzov01

    renzov01 LI Guru Member

    got it all sorted out and working :cheer:

    the dd-wrt software is working now on 2 routers version 5,
    however i got still 1 issue..........the DHCP is not getting the cable modems IP correct so my internet is not working, the network internaly LAN/WLAN is working perfectly.

    any suggestions how i can get the DHCP set with the correct cable modem IP so my internet will be working??
     
  9. renzov01

    renzov01 LI Guru Member

    everything is working now.........updated the router with micro 0107
     

Share This Page