1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Jumbo Frames Support and Question

Discussion in 'Tomato Firmware' started by bucher, Dec 31, 2011.

  1. bucher

    bucher Networkin' Nut Member

    I've been reading into Jumbo Frames and reading a bit about them, but I'm a little uncertain if things are working correctly. I have a E2000 running latest toastman firmware, and I have a Realtek nic in my laptop that supports various Jumbo Frame sizes, starting at 2000. I recently purchased a Western Digital Mybook live.

    One strange thing I have noticed is that when I set Jumbo Frame size to 2K in device manager, the actual setting in registry is 2034. Another strange thing, without enabling JF in the router, when I ping the router with the command "ping -f -l " the largest size I can use is 1504 bytes, which indicates to me that when not enabling JF in the router, it is still using a larger MTU than 1500. When I ping the router wirelessly, 1472 is the largest size I can use. When turning on JF 2k, 1504 is still the largest size I can use. When changing both device manager and the router to 4K, I get the same result.

    If I telnet into the router and do "ifconfig" it shows 1500 for the MTU for br0, eth0, and eth1.

    Am I incorrect in assuming that Jumbo Frames should change the MTU, or am I confusing something, or does JF not work for this router?

    When I change the MTU to 2000 in the mybooklive I am able to ping the mybooklive with packets as large as 1972, which indicates that JF are working for it. So I'm confused..
  2. bucher

    bucher Networkin' Nut Member

    I tried to issue a ifconfig br0 MTU 2000 and the router locked up.

Share This Page