1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Just bricked rtN66U after Tomato upload

Discussion in 'Tomato Firmware' started by w11x22, Jan 15, 2013.

  1. w11x22

    w11x22 Networkin' Nut Member

    Hi all
    I just received thia Router and flashed the Router with Shibby latest build for this Router I followed all the instructions and changed the IP to Static etc but after the reboot I was unabe to log in to 192.168.1.1.. I tried everything but none worked... When I run the Asus find Utility it finds the Router with SSID as "Tomato24" or 22 and I am abke to ping the Router but cant login to GUI.... I just lost my Router and as forums I was told that this model is close to un brickable but in my case it looks like I bricked it......I even tried the stock build to throw on top of this but still nothing.....Any help is greatly appriciated........................
    Please help.................
     
  2. Mangix

    Mangix Networkin' Nut Member

    if you can ping it, it is not bricked!

    that being said, clearing the nvram sounds like what you need. i think holding the WPS button or the reset button(if it has one) will fix it.

    telnet should also work. default user/pass: root/admin
     
  3. w11x22

    w11x22 Networkin' Nut Member

    Thanks for the reply.. I tried the reset button that did not work...will try WPS button now.... Could you let me know the comand for the telnet as I am not familiar with Linux...
     
  4. Bird333

    Bird333 Network Guru Member

    WPS is for clearing nvram. Reset button is for putting the router in recovery mode.
     
  5. Monk E. Boy

    Monk E. Boy Network Guru Member

    Disconnect power from the router. Press and hold the reset button. Connect power to the router. Continue holding the reset button until the power light starts slowly flashing. The router is now in recovery mode and you can release the reset button. Its IP address is 192.168.1.1.

    You can now either use the ASUS Firmware Recovery Utility to re-flash the router, or you can assign 192.168.1.2 to your NIC and visit the recovery mode website to try an NVRAM reset from it. Either one should work, assuming you chose a flash that's compatible with the RT-N66U.

    The firmware recovery mode is why these routers are unbrickable, not because you can't send a bad flash to them.

    Unless you go through the process of re-flashing the CFE, something I don't recommend, you pretty much can't brick them. The reason a CFE flash can brick them is because this recovery mode "lives" in the CFE.

    (I should note that you can't accidentally flash the CFE by mistake as a newcomer to flashing routers, its just something to be very careful of doing when you gain experience)
     
  6. w11x22

    w11x22 Networkin' Nut Member

    Hi Monk
    I tired all this but nothing woked.....How can access the recovery mode website.....Please let me know for future and thanks for the reply....

    Li the Guru, your reply helped me and I reset the NVram as suggested by you to hold the WPS button and that let me in without any problems.............. I thank you guys again for such a top notch support, at first I thought that I have lost my 150 bucks....

    Monk please do let me now how to enter the `recovermode website`and also I am not familair with CFM...Please advice
     
  7. Monk E. Boy

    Monk E. Boy Network Guru Member

    When you have an ASUS router in recovery mode, which is done by holding down reset and connecting power then continuing to hold down reset until the power light starts flashing, the recovery mode website is at http://192.168.1.1. You have to assign an IP address (e.g. 192.168.1.2) to your Ethernet adapter in order to view it. You have to be connected over Ethernet, wireless won't work.

    Glad to hear it's working, the N66s have very nice hardware, and I've been pleasantly surprised by their stability under Tomato. I hope your experiences from here on out are as pleasant as mine have been.

    CFE is the firmware that runs your firmware. You can only flash it by entering commands over a telnet or SSH (command line) interface and even then it's pretty tricky to unlock and perform, its not something you'll do by mistake.
     
  8. RMerlin

    RMerlin Network Guru Member

    Note that you can also use the Firmware Recovery tool from the Asus CD while the router is in recovery mode - this saves you the trouble of having to set a static IP on your PC.
     
    Dr Strangelove likes this.
  9. Mangix

    Mangix Networkin' Nut Member

    on linux: telnet 192.168.1.1

    Windows has this too but must be enabled through Programs and Features in Control Panel.

    PuTTY also works. It's a GUI frontend: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
     
  10. Monk E. Boy

    Monk E. Boy Network Guru Member

    Yup, and I actually recommend using that method for the first flash because it makes you wait an appropriately long time during and after the flash.

    Now, granted, even after that completes you should fire up Tomato (visit the router's website) and perform a long NVRAM erase, then give that process 5 minutes or so to complete after it reboots.

    I had to setup about 5 of these N66Us recently and it was surprising to see how little changes in my setup procedure, like not waiting after the erase, made a big difference in the size of the NVRAM export I run after router setup. Patience is a virtue.
     
  11. SteveF

    SteveF Serious Server Member

    Monk, this is SteveF. I had to reapply for my ID which disappeared alongside with my post I started a week ago or so. Thank god, I printed it to a pdf file just before it disappeared. I do not know what made me do it. In any case, could you look at my post on the restarted 'QoS versus BW Limiter' post of mine. Here is the link:

    http://www.linksysinfo.org/index.php?threads/qos-versus-bw-limiting.64951/#post-218264

    Thanks for looking at this double-linking message.

    Steve
     
  12. Brian

    Brian Serious Server Member

    I think I managed to brick one. I can't get it into recovery mode. Holding the reset button during power up never causes the power light to blink. I can't ping it, can't get to 192.169.1.1, can't telnet.

    I have tried the 30/30/30 NVRAM reset.
    I have tried the reset button for recovery, both with pulling the power plug and with the power button.
    I have tried the WPS button also with no effect.
    The ASUS device discovery utility doesn't find the router.
    The ASUS firmware restoration utility won't connect to it.
    It doesn't ever seem to enter recovery mode. I get a solid power light after about 7 seconds. I've tried holding the reset button for various lengths of time, from 5, 10, 30 seconds all the way up to a couple minutes.

    I even opened it up and tried the serial console. All I get is garbled characters, although at 115200 baud there is some regularity to the garbled characters. It's almost as if the character encoding is wrong, but the different encodings I've tried haven't helped.

    Does anyone have any other ideas for me to try? Or should I just give up on this one?
     
  13. Monk E. Boy

    Monk E. Boy Network Guru Member

    I know if the CFE is reflashed and something goes wrong during the flash the router gets bricked, but as I recall the CFE is in a read-only portion of the flash until you unlock it from a telnet/ssh session. Otherwise the reset button should work.

    Though of course its possible for a router to brick to due a hardware failure.

    From your description it almost sounds like your baud rate is set wrong - have you tried different values and checked to see if there's any difference? Maybe you used the wrong pinout for the serial leads?

    How do the capacitors on the board look? Any of them bulging or leaking?
     
  14. Brian

    Brian Serious Server Member

    [quote="Monk E. Boy, post: 223253, member: 43369"
    From your description it almost sounds like your baud rate is set wrong - have you tried different values and checked to see if there's any difference? Maybe you used the wrong pinout for the serial leads?

    How do the capacitors on the board look? Any of them bulging or leaking?[/quote]

    Thanks for your response.

    I've tried baud rates of 9600, 19200, 38400, 57600, 115200, and 230400. I've tried swapping Rx & Tx at each rate. I've tried different parity and stop bit settings. The only time I get anything consistent is at 19200 8,N,1 and no flow control.

    [​IMG]

    At boot up, I get a lot of garbled text, as if it's displaying the status messages for a Linux boot process. After a minute or so it just repeats the text shown above over and over. As I was typing this I began to wonder if the USB to serial adapter might be part of the problem. I just tried the serial port in the laptop docking station. I get the exact same results. I don't have access to a computer with a built in serial port right now. I'll give that a shot also when I get a chance, but I'm not hopeful it'll be any different.

    The 2 barrel capacitors appear fine, at least to visual inspection. There are no visual signs that anything has burned or over heated nor any signs that anything is physically damaged.

    Ten seconds or so after booting I get a solid power light (regardless of whether I hold down reset, WPS, or both). I would suspect a broken reset switch if it weren't for the other problems.

    I also get network activity lights on the front when a Cat 5 is plugged into any of the network ports.

    I'm reading on dd-wrt.com forums about Jtag. I still need to do more reading about it, but I'm beginning to think that might be my only hope.
     
  15. Toastman

    Toastman Super Moderator Staff Member Member

    From your description, I'd say you had the same problem as me, the mobile phone TTL/USB adapter I was using was the culprit.
     
  16. Brian

    Brian Serious Server Member

    I scrounged up a computer with a built in serial port and tried again. Still no joy. I used Hyperterminal instead of Putty, but the results are almost identical.

    I'm going to build a jtag cable and try that method.
     
  17. SteveF

    SteveF Serious Server Member

    Brian, I do not know if you read the article by the attached link. It helped me, you may want to try it (I do not know what Asus router you have, this is for WL-520GU but all Asus routers may behave the same way from the restoration point of view???):

    http://www.dd-wrt.com/wiki/index.php/Asus_WL-520GU#Asus_Firmware_Restoration_Utility

    If you did not do any drastic thing, I do not believe that you may have a hardware problem. So you might be able to recover if that assumption is correct.

    Steve
     
  18. eahm

    eahm LI Guru Member

  19. Monk E. Boy

    Monk E. Boy Network Guru Member

    I'm sure you know this already, but the dd-wrt database lists the serial port as 115200 8-n-1 w/o flow control. If it doesn't work at those settings then something's gone horribly wrong.

    Any chance you had put a 64K firmware on it?
     
  20. Mangix

    Mangix Networkin' Nut Member

    Just saw this. You should NEVER EVER use your computer's built-in serial port for this. There's a big voltage difference that can fry your router. Your computer's serial port runs on 12 volts while a router runs on 3.3 volts.

    What you need is a serial adapter similar to this one: http://www.ebay.com/itm/USB-2-0-to-...376?pt=LH_DefaultDomain_0&hash=item2c65c24878

    That's the one I have and so far it has worked with four different routers.
     
    koitsu and Monk E. Boy like this.
  21. lefty

    lefty Networkin' Nut Member

    Most important thing is that whatever adapter you use must be capable of doing a voltage level shift to +3.3V not just +5V, this cannot be avoided, i have used a ca-42 clone cable for many years now, can't tell you how many units i helped port or corrected porting using this cable. You can purchase them on ebay for around $5 dollars US.

    Garbage output like what is listed above is definitely a bad cable sign, sometimes it can mean you got the tx/rx hooked up incorrectly, but from what i see above, i would lean more toward it being an improper cable in general. You mainly have to keep in mind when hooking up these cables, you have to hook the tx end of the cable to the rx end of the router. Most times, especially when i see the serial ports filled with solder, i only free up the tx/rx holes for the serial cable, i use the radio shielding for the ground, saves a little trouble on stubborn ports.

    Here is the cable i have used for a long time now:

    http://www.ebay.com/itm/USB-Data-Ca...853261?pt=PDA_Accessories&hash=item4ab85058cd
     
    Monk E. Boy, RMerlin and koitsu like this.
  22. Brian

    Brian Serious Server Member

    Thanks for all the suggestions everyone.

    Toastman, Mangix, & lefty, it very well could be my cable. I originally tried the serial with a CablesToGo USB to serial adapter. I only tried the built in serial port at the very last. I ordered a TIAO multi-protocol adapter yesterday that will do serial, jtag, etc. This one specifically says it can be used for for restoring bricked routers, hacking XBox, and the like. I'll let everyone know if that works.

    SteveF & eahm, the restoration utility won't work. It can't find the router and the router won't go into recovery mode.

    Monk E. Boy, Those are the serial settings that get the best results, but still it's still garbled. I did not put a 64K firmware on it. I had already done that successfully with 2 previous routers, but the stock firmware on this one was a newer version. I did not attempt the CFE update because of the firmware mismatch. This is the first one I actually attempted a 32K firmware on. I probably screwed up at this point. I had some detailed notes from the previous firmware updates. I probably should have researched from scratch installing this different version. I think I got too comfortable and it bit me.
     
  23. Toastman

    Toastman Super Moderator Staff Member Member

    When you look for these serial cables, you have to be very careful. For example, where I live, it is very hard to find a genuine CA-42 cable. The cheap clones come with several different chips inside, and none of them are truly compatible. The problem I had was that I could talk to a Netgear router OK but anything coming back was garbled. The same cable worked correctly with satellite TV receivers and also WRT54GL, and I never did find out exactly what was wrong, as the voltage levels all seemed correct. I changed to one that is supplied by Mouser, and it worked instantly.
     
  24. RMerlin

    RMerlin Network Guru Member

    Those USB to Serial adapters don't seem to play nice with TTL serial cables. I had a serial cable myself that was known to work (it was previously used by the WDLXTV lead developer, who sent it to me), and I never got anything but garbage using my UISB2Serial adapter with it.

    So I ended up doing all my development blindly without serial cable. That was "fun" while troubleshooting the GRO issues ;)

    Thanks for the URL lefty, I have ordered a pair of these. Might come in handy at some point.
     
  25. leandroong

    leandroong Addicted to LI Member

    I bricked my router when loading Shibby FW105, forgot to look for MIPSR1 and too late when I recognize my stupidity. To make story short, I was able to revive my router by just using 30-30-30. Took me around 2hrs though before finally succeeded having ping access to router IP and load FW using tftp. This is not fabricated story.
     
  26. lefty

    lefty Networkin' Nut Member

    Yes, you will need to of course splice off the phone connector end off, then it should be 3 wires, sometimes though they have been known to have 5, but all the ones i bought from gadgetown, which i have 3 of them, have only had 3 wires, 1 for tx, 1 for rx, and lastly 1 for GND.

    Easiest way to find out whats what without using a multi-meter is once you have it spliced off, and have plugged it up and let windows auto-detect it and then install the prolific driver for it, then open up your hyper-terminal or putty or whatever term program you want to use, set the proper port speed of course 115200 8,N,1 and no flow control, then cross the wires whilst typing something to the terminal, if your typing is echo'd to the terminal then you have atleast found tx and rx, if it doesn't echo back, then you are most likely crossing tx and GND or rx and GND. With a multi-meter though, you can easily remove all that type of guess work.

    To the poster with brick: main problem we have now with your unit is that if you avoided the proper cable and the one you used didn't have this type of voltage level shifting in it, you most likely fried your serial port, and now you will have to recover via jtag if this is the case.
     
  27. Brian

    Brian Serious Server Member

    Just an update.

    My problem was in fact the serial cable. Fortunately I did not fry the serial on the RT-N66U.
    Using a TIAO USB multi-protocol adapter I was able to communicate via the TTL serial pins.

    It took me several attempts to get the timing right with tftp, but the stock firmware is being flashed now. When the instructions say start the transfer "immediately", they mean it.

    *crossing my fingers*
     
  28. Monk E. Boy

    Monk E. Boy Network Guru Member

    Awesome news.

    Yeah, TFTP has a very narrow window of opportunity, so narrow that Windows 7's ridiculous behavior of searching for an connection to the internet before letting you transfer over the interface (or whatever it's doing immediately after link goes up) takes too long for tftp to work.

    Another reason to keep an XP system around...
     
  29. Zhuinden

    Zhuinden Reformed Router Member

    Hello!


    I had a similar problem, as in I was unable to access Recovery Mode even while plugging in power and pressing the Reset button during doing so.

    The solution was the following sequence of actions:
    - Unplug the router
    - Hold WFS Button
    - Plug power in the router
    - Wait until the power LED starts flashing
    - Release WFS Button
    - When all the LEDs light up, start pressing Reset button
    - Tadah! the power LED is now flashing slowly - recovery mode has been reached!


    I hope this will help someone in the future.
     
  30. gianpy69

    gianpy69 Reformed Router Member

    Hey Zhuinden,
    i just registered because i want to thank you. You save me and my router went in recovery mode following your instruction.
    Thank very much

    Gianpaolo
     
    Zhuinden and darkknight93 like this.
  31. Zhuinden

    Zhuinden Reformed Router Member

    I am glad I could help :)
     
  32. Zhuinden

    Zhuinden Reformed Router Member

    I have encountered a different kind of bricking after a messed up firmware upload in which case the problem was NOT that the router didn't go into recovery mode. The router ALWAYS went into recovery mode, even after flashing a new firmware!!!

    Okay, so this is more of a trial and error thing, but don't give up! It took me 5 hours to figure out the right solution with on-and-off tinkering, and with a weird procedure it was successful. Quoting myself from another website about the same thing:

    This happened due to a foiled DD-WRT upload, by the way. But it was still fixable.
    I figured it's better if I post the solution here as well.
     
  33. koitsu

    koitsu Network Guru Member

    For what it's worth: when I got my RT-N66U, and moved from the stock Asus firmware to Tomato (which didn't work through the Asus web GUI), I was forced to use the Asus Recovery Tool (or whatever it's called).

    The version of that tool I tried did not work (it sat there forever (literally 30 minutes) doing nothing), so I used another version (I forget where -- either off their site or maybe found in a thread here somewhere?), which then completed the transfer successfully. (I assume this is just a TFTP client by the way, but who knows)

    What I ended up with was a router which was in a very weird/wonky state. It would respond to 192.168.1.1 (for ICMP) intermittently, but the web interface (or any other part, telnet etc.) would not come up. I power-cycled the thing a few times, eventually getting it into another weird state (maybe I angered the CFE, not sure), which then eventually let me do the classic tftp-based upload method (what I prefer to use because I know what it does, heh :) ).

    But even after I did that, the router just sat there, seemingly in the same broken state. But then I remembered threads similar to this, and others, where people said verbatim: leave the router alone for a full 30 minutes. And when they say 30, they aren't kidding -- they REALLY DO mean a full 30 minutes. So I did just that -- waited, applied patience.

    Lo and behold, it worked. Eventually I got the Tomato web GUI, and subsequent reboots worked fine (no delays/oddities). It's almost as if the "recovery mode" flash methodology is extremely slow or something, or maybe there is some kind of "backup ROM" that's kicking into place. Flashing these things isn't exactly the fastest process, especially with the flash area being so big these days.

    I know there isn't a lot of hard evidence here in my post, and I apologise for that. It's mainly anecdotal / me remembering the process. I didn't have any of this nonsense with my RT-N16, and because the whole ordeal is happening at a very low level (probably at the CFE stage and pre-kernel), it's very hard to troubleshoot + get insights into what's going on, barring modding a serial port on the thing (and I don't want to violate my warrant on my RT-N66U for such).
     
    BikeHelmet likes this.
  34. Siff

    Siff Serious Server Member

    I can second that advice: I have two Asus RT-N66Us and the first flash I did on the first one of them didn't work. It took me 2 more unsuccessful attempts before I recalled that I have read somewhere that one should leave the router for 15 min. to complete the flash. And, after ~25 min., the 4th attempt was 100% success.

    Then I flashed both routers at least 5 more times (newer builds and different build versions) and I always timed how long it took before the router started to respond to pings - the average time was 15 min. This and the additional 5 min. I read the router needs to build the NVRAM, brings the average time to 20 min., but YMMV.

    So, give it some time - run a ping /t 192.168.1.1 and do not touch the router before 5 min. have passed after it starts responding.

    Good luck!
     
  35. Image This

    Image This Reformed Router Member

    Remembers me of my first attempts at flashing Tomato onto the RT-N66U rather then the Stock Firmware. After I had success though, I never encountered anything else in that regard for many many updates / reflashes up until today.
     
  36. PaulB

    PaulB Network Newbie Member

    Had to sign up for an account just to post.

    I too had the 6 hour ordeal with this damn router. I did my looking on the DD-WRT site and found that it was compatible and it pointed me to a mini Firmware release to upload. Thinking it was compatible and that I had upgraded a number of WRT-54G routers in the past I uploaded it, then the PITA started. Per instructions in the GUI I rebooted the device manually after it said it had finished, this was only within the first 5 minutes or so, I see now this was my first mistake. I am not sure if this caused the remaining issues or not.

    After this reboot I could not get to the device with DHCP so I set static and still could not get to it or ping it. I found the means of recovery mode (WPS button) and was able to get into the recovery GUI. I re-loaded the mini config and the same thing. I then found info about using the Merlin config first (this is the time I discovered that there are some very detailed steps for this specific router DOH!). Still nothing. I then tried going back to the ASUS factory config, nothing. At this point I also got into the locked recovery mode, could not get the thing to boot to anything BUT recovery.

    I was starting to get pretty frustrated thinking I had just hosed the thing a few hours after I bought it, but decided to keep going since there was apparently a 30 min delay on any uploads/changes that were being made. I started to make my changes and then set a 30 min timer on my phone and waited until it was done to make the next attempt. I cleared NVRam, uploaded Firmware, cleared NVRam and tried...rinse and repeat with a different firmware. I also tried the 30/30/30 to no avail and even the "mash all the buttons" approach mentioned earlier...nothing. I would always get to the hung recovery boot cycle with only the power (slow flash) and the E0 port light active.

    I then went back and cleared the NVRam one more time (45 min wait) then re-loaded the mini config from DD-WRT (45 min wait) but then I instead loaded the big config for the same release as the mini then waited another 45 min. BINGO!!!!

    I could now ping the device, the WiFi light was on, it was no longer in recovery mode and I could see the GUI! Thank the gods!

    I then got to work configuring the device for PrivateInternetAccess VPN so that I could get in market hockey games on GameCenterLive....I uh mean so I can ensure my personal security...

    For anyone using the devices for this, the instructions on the PIA site suck (surprise surprise) and I found a post over at Instructables.com that provided much better information.

    Hang in there if you are fighting this thing...if you can ping and hit the recovery page you HAVE NOT bricked the thing, it is just being a b!tch
     
  37. BikeHelmet

    BikeHelmet Networkin' Nut Member

    I don't do much serial port stuff, but I've flashed a lot of routers, and I have to say that flashing my RT-N66U was just as dramatic as it was for the rest of you.

    I set my laptop (not plugged into my network) to have a static IP and plugged into the router. After exploring the web interface and discovering that it wouldn't let me flash through that, I dug up the Asus Restoration Tool that I had heard might be required. The tool didn't see the router for some reason, so I kicked it into recovery mode and then it was able to see it. I flashed it, waited... only a couple minutes later it came back up in recovery mode. I could browse the web interface just fine. I waited 20-30 minutes and rebooted it, but it came back up in recovery mode again.

    Flashing through the web interface didn't work, so I tried flashing with the Asus tool again. Left it for a half hour, but it was still coming up in recovery mode. Hmmm...

    Then I got the idea to try resetting NVRAM. (I wasn't sure if the tool did it for me, and had planned to do it from the web interface, but obviously never got that far.) I looked up how, reset it, and then... nothing. I couldn't ping the router anymore. I noticed that the port lights went out, which was a bit foreboding.

    I was pretty flustered at that point, so I left to have a shower and cool off. When I came back later I tried to ping the router, but found that it was still dead. Tried changing cables, but still wasn't getting any signs of life out of it. I tried to reset the NVRAM again, but the lights didn't do anything impressive - just stayed solid. At that point I was pretty bummed - most of the routers that I flashed in the past at least had the switches come to life, suggesting that the basic hardware was initializing properly. No lights on the LAN ports and an NVRAM reset switch that didn't work seemed pretty grim.

    I flicked on my WiFi and unplugged my cable to do some online research, but then I noticed something very strange - two unprotected wireless networks, very clearly from the brick beside me. Connecting to either failed until I set a static IP for my WiFi - no web interface whatsoever, but by chance the Asus tool was able to see the router. Since I had done two NVRAM resets by this point, I figured I'd give it a go, and flashed the same Tomato firmware again over WiFi. I left it for a full 50 minutes, and when I came back the wireless was gone - but I was able to plug in and bring up a glitching out Tomato web interface. Navigation was broken, but I was able to copy+paste the URL for the firmware upgrade page. It seemed like a bad idea using that firmware upgrade box, but I figured after flashing over WiFi, it was worth a shot. I ticked the box to reset it again, then let it flash and waited another 50 minutes... THAT time it flashed properly, and Tomato came up properly. The router has been stable ever since.

    I've probably flashed about 30 routers so far, ~27 of them perfectly smooth, and two requiring a single NVRAM reset before the new web interface would come up. This one was downright weird! I almost get the feeling that half of the firmware was alive and half was dead after those first flashes. I have no idea how it killed the wired ports, as my understanding is those switches are usually separate hardware that initializes independently.

    Unsecured wireless saving my bacon was completely opposite to what I expected. Weirdest router ever.

    -BikeHelmet
     
  38. Grimson

    Grimson Networkin' Nut Member

    Well I found flashing the RT-N66U a very smooth experience:

    1. Set a static IP on your PC and verify you can reach the stock web interface.
    2. Turn it off, hold the reset button and turn it on, when you see the power light slowly blinking let go of the button.
    3. Open up the web interface of the CFE by going to the same IP you used for the stock interface.
    4. There is an option to clear NVRAM, use it but don't reboot the router.
    5. Now flash the tomato firmware through the CFE's web interface and let the router do it's work.
    6. Wait for at least 20 Minutes, the router will reboot at least 2 times during this period.
    7. You should now be able to reach tomato on 192.168.1.1, make sure the static IP of your PC is in that range.
    8. If you can't reach it turn it off, hold the WPS button, turn it on and wait till the power light is flashing fast.
    9. Now let go of the WPS button and restart the router again.
    10. Give it around 5 minutes to completely boot up and then you can reach the tomato web interface.

    There is no need for the Asus Restoration Tool with the web interface from the CFE.

    I have now flashed a bunch of them for family and friends. And only on one I had to use steps 8 to 10, but I guess I forgot to clear the NVRAM before flashing in that case.
     
  39. Anne Marie

    Anne Marie Network Newbie Member

    I have the same issue as the gentleman that started this thread. I have had the ASUS RT-N66U router a couple of months and decided I would set up the ftp server and DDNS service to access my USB files anywhere.

    During the course of this weekend I have tried setting it up/resetting it, with some success but not all. I was using the latest Merlin firmware then on the last reset I thought I would try the Tomato 24 firmware. Since then I have tried all day and night to restore the router.

    On the last restore I used the latest ASUS firmware (I followed the ASUS website FAQ to the letter)... it loads and says it is successful. However when I run the discovery tool if finds the router with Tomato 24 and it is sending a wireless signal under that name. I cannot log in to the Router's web based gui. I have emptied the cache ... nothing has worked. I tried the WPS button and that didn't do anything. I am connected to the router on a wired connection. The Discovery tool finds the router at 192.168.1.1 but I can't access it on the web gui. I am at my wits end with this and under pressure because no one else can connect to the internet. I can follow directions but am not a techie like some of you wonderful people that are assisting others. Thanks in advance for any help you can provide. I am hoping I didn't kill it : ( .

    Other details: I am connected to the internet with a VDSL modem/router (wireless has been disabled) it uses 192.168.1.1, so I have to change the IP on my router to 192.168.2.1 once I get into the app. When it is working properly the router app identifies the conflict and completes the change itself, but I have done it manually when it didn't.
     
  40. BikeHelmet

    BikeHelmet Networkin' Nut Member

    Anne Marie,

    Make sure you're plugged into one of the offline Tomato router's ethernet ports. Do not plug it into the modem or anything else. Both of your devices prefer 192.168.1.1 as default IP, which will only cause conflicts during this sensitive/ornery update process.

    No, you probably didn't kill it... especially if you can see a wireless network. But it is likely that DHCP is buggered, among other things. Make sure you set those static IPs for wired/wireless in the Network and Sharing Center.(Windows) Just choose any IP on the same subnet, like 192.168.1.100, and keep gateway and DNS as 192.168.1.1

    Also read my story... for some strange reason wireless was the only way that worked for me. I had to reflash the router quite a few times before it finally took properly.

    -BikeHelmet
     
  41. Grimson

    Grimson Networkin' Nut Member

    Which firmware did you actually flash? Please post the complete filename.
     
  42. Anne Marie

    Anne Marie Network Newbie Member

    tomato-K26USB-1.28.RT-N5x-MIPSR2-124-AIO-64K.trx

    Thanks
     
  43. Grimson

    Grimson Networkin' Nut Member

    That should work, if the flash completed follow the steps 8 to 10 on my earlier post.

    And if your modem uses the same IP disconnect it from your PC and/or the router while your setting up tomato, a reboot of the PC may be needed to clear it's ARP in that case.
     
  44. Anne Marie

    Anne Marie Network Newbie Member

    Bike Helmet .... Thanks for trying to help, I tried flashing it wirelessly a couple of times, did nothing. I see the wireless network tomato24 listed as available, but I also see the ghost of my old wireless connection. I tried running the Device Discovery tool while wireless and it doesn't pick up anything. Tried plugging ethernet back in because PC had been sitting a few hours - no luck. While plugged into router ran Device Discovery tool again and it picks up Tomato24.
     
  45. Anne Marie

    Anne Marie Network Newbie Member

    Grimson I could kiss you, that worked a treat. Thank you very much
    Cheers Bike Helmet for your assistance and support too : )

    Note: Because Device Discovery showed it as Tomato24, I figured the restore to ASUS firmware didn't take. In fact it did because that is what it came up as when I got the web interface.
     
  46. Grimson

    Grimson Networkin' Nut Member

    The Asus discovery/configuration tools will not work with Tomato, because Tomato does not include the service software used by them.

    So if you want flash to tomato again you can follow my post above and then configure your router via it's web interface.
     
  47. Anne Marie

    Anne Marie Network Newbie Member

    Thanks again Grimson
     
  48. schnappi

    schnappi Serious Server Member

    Hi,

    Honestly did not read the entire thread. So if am repeating or if has been solved sorry.

    DHCP might be disabled by default (not sure about Shibby Tomato builds).

    Try connecting to the wireless (should be wireless for 2.4ghz and wireless1 for 5 ghz) with a smartphone or tablet (sometimes Windows caches networks oddly in the registry or something that causes Windows 7 not to immediately recognize new ethernet network) and use the following static IP settings:

    Use static IP: 192.168.1.X
    Subnet mask: 255.255.255.0
    Default gateway: 192.168.1.1
     

Share This Page