Kai on v4.71.1, Hyperwrt 2.1b1 + Thibor15c

Discussion in 'HyperWRT Firmware' started by rvas18, Sep 29, 2006.

  1. rvas18

    rvas18 LI Guru Member

    is it still possible to get kai running on v4.71.1, Hyperwrt 2.1b1 + Thibor15c installed on a linksys wrt54g v4 i would be controlling it from XBMC and i am sorta clueless on how to get started
     
  2. GhaladReam

    GhaladReam Network Guru Member

  3. AmyGrrl

    AmyGrrl Network Guru Member

  4. rvas18

    rvas18 LI Guru Member

    all right i got the script on my router i was kinda unsure what script to use, i beleive my router is the gateway??? but anyway in telnet i get this as my prcocesses

    165 0 840 S ./gokaid -d
    166 0 840 S ./gokaid -d
    167 0 840 S ./gokaid -d
    168 0 840 S ./gokaid -d
    169 0 840 S ./gokaid -d
    170 0 840 S ./gokaid -d
    171 0 840 S ./gokaid -d
    172 0 840 S ./gokaid -d
    173 0 840 S ./gokaid -d
    174 0 840 S ./gokaid -d
    175 0 840 S ./gokaid -d

    ive tried killing the all and i type

    tmp/gokaid to start it again and i get

    # tmp/gokaid

    KAID: Config file 'kaid.conf' not found...

    but the kaid.conf is definetly downloaded in the tmp/kaid.conf

    i would appreciate anyhelp getting this fixed cause kai doesnt work well over a wireless connection and i dont have a pc hardwired to the router to run the engine now
     
  5. pitch78

    pitch78 Network Guru Member

    gokaid et kaid.conf location

    use cmd:
    ./gokaid -d -c /tmp/kaid.conf

    ./gokaid -h for more informations

    hope this will help you
     
  6. rvas18

    rvas18 LI Guru Member

    i tried it but it doesnt work i dont what do the ./ mean cause kaid isnt found anywhere but the tmp directory
     
  7. rvas18

    rvas18 LI Guru Member

    this is the output

    # ./gokaid -d -c /tmp/kaid.conf

    /tmp/.webcmd.sh: /tmp/.webcmd.sh: 2: ./gokaid: not found
    although the processes show it running ./gokaid -d
     
  8. pitch78

    pitch78 Network Guru Member

    You must do it from the /tmp directory
    You should be in by default, otherwise use this instead :

    /tmp/gokaid -d -c /tmp/kaid.conf

    if you execute a ls command or ls -l
    in the /tmp dir.
    do you see gokaid & kaid.conf ?
    if gokaid executable ?

    Else, i don't now...
     
  9. pitch78

    pitch78 Network Guru Member

    You can also try to execute :

    /tmp/gokaid -c /tmp/kaid.conf

    to see what's wrong in command line...
     
  10. rvas18

    rvas18 LI Guru Member

    looks like i have a segmentation fault gotta read up on that

    # /tmp/gokaid -c /tmp/kaid.conf

    KAID: Kai Engine for KaiStation is initialising...
    KAID: Kai Engine for KaiStation is starting...
    THREAD: Engine thread started...
    THREAD: Packet sniffing thread started...
    PCAP: Applying libpcap filter...
    THREAD: Orbital stream thread started...
    THREAD: Datagram server thread started...
    KAID: Kai Engine for KaiStation has started...
    Segmentation fault
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice