1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

kai suport on v4.70.8, Hyperwrt 2.1b1 + T

Discussion in 'HyperWRT Firmware' started by nando1975, Mar 5, 2006.

  1. nando1975

    nando1975 Network Guru Member

    in runing on my wrt54gsv4 Firmware Version : v4.70.8, Hyperwrt 2.1b1 + Thibor13d and i would like to know how could y activate kay suport on itt becouse i readed a toxic post saying tath:

    Removed Kai from Gui, it can still be activated with telnet "nvram set kai_enabled=1"


    i tryed in on my router but i can,t make it to work

    regards
     
  2. Thibor

    Thibor Super Moderator Staff Member Member

    kai was removed altogether, look at www.thibor.co.uk
    there is a script there for enabling kai
     
  3. nando1975

    nando1975 Network Guru Member

    thanks

    i tryed it an all ig get is
    Your router is currently syncing with Kai...
    Please refresh this page in 2 mins.

    and 20 min later stlil the same thing is there any thing i have to edid on my script??



    regards
     
  4. itsmeohmy

    itsmeohmy Network Guru Member

    I get the exact same problem.

    WRT54G V2.0 using Thibor 14.

    All I get is "Your router is currently syncing with Kai... Please refresh this page in 2 mins."

    And it doesn't matter how long I wait because that message never goes away.

    Could this announcement from the Kai team have anything to do with it?

    http://texas.teamxlink.co.uk/forum/viewtopic.php?t=17210

    They say that Kaistation is no longer available for use on the WRT54G/S because the router "performs unreliably"?

    They posted that back in January, yet Thibor posted here in March saying to use the bootscript.

    So who is right? Thibor? Kai?

    Help!
     
  5. nando1975

    nando1975 Network Guru Member

    try this script



    #begin
    cd /tmp
    echo "#!/bin/sh cd /tmp
    if [ ! -s gokaid ]; then
    wget
    \"http://www.teamxlink.co.uk/kaistation/profile.php?action=getgokaid&kaiid=\`nvram
    get kaiid\`\" -O gokaid
    sleep 1;chmod +x gokaid;fi
    ./gokaid" > startkaid
    chmod +x startkaid
    echo "*/2 * * * * root /tmp/startkaid" > cron.d/check_kaid
    touch crontab
    mkdir wwwext
    echo "<iframe width=396 height=175 frameborder=0 scolling=auto
    marginwidth=0 marginheight=0
    src='http://www.teamxlink.co.uk/kaistation/profile.php?action=edit&kaiid=<%
    nvram_get(\"kaiid\");
    %>&if=br0,eth0,eth1,vlan0,vlan1&style=linksys'>
    </iframe>" > wwwext/kai.asp
    #end
     
  6. itsmeohmy

    itsmeohmy Network Guru Member

    That's the exact same script that Thibor has on his page. I've been using that. Doesn't work.

    (BTW, yours is missing the closing tag for the iframe.)

    Thanks for trying though.
     
  7. Thibor

    Thibor Super Moderator Staff Member Member

    you could start by running each line of the startup script manually and see where it fails, ie the wget line and see if it actually downloads the kaid binary. also you could see if your tag is in the nvram, nvram show | grep kai. if nothing is there, do: nvram set kaiid=""; nvram commit and reboot, that may help
     
  8. Mag1c1an

    Mag1c1an LI Guru Member

    Can not get KaiD to start!

    Hi all, i have just installed Thibor 13d on my WRT54G router. Howerver, i am unfortunately having problems getting the Kai Daemon to start. Whenever i go to the http://192.168.1.1/ext/kai.asp page nothing is showing.

    Kai Control Pad on my XBMC tells me that Kai Daemon isnt running no matter what i do.

    I took the advice a couple of line up and i can see that my kaiid is showing up in nvram, rebooted my router and still no Kai.asp page.

    Here is the script i am using for my startup script, which by the way also shows up in nvram.

    #begin
    cd /tmp
    echo "#!/bin/sh
    cd /tmp
    if [ ! -s gokaid ]; then
    wget \"http://www.teamxlink.co.uk/kaistation/profile.php?action=getgokaid&kaiid=\`nvram get kaiid\`\" -O gokaid
    sleep 1;chmod +x gokaid;fi
    ./gokaid" > startkaid
    chmod +x startkaid
    echo "*/2 * * * * root /tmp/startkaid" > cron.d/check_kaid
    touch crontab
    mkdir wwwext
    echo "<iframe width=396 height=175 frameborder=0 scolling=auto marginwidth=0 marginheight=0
    src='http://www.teamxlink.co.uk/kaistation/profile.php?action=edit&kaiid=<% nvram_get(\"kaiid\"); %>&if=br0,eth0,eth1,vlan0,vlan1&style=linksys'>
    </iframe>" > wwwext/kai.asp
    #end

    What else can i do, how do i find out if it is actually downloading the kaid.bin from teamxlink.co.uk?
     

Share This Page