1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Linksys Release official WRV200 v1.0.39 firmware!

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Jun 6, 2008.

  1. Toxic

    Toxic Administrator Staff Member


    WRV200 Firmware 1.0.39 Release Note


    Issues Fixed:

    1. Fixed the problem that WRV200 may block the FTP traffic after a random period of time.

    2. Fixed two QuickVPN issues with Vista and Vista SP1. With this firmware, QuickVPN
    Client can connect to WRV200, regardless whether the Client is behind a NAT or not.

    3. Fixed a PPTP WAN Connection issue where WRV200 cannot connect with certain
    PPTP servers.

    4. Fixed an issue where certain wireless clients may cause WRV200 to flood the LAN
    with ICMP Echo requests.

    Known Issues:

    1. QuickVPN Client v1.2.8 on Windows Vista cannot work properly when the Vista PC uses
    a wireless adapter to connect to the network. The issue will be fixed by a future
    release of QuickVPN Client.

    2. Windows Firewall needs to be enabled on Windows Vista in order for QuickVPN Client
    to function properly. This is due to the fact that IPSec service on Vista is disabled
    when Windows Firewall is disabled.

    3. QuickVPN Client v1.2.6 on Vista does not work properly when the Server Address is
    a DDNS domain name. This issue was fixed by QuickVPN Client v1.2.8.

    4. There is a known issue with Windows XP SP2 Firewall - ICMP packets are always dropped
    by the Firewall when the Firewall is enabled. The issue will cause the QuickVPN Client
    not being able to establish a tunnel with the remote QuickVPN Server successfully.
    Microsoft has released a patch to fix this issue. Once you install the patch, the issue
    should be resolved.

    download : http://www.linksys.com/servlet/Sate...2335899B03&displaypage=download#versiondetail
  2. pepemosca

    pepemosca LI Guru Member

    Wow! Thanks Toxic for the post!!!

    Does anyone has tried this firmware already?
  3. Sfor

    Sfor Network Guru Member

    I've loadaed the firmware. The first impression is not a great one. After making changes to the clock settings on the basic setup page, the form does not load correctly in most cases. Saving settings makes the router to reboot. The page does not reload itself correctly, in such a case. The page is destorted or the fields are not filled correctly.

    Also the "Automatically adjust clock for daylight savings changes" option does not work correctly for the "(GMT+01:00) Sarajevo, Skopje, Wasaw, Zagreb" time zone. (It is a very old bug)
  4. pepemosca

    pepemosca LI Guru Member

    So maybe a 1.0.40 version is right on the corner... Maybe, or hope so!
  5. pepemosca

    pepemosca LI Guru Member

    I see that there're not much adepts to this release :)
    There are no posts about this firmware :O
  6. Sfor

    Sfor Network Guru Member

    Well, I've been playing a bit more with the new firmware. The problems with page loading right after a reboot are happening from time to time, only. It is enough to refresh the web page in such a case. Still, I've tested just the web interface, so far.
  7. Sfor

    Sfor Network Guru Member

    I have found some changes in the IPSec VPN section. The first I've noticed is a new "NetBIOS Broadcast" checkbox available. The second change is much more funny than important. In the VPN Log the WRV200 calls itself a WRV210 (?!?) when making informational response related entries. An example: "[WRV210 Response:] Remote peer has no tunnel entry to correspond to this tunnel."
  8. pepemosca

    pepemosca LI Guru Member

    A new WRV arround the corner? With the same firmware? With the same problems!? I pass.
  9. ghost_zero5

    ghost_zero5 LI Guru Member

    Is the FTP and ICQ and maybe other connection issue with this firmware now REALLY fixed?
    I am now using a different router because of this though already, but I still would like to know...
  10. Sfor

    Sfor Network Guru Member

    I've changed my gateway router, as well. The current one works better than I was hoping for. The WRV200 is just an IPSec security gateway processing only the VPN traffic placed behind an OvisLink gateway router. I do not want to change my current set, as it works very well with WRV200 1.0.37 firmware. I will deploy yet another WRV200 as a remote gateway. But, I'm not in a hurry.

    Since there is no access to the beta firmware versions, I do not feel like a beta tester, any more.
  11. Sfor

    Sfor Network Guru Member

    Another small bug: DHCP lease time remaining is in the "Host Name" column on the Status - Local Network - DHCP Clients Table page.

    The WRV200 web interface will fail, if an IPSec tunnel with the Remote Security Group equal to the Local security group is connected.

    Only one tunnel with an active NAT-Traversal function can be created. There is no control over the Remote Secure Group in such a case.


    I made an IPSec tunnel between 1.0.37 and 1.0.39 WRV200 routers. The 1.0.37 is hidden behind NAT. The 1.0.39 is on dynamic IP with DDNS.

    If the 1.0.39 has the NAT-Traversal switched off, both routers are showing a correct connection C status and it is possible to open another router web interface through the VPN tunnel.

    If the 1.0.39 has the NAT-Traversal turned on, the other router does show the T status (instead of C), when the tunnel is working. Also it is not possible to enter another router WEB interface through the VPN tunnel. Still the tunnel is working correctly, as it is possible to access all other remote devices.
  12. Sfor

    Sfor Network Guru Member

    I've changed the firmawre in one of the endpoints to 1.0.39, as well. The tunnel status does not go to C, just as it did before. When I put an RV042 in place of the endpoint WRV200, the connection status is displayed correctly.

    So, the bug exists in both 1.0.37 and the 1.0.39 firmware revisions.
  13. rs4711

    rs4711 Guest

    use 2 WRV200 as WDS WLAN Bridge only.
    Both WRV200 have no internet connection. Both are access points and are extending the WLAN through WDS.

    After 5 or 6 days after rebooting, I cannot connect to the web interface anymore.
    I get the login mask. After entering user and password, the browser interface stays empty without any error (tested with Firexfox 2.0.14, Firefox 3.0 IE 7).

    Yes I have the Allow Wireless Web Access enabled on both WRV200.
    Yes i have done factory reset before flash of 1.0.39 and factory reset after flash.
    Yes the problem exists on both WRV200.

    So what can I do?
    The only way is to restart the WRV200.

  14. Sfor

    Sfor Network Guru Member

    I had a strange situation with one of my WRV200. I've been playing with settings. After a reboot the router stopped responding. After examining the router lights it appeared it reboots itself constantly. The power reset did not worked, the hardware reset button did not worked, as well. In order to bring it back to life it was enough to disconnect cables from all LAN ports. The router booted and the web interface was working, again. But, with any reboot with any LAN port connected the router was doing the same reboot loop, again.

    In order to get rid of the strange "reboot looping", I've disconnected the LAN ports. Waited until the router finishes booting. Then connected the LAN cables back. The web interface was working, so I did a hardware factory defaults routine. After entering all the settings, the router works correctly, so far.
  15. pepemosca

    pepemosca LI Guru Member

    Mm, seams that this firmware is not good at all.
    I still on the .38.
  16. Sfor

    Sfor Network Guru Member

    There are no proof the problem was related to the firmware. I saw several situations with the older firmware, when the router rebooted itself a few times in round. But, it never entered endless loop, and a power reset was always effective. This time the situation was different. It could be the new firmware, or something else is going on here.
  17. pepemosca

    pepemosca LI Guru Member

  18. Sfor

    Sfor Network Guru Member

    I do agree the quality is the same as the price. In other words, both are low.
  19. pepemosca

    pepemosca LI Guru Member

    Well, I'd paid $120 for this router, where the WRT54GL cost 20 bucks less.
    (here in Argentina).

    So, it wasn't that cheap for me.

    Still, I agree with you about the quality level :)
  20. Sfor

    Sfor Network Guru Member

    Well. The WRT54GL does not have hardware security acceleration, as far as I know. So, WRV200 is many times faster with VPN processing. Other devices able to match the WRV200 VPN throughput are twice as expensive, at least.

    Other Linksys devices with the same VPN processing speed are WRV54GL and BEFVP41 (both about 30Mbit).
  21. DerToob

    DerToob LI Guru Member

    I found another bug with VPN. Don't know if it is a .39 problem only.

    I've setup two VPN Tunnels and wanted one of them being disabled.
    After disabling tunnel B the router keeps on trying to start two tunnel with the result that tunnel A restarts every minute.
    There is no way except factory default reset to delete tunnel B entrys.

    By the way:

    i decided to to replace one of three WRV200 with a netgear FVG318 v2.
    What shall i say..... yesterday i uploaded the newest firmware hoping some problems will be gone :rolleyes:
  22. Sfor

    Sfor Network Guru Member

    Two of my WRV200 are working with one VPN tunnel constantly disabled. I have not noticed any negative influence from the disabled tunnels, so far.

    On the other hand I do have an impression the WRV200 starts to work slower or becomes less responsive if it tries to establish a tunnel. So, if the remote device is disabled WRV200 does not work well untill it stops the connection retries.
  23. DerToob

    DerToob LI Guru Member

    I don't know.. i've tried to reproduce the bug and enabled and disables the second tunnel again and nothing happend. :confused:
  24. Sfor

    Sfor Network Guru Member

    I've encountered a problem with WRV200 DHCP server. I found no possibility to change the default gateway setting obtained through DHCP. This restricts the usage of the DHCP in WRV200 to simple internet gateway. My LAN is much more complicated, and cheap routers based on SMC chip and code are giving much more possibilities when comes to the DHCP. (For an instance OvisLink IP-1000R - a clone of the SMC barricade series)

    It's sort of a feature request. I doubt it will be considered seriously, because even RV042 does not let to change the gateway IP obtained through DHCP.
  25. hvico

    hvico Guest

    I am experiencing blocking of the ftp traffic after a random period of time (Linksys WRV200). Firmware 1.0.39 was supposed to fix this annoying bug but after upgrading my router to this version I still have the problem. Linksys WRV200 1.0.39 changelog

    "1. Fixed the problem that WRV200 may block the FTP traffic after a random period of time."

    Any suggestions? Many thanks!
  26. fredari

    fredari Addicted to LI Member

  27. Sfor

    Sfor Network Guru Member

    The VPN seems to be the strongest point of the WRV200.
  28. pepemosca

    pepemosca LI Guru Member

    fredari, are you using the .39 firmware?
  29. fredari

    fredari Addicted to LI Member


    :agree: (I had the same prob with the old firmware, but never tried upgrading the driver then. Sympoms were identical with the .39 as with the shipped driver .2X - something)
  30. pepemosca

    pepemosca LI Guru Member

    I still don't change from the .38... I'm scared :)

    But you'd never tried the .38, right?
  31. fredari

    fredari Addicted to LI Member

    Divorce is difficult, but eventually pays off. :biggrin:
  32. Grohotun

    Grohotun Guest

    this firmware don`t remove problems ... ftp and icq are blocking sometimes..... anybody know how to fix this? i don`t like to reboot router every hour.
  33. Sfor

    Sfor Network Guru Member

    The router worked for two months without the "reboot loop". But, the problem came back. This time I had a spare WRV200. So, I've transferred the settings to the new one (by file), hoping to test if I'm fighting with a hardware malfunction problem. And the new router behaved exactly the same, as the old one. The conclusion is the settings are holding the key to the problem. The settings got corrupted, somehow, I believe.
  34. monz88

    monz88 Guest

    I have WRV200 with 1.0.39 firmware.
    I connect with my provider at L2TP or PPTP connection, but i don't have buttons "connect" or "disconnect" in Status!:mad:
    What can i connect to internet???

    Attached Files:

  35. Sfor

    Sfor Network Guru Member

    I've found another problem with WRV200 working in the router mode.

    It is possible to access the WEB interface of the WRV200 using WAN IP with remote management disabled from the LAN port side.

    The client computer:
    IP: Gateway:

    The WRV200 in router mode:
    WAN: Gateway:

    When connected to the network with just the LAN port it is possible to access WWW interface through the WAN IP. This means the LAN port responds to ARP queries targeted towards the WAN IP MAC. It should not to do it in any case, I believe.

    Further testeng revealed, the WRV200 LAN port does respond to both LAN and WAN IP ARP queries in both router and gateway modes. The difference between those modes is the WRV200 does not responf to WWW WAN IP queries in the gateway mode.
  36. ramper

    ramper Guest

    Hi All!

    I have router WRV200. After update firmware to v 1.039. My router have self reboot time from time to time. On firmware 1.038 all works good, but i'm delite this firmware. Please send me firmware 1.038 or 1.037 to m_rud@mail.ru or post link. Big thenx to all and sorry for my bad english.
  37. xitah

    xitah Guest

    Access shared folders inside LAN

    November 2008 WRV200 1.0.39 still working without NETBIOS broadcast. I'm not talking about VPN connections. Wireless clients (SSID isolation function disable) can't access to shared folders in the network, only with IP.
    Any solution?
  38. Sfor

    Sfor Network Guru Member

    Well, I had an opportunity to deploy another remote WRV200 router. Now I have two working both with PPOE and Nat-Traversal IPSec. The difference between them is one does have a static IP the other one uses DDNS. All WRV200 are working with the 1.0.39 firmware, now.

    Apparently the DDNS is the key factor with the incorrect tunnel status reporting. After connecting to the static IP WRV200 the status shows C. In case of the DDNS connection the status always shows T (when the tunnel is working correctly).

    On the other hand, I'm unable to access the WEB page of any WRV200 with Nat-Traversal enabled through the IPSec tunnel. So, this issue seems to be related to the NAT-Traversal function.
  39. pepemosca

    pepemosca LI Guru Member

    I know is late, but did you got the firmware?
  40. pepemosca

    pepemosca LI Guru Member

    You lost me :)

    What's that?!
  41. Sfor

    Sfor Network Guru Member

    One of the gateway to gateway IPSec VPN tunnels can have the NAT - Traversal option enabled. It's purpose is to make a IPSec VPN connection through a NAT without IPSec passthrough ability.
  42. pepemosca

    pepemosca LI Guru Member

    Oh, I think I get it.
    Is not like now I can give a conference about the subject... But I get the idea.

  43. gyle

    gyle LI Guru Member

    Hi All,

    I noticed a strange thing recently. The WiFi bandwidth is limited to roughly 10 Mbps. I tried with two different adapters, a laptop with Intel chipset and a RaLink USB pen but it behaves the same. I also tried to play with encryption settings (as I thought it might be processing power issue - I use maximum lenght WPA2 key) but it didn't help either.

    Any idea? I just guess that it is 1.0.39 specific altough I am using this version since it has been released.
  44. pepemosca

    pepemosca LI Guru Member

    Ideas? Just do a hard reset of the router and try again :)
    Any new wireless devices? Any new interference?
  45. gyle

    gyle LI Guru Member

    I have done that :)

    No, no new wireless devices. Interference? Well... hard to be sure but I don't think so.
  46. Piteko

    Piteko Guest

    Where can i find the download link for the latest firmware to the WRV200?
    I can't find it in cisco home page!?
  47. pepemosca

    pepemosca LI Guru Member

  48. tv1000

    tv1000 Guest

    it surely did for me, thank you!

    Best Regards,
  49. pepemosca

    pepemosca LI Guru Member

Share This Page