1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Linksys RVS4000 Firmware v1.2.10 Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Sep 3, 2008.

  1. Toxic

    Toxic Administrator Staff Member

    RVS4000 Firmware v1.2.10 Release Note 9/02/2008

    *******************************************************************************
    * Please reset the router to factory default settings after firmware upgrade. *
    *******************************************************************************

    Changes:

    1. Fixed the issue that Vista QuickVPN Client cannot connect to RVS4000 when the Client is behind a NAT device.
    2. Fixed the issue that QuickVPN Client cannot re-connect to RVS4000 without rebooting the router after the tunnel is up for an extended period.
    3. Fixed the issue that FTP does not work when MAC Clone is enabled.
    4. Fixed the issue that FTP file transfer will slow down significantly when there is a large number of small-sized files invloved.
    5. Fixed the issue that IP Based ACL cannot regulate FTP service.
    6. Fixed the issue that Port Forwarding does not work when IPS is disabled.
    7. Fixed the issue that Port 443 cannot be forwarded to a LAN PC, when QuickVPN or Remote Management is using the port. With this firmware, configuration leading to a port conflict will result in a pop-up warning.
    8. Support port forwarding to multiple VLANs/subnets.
    9. Fixed the issue that VPN tunnel cannot reconnect automatically when the DDNS WAN IP address of RVS4000 is changed by ISP.
    10. Fixed the issue that VPN Tunnel Name with a space character will lead to tunnel not able to connect.
    11. Fixed the issue that System Up Time displayed incorrectly in SNMP browsers.
    12. Fixed some SIP ALG issues that led to one-way audio.
    13. Removed the support for NAPT-PT. RVS4000 will use 6to4 tunnel to connect IPv6 hosts in the LAN to IPv6 hosts in remote IPv6 islands.
    14. Updated the IPS Signature to version 1.38.
    15. Support ProtectLink Gateway, which requires a subscription.
    Known Issues:

    1. There is a known issue with Windows XP SP2 Firewall - ICMP packets are always dropped by the Firewall when the Firewall is enabled. The issue will cause the QuickVPN Client not being able to establish a tunnel with the remote QuickVPN Server successfully. Microsoft has released a patch to fix this issue. Once you install the patch, the issue should be resolved.http://support.microsoft.com/kb/889527/en-us
    2. Saving the configuration of port forwarding or port triggering rules will cause the router to restart the firewall module, which can cause a temporary lockup of the router for 10-15 sec.
    3. QoS Rate Control has no effect when IPS is disabled.
    4. DHCP Relay is not supported when when multiple VLANs are created.
    5. DHCPv6 Server may stop working sometimes, but it will not affect IPv4 hosts in the LAN.
    6. IPS cannot block eMule 0.48a.
    7. Number of VPN Tunnels Available may show incorrectly in the VPN>Summary page.

    http://www.linksys.com/servlet/Sate...86741396B170&displaypage=nodata#versiondetail
     
  2. Toxic

    Toxic Administrator Staff Member

    Please feel free to post your findings on the new firmware here. it can help with development on future releases. if you have an issue, please give as much info as possible WAN type, MTU setting, what services running on PCs etc,etc. and whether you can replicate the issue time and time again, with clear instruction on how to replicate it.

    PS: make sure you reset to factory defaults after upgrade!
     
  3. linksys_rvs4000

    linksys_rvs4000 Addicted to LI Member

    Definitely an improvement! I just updated and reconfigured my router after reseting. Feels a bit snappier and activated IPS doesn't slow down the internet anymore.

    A bug: The checkmark in "port range forwarding" won't activate. After each reload/reboot all are unchecked. I haven't tested if this is only a interface bug or if the problem is somewhere deeper.

    I have no experience with long term stability, but this firmware version seems to be quite good. :)
     
  4. Toxic

    Toxic Administrator Staff Member

    can you confirm that if your using any proxy cache or antivirus software that it ignores your IP of your router. I have known and seen issues like that if software that affects the browser. are you using Firefox or MSIE?
     
  5. soparanoid

    soparanoid Addicted to LI Member

    cool. i just bought the RVS4000 a few days ago.

    looking forward to throwing a few security questions out there.
     
  6. JoeQca

    JoeQca LI Guru Member

    IPSec VPN Down

    I feel bad to write this but the new version 1.2.10 has broken the point to point vpn between 2 RVS4000 units. After spending some time setting them up again I reverted back to 1.1.14 and without touching any settings the vpn's came right back up again. Linksys please test before releasing out. The units I have setup are only doing point to point nothing else…..
     
  7. Toxic

    Toxic Administrator Staff Member

    as I said before:

    if you just post something is not working how are linksys meant to replicate the issue? you said you did not touch any settings yet how did the vpns work if you reset to factory defaults?

    can anyone else confirm VPNs are now not working?
     
  8. Ironwalker2

    Ironwalker2 LI Guru Member

    Can this be confirmed by anyone with a fat pipe or optimum online boost 40mb download?
    Because OOL Boost will not work with this router and IPS on from DSLReports FAQ.I would love to use it if it does work, but, I do need all my bandwidth max.

    Can it be confirmed at all by anyone?

    Thank you
     
  9. uffez

    uffez Network Guru Member

    Tring this router again, feeling it is less "buggy" now and with reasonable performance. But, when trying to open ports for SIP it simply cannot be done. The port is not opened and the incoming call fails consistently. Have tried single ports as well as port ranges - but the result is the same. Tested with "shields-up". Something happens though, since the port changes from "stealth" to closed - but it is not opened.

    Am I doing something wrong here?
     
  10. Toxic

    Toxic Administrator Staff Member

    have you reset to factory default?

    to all:

    if there is a problem, we need to identify it by giving as much information, but please dont just report that "something doesn't work", this give no indication how to replicate an issue.
     
  11. uffez

    uffez Network Guru Member

    Yes, I started with doing a reset. I believe I explained the issue enough - don´t you? What more can I say? Are there other ways than the ones I mentioned to set port forwarding? IPS is active, Firewall is active too.
     
  12. JoeQca

    JoeQca LI Guru Member

    More Information

    Toxic, you are 100% correct, I apologies for leaving such a loose post. I will spend some time this weekend, re-flashing and resetting to factory defaults are re-configure both units to connect to each other. I will post my findings...
     
  13. uffez

    uffez Network Guru Member

    Regarding my port-forwarding - something is at least 50% correct in the sense that the state truly changes (when checking with "shields up")... More investigation follows...
     
  14. Toxic

    Toxic Administrator Staff Member

    what type of wan are you using? cable? adsl?
     
  15. uffez

    uffez Network Guru Member

    Fixed now, proves I´m a beginner with this router... Had missed to define static IP in the router for the SIP-SPA3102... Thought it wasn´t necessary - but after defined it appears to be working even though "shields-up" still say it´s closed...
     
  16. Toxic

    Toxic Administrator Staff Member

    Please note.

    if you port forwarding, it is recommended (I would say you must) to use static IPs since if all your devices get DHCP IP assigned addresses, then they may get a different IP and thus the port forwarding will not work for that device.
     
  17. uffez

    uffez Network Guru Member

    Well, yes - I had defined static IP inside the box - wasn't aware I had to set it also in the router...

    Apart from this - it now seems to work quite OK for me.... Want to see long-duration stability, too... So far less than a day's up-time....
     
  18. uffez

    uffez Network Guru Member

    More questions:

    - Will the router act as DNS? When setting the static IP I believed that would also allow for enabling to resolve those hosts when eg accessing them through web-services (I have a few hosts with web-support). But, the hostnames are not resolved. Do I have to set-up a local DNS server on the LAN? Have tried to set the router as DNS1 on the LAN-tab, but that didn´t help.
     
  19. uffez

    uffez Network Guru Member

    Have set-up my wireless router as DNS-server and DHCP-server. Works excellent so far.
     
  20. cmajewsk

    cmajewsk LI Guru Member

    Finally!

    Well, I loaded this firmware, reset to factory defaults and I must say I am impressed! My overall upload and download speeds have definitely increased, and FINALLY FTP is WORKING!!!
     
  21. uffez

    uffez Network Guru Member

    I just want to say - so far so good... Not a single hickup for a week now...
     
  22. linksys_rvs4000

    linksys_rvs4000 Addicted to LI Member

    I'm quite satisfied with the new firmware. Everything I need works quite well (at least compared to the older firmwares).

    The only hassle I found: You MUST use Windows and Internet Explorer. Otherwise you cannot configure some settings. They should make it Firefox and Safari compatible. Every time I want to change something, I have to fire up Windows... :thumbdown:
     
  23. uffez

    uffez Network Guru Member

    OK, well the few things I have fiddled around with has been done through Firefox and Safari. Didn´t note any problems...
     
  24. tony4d

    tony4d LI Guru Member

    Cisco 871:

    router01 uptime is 2 weeks, 2 days, 21 hours, 26 minutes
    System returned to ROM by power-on
    System image file is "flash:c870-advipservicesk9-mz.124-15.T6.bin"

    Can anyone beat that? :)
     
  25. uffez

    uffez Network Guru Member

    Nope - not yet... So far only: System up time: 10 days, 21:27:37
     
  26. micrisc

    micrisc LI Guru Member

    WOW, after 2 years having a beta quality router I finally feel like I didn't totally get ripped off. I am glad I kept these things on the shelf. Maybe I can use them for something useful now.
     
  27. micrisc

    micrisc LI Guru Member

    Take that back. Anyone have PPPoE connection issues? I get this.....

    Dec 31 19:08:19 - Plugin pppoe loaded.
    Dec 31 19:08:19 - PPPoE Plugin Initialized
    Dec 31 19:08:19 - Plugin pppoe called.
    Dec 31 19:08:20 - pppd 2.4.1 started by root, uid 0
    Dec 31 19:08:20 - Sending PADI
    Dec 31 19:08:22 - Connecting PPPoE socket: 00:00:00:00:00:00 0000 0x427d8
    Dec 31 19:08:22 - Couldn't get channel number: Transport endpoint is not connected
    Dec 31 19:08:22 - Doing disconnect
    Dec 31 19:08:22 - Exit.

    BTW, i didn't update the time yet ;)
     
  28. djcoolmax

    djcoolmax Network Guru Member

    I just flashed with the new firmware and connected to the Thomson ST536V6 (bridge mode). So far so good. p2p speeds have been acceptable....
     
  29. linksys_rvs4000

    linksys_rvs4000 Addicted to LI Member

    PPPoE works for me. Have you reseted the router after updating the firmware? And also make sure you use IE6/7 for configuring.
     
  30. micrisc

    micrisc LI Guru Member

    I reset to factory defaults before and after flash upgrade. When I click on connect it does nothing. real strang. Almost like the pppd is messed up. I may try reflashing it
     
  31. micrisc

    micrisc LI Guru Member

    tried reflashing and it still does it
     
  32. donathome

    donathome LI Guru Member

    1.2.10 seems to do the trick for my setup

    Upgraded one unit this morning. So far I have an up time of about 1 hour, but FTP is working (for the first time ever) and HTTP speed is at the full link speed of 15M (both up and down). If course I had to turn IPS off to get the full speed, but that is ok. I will let it go for a week and (if all goes well) update my 2 others.
     
  33. uffez

    uffez Network Guru Member

    System up time: 13 days, 17:03:25

    Seems rock solid to me - my other router normally restarted spontaneously once a week... But, I´m using it in a low performance home environment so it should for sure not have any problems - with a 24 Mbit ADSL only...
     
  34. nitehawke

    nitehawke LI Guru Member

    I posted a scathing review of the last beta firmware...and was extremely skeptical of this 'final' release. However I installed it about 48 hours ago and my router has been running rock solid since.

    No reboots needed, P2P performance is dramatically better (router does not grind to a halt and finally require a reboot if you open too may P2P sessions).

    Overall, I'm impressed with this release so far.

    One question for folks out there: has anyone proven that the Vista QVPN issue (when Client is behind NAT) has truly been fixed in this release (as noted in the release notes)? I just tried connecting to my RVS4000 running v1.2.10 firmware with QVPN version 1.2.11 and my workstation got stuck at the 'verifying network' stage. I was tethering from a mobile device when attempting to connect (my IP was 192.168.0.2--so I'm fairly certain I was behind NAT).

    Will keep running router and report back. If this new firmware truely is more stable, I'll be very happy--purchased 5 RVS4000's over a year ago to use in small business offices--they've been useless thus far.
     
  35. Whomiga

    Whomiga Addicted to LI Member

    RVS 4000 - Unable to get DHCP value from WAN

    Last version that would actually get a WAN value from the Cable Modem is version 1.1.11 - Tried 1.1.14 and 1.2.10 - Neither was able to get a WAN DHCP value from the Cable Modem.

    Cable Modem - D-Link DCM202
    RVS4000 with Default Factory Settings

    Version 1.1.11 is giving me lots of problems, so I really need to use a later version if it can possibly fix other stuff.
     
  36. tester0101

    tester0101 LI Guru Member



    same problem here. no wan from the modem always down.
    My router RVS4000 was working on firmware 1.1.12 but there was somes errors i have to unplug and replug the power to work. i upgraded today to version 1.2.10 upgrade was successful but no wan. internal DHCP fine no wan from my MODEM i tried 2 providers. i unplug the RVS4000 and i tried with one dlink wan and internet work great replug the rvs4000 nothing no wan. now i am searching for firmware 1.1.14 if anyone has it or has link let me know.

    thank you


    i have another router working great with version 1.1.14 (VPN and network) for that reason i am searching for 1.1.14 firmware.

    thank you
     
  37. vpnuser

    vpnuser LI Guru Member

    Did you reset the router to factory default settings after firmware upgrade?
     
  38. alphawolf

    alphawolf Addicted to LI Member

    Before you ask, yes I set to factory defaults... both from web interface and hardware reset button... before and after the upgrade.

    From IE 7, I tried to set the WAN with a static IP. I click "Save" and nothing happens. I notice in the bottom left corner of IE there is an error -- "checkKey is undefined" on line 321. Sure enough, if I check the source of the web page, there is no 'checkKey' function on this page. There is on OTHER pages, but not this one.

    Then, I try to change the LAN IP address, and turn off DHCP... click the "Save" button, and again nothing happens. There is again an error reported by IE -- this time "msg_lan_change is undefined" on line 536.

    Has nobody else tried to change their WAN or LAN IP's?
     
  39. tester0101

    tester0101 LI Guru Member


    Yes i reset the router. and even i flash the version 1.2.10 again reset the router every was successful. still no wan at all i have DHCP and no wan so i am losing time with this router. todays i will buy another one sonicwall.

    if someone has the firmware 1.1.14 please post it

    thank you
     
  40. Toxic

    Toxic Administrator Staff Member

    Are you able to get some sort of packet capture on the WAN port of RVS4000 at all?

    Also could you reboot your Cablemodem first of all then your router with the new firmware.
     
  41. tester0101

    tester0101 LI Guru Member


    0 wan packet. always down.

    i reboot the cablemodem 3 times also i called my provider and they ping the modem and it's ok. i plug one small dlink router and i worked as soon i plug the power evreything up and running. there is problem with the firmware 1.2.10 itself. i explain. i have an old firmware here 1.1.9 i upload it to the router and it work the wan working i download the 1.2.10 wan is down.

    can you provide me the firmware 1.1.14 for the RVS4000. i am searching for it if i don't have the firmware by today i will buy sonicwall TZ150.

    thank you.
     
  42. alphawolf

    alphawolf Addicted to LI Member

    I have v1.1.14 saved still -- how would I get it to you?

    Also, has anyone checked out whether they can set a static IP on WAN? Or turn off DHCP on LAN? I detailed the problem I was having a few posts back.

    Thanks, Mike
     
  43. PeteSL

    PeteSL Addicted to LI Member

    I was able to set both static IP on the WAN and turn off DHCP on the LAN with IE7. However, while the 4000 was showing everything as happy (WAN and LAN up and active), The router could not access the WAN. Pings and trace routes generated in the diagnostic page on the router confirmed that it could not access the next router upstream (the 4000 is using a public IP). Downgrading to 1.1.14 fixed the problem (available from the Linksys FTP site).

    Pete
     
  44. tester0101

    tester0101 LI Guru Member

    THANK YOU for your reply. i found 1.1.14 firmware and i downgrade rvs4000 to 1.1.14. and everything is up (wan-dhcp-vpn). no problem at all.
     
  45. RVS 4000 - Unable to get DHCP value from WAN

    Hi

    I have a:

    Linksys RVS4000 with firmware 1.1.14

    Thomson THG540 (cable modem provided by my ISP, ZON-Portugal)

    the linksys RVS400 is unable to get a WAN DHCP value from the Cable Modem.

    I also have a linksys BEFW11S4 (firmware 1.43.3z ETSI, Nov 27 2002) and with it I do not have any problem getting the WAN DHCP value from the Cable Modem.

    Should I go back (1.1.11) or forward (1.2.10)?

    Any help will be greatly appreciated, thanks.
     
  46. colakork

    colakork Guest

    I have the RVS4000, and I tried upgrading from original firmware (was it 1.1.12) to 2.2.10. I can say that it went straight to hell, and I had to download the "reset firmware" thingy to get things running again.

    This was because the RVS4000 would not get the WAN ip and dns-servers. I tried connecting the rj45 plug directly into my computer, and it worked like a charm. Also, using another router worked (they were both getting their wan ip's). So this is definitly another bug in the firmware.

    So is there any fix for this, besides downgrading? I would really like to get my p2p-applications running properly (does the new firmware support more connections than the last one, with what, 50 connections max do?).
     
  47. WidgetGuy

    WidgetGuy Guest

    Firmware upgrade not working

    I too am having problems with the v1.2.10 firmware after the upgrade from v1.11 to the new version. I restored factory defaults and the RVS4000 was unable to find a DHCP address on the WAN side. I even tried a static address on the WAN that was working with v1.11 previously. It just wont pass through from the LAN to the WAN wither way. The only thing I can do is downgrade at this point. Is there a patch yet?
     
  48. AcesHigh

    AcesHigh LI Guru Member

    I got a Speedtouch 546i ADSL modem in bridged mode and a RVS4000 with the PPPoE login details. Have run the original 1.1.11 firmware for quite some time but due to some VPN issues I wanted a update on the firmware. I upgraded the OS/Firmware to 1.2.10, did the factory default restore and set it up with the same settings that worked before. Result: No working PPPoE connection

    Tried to restore my backup of the 1.1.11 config but this didnt work either. Solution: Had to run the Resque restore program and put the old 1.1.11 firmware back.

    So now im back at the 1.1.11 firmware, turned off ALL functions on the RVS4000 and set a Cisco 877 router in DMZ (wich i cant direct connect to the ADSL either) using the Cisco as VPN server and firewall for the rest of my network... It works but was a really costly experience :frown:
     
  49. AcesHigh

    AcesHigh LI Guru Member

    I forgot to test something more so i did another go at the 1.2.10 firmware.

    Scenario:
    I set up a Linksys BEFSX41 router, connecting with the Speedtouch modem in brigde mode using PPPoE and got a network going. Then I put the RVS4000 with freshly installed 1.2.10 firmware on the inside using Dynamic IP on the WAN interface and a new different LAN network segment on the RVS4000's LAN ports.

    Result:
    The RVS4000 couldn't even get a IP on the WAN port from the perfectly working BEFSX41's DHCP server...

    Conclusion:
    Anyone telling me that this firmware (1.2.10) is working nicely on ALL the RVS4000 routers can keep on dreaming, this is NOT a stable firmware at all. At least not on ALL the RVS4000 routers out there. I hope Linksys/Cisco will do better than this in the future, because this "betatesting" of firmware/OS on the public users are crap :thumbdown:
     
  50. Toxic

    Toxic Administrator Staff Member

    Guys, I am curious....

    Have any of you contacted Linksys and reported the problem to linksys reference the new firmware and the WAN issue? without reporting it to the official sources, unless linksys read these forums, next to nothin will be done about it and a solution will not be found.
     
  51. AcesHigh

    AcesHigh LI Guru Member

    Well Linksys have a support/community forum where they, amongst others, advertise their new stable firmware's. They do this on all their different hardware. I take (took) it for granted that they read the reply's on those posts. However it doesn't seem that they do, at least they only reply to the "easiest" problems people got, and their replies seems to be rather basic like "HAVE YOU TRIED THE RESET BUTTON" or stuff like that. If you check the support/community forums at www.linksys.com you will find huge amount of complaints over "beta" versions of their firmwares wich never have been answered by any of the responsible people at Linksys at all... But to answer your question Toxic, YES i have reported ALL my issues over Linksys products.

    I have used most of the different Linksys routers and accesspoints available for the scandinavian marked for a long time, some of the older ones with great success and some newer ones with less success. The reason that I still am using Linksys products is that those products that works actually works better than they themselfs would think. But the main thing is that it seems like Linksys are pushing beta releases of firmware out to the public without thinking of that most of the public doesn't have the knowhow or patience to deal with some of their crappy firmwares. :thumbdown:

    Im sorry for this long post, but this is really starting to bug me and it really doesn't help complaining to my wife :wink:
     
  52. Toxic

    Toxic Administrator Staff Member

    Could you give me the ticket number you raised with Linksys Tech Support so I can then forward this onto the powers that be.
     
  53. Stray_Bullet

    Stray_Bullet Network Guru Member

    heh, wish I could dl it...

    I got the ips signature but the firmware just will not download... I tried explorer, filezilla, fire ftp...

    Using 1.2.06 now.

    Oh man... I have no problem with ftp, except linksys.
     
  54. stacker

    stacker Guest

    Hi, I have experienced ftp time-outs at the end of long transfers (30+GB) Firmware 1.2.10 fixed this problem I guess, all acive connections work good. But now pasv connecting clients get refused (err421). The strange thing is that exactly this pasv using client had no problems at all when I was on fw 1.1.14 !
     
  55. Jamesss

    Jamesss LI Guru Member

    Hi,

    The first problem I encounter now after upgrading the latest firmware 1.2.10 is that DDNS is not working. It cannot connect to DDNS site.

    Anyone experiencing this behavior? thanks
     
  56. Toxic

    Toxic Administrator Staff Member

    anyone got a ticket number from Linksys Tech Support for their WAN issue?
     
  57. Toxic

    Toxic Administrator Staff Member

    Can anyone confirm that teh WANissue is due to not setting up the MAC Address cloning again? when you reset to factory defaults you will loose any mac address cloning. you may need to re add the cloning of the mac address (possibly)
     
  58. tony4d

    tony4d LI Guru Member

    Toxic, I know this is off topic and you can delete if you want, but I feel I owe it to the community.

    Guys, once again, if you can afford it, go with a Cisco 870 series router. Not one hiccup since I got it fully configured (Cisco 871 with adv ip svcs):

    router01 uptime is 6 weeks, 4 days, 6 hours, 1 minute
    System returned to ROM by power-on
    System image file is "flash:c870-advipservicesk9-mz.124-15.T6.bin"

    I struggled with the horrible quality that is the RVS4000 for almost 2 years!
     
  59. PeteSL

    PeteSL Addicted to LI Member

    In the case of the router not talking to the WAN interface when set for a static IP, MAC cloning is not the issue. I have not talked to Linksys because this was a customer production router which had to be replaced immediately. Only now have I been able to run any extensive tests. Results:

    Hardware Reset to factory defaults.
    Configured static IP address for WAN.
    Pinged upstream "router" which is a working IP device that responds to pings. I pinged from the web interface and from a LAN-attached PC. No response and no WAN activity on the RVS4000's front WAN LED.

    Pinged from the upstream "router" which showed WAN activity on the RVS4000's front WAN LED. No response from the RVS4000 regardless of whether Block WAN Requests was enabled or not.

    No success by turning off either (or both) Firewall or IPS in any of the tests.

    Looks like the iptables is screwed up when setting the router to a static WAN IP address. So now this brick sits in its box waiting for Linksys to try and fix their firmware, again (hopefully less than a year).

    Downgraded RVS4000 to 1.1.14 and WAN works as advertised. Definite issue with 1.2.10.
     
  60. Toxic

    Toxic Administrator Staff Member

    I have been advised but Linksys Dev team that no one has reported to Linksys Tech Support this issue. without them directly consulting the customer one a one to one basis, tell me how exactly are they to replicate your issue?

    I suggest you raise a call with linksys, give me the ticket number then i'll get the guys that handle the RVS4000 to contact you.

    without them fully being told via their tech support nothing will happen. I have told everyone that has this issue to report it. if you cannot be bothered to report an issue to the correct support, then there is really no point in posting any messages at all now is there?
     
  61. rgould

    rgould LI Guru Member

    i must admit, every time a new revision comes out i come here and you all moan and complain and cry. my 1.0.15 firmware keeps on plugging along. i dont have issues with ftp, and despite what the smallnetbuilder.com tests indicate, i seem to get more than 16Mbps down (last i checked i was getting 25Mbps from comcast). yes, i have the IPS turned off. and i also seem to be able to get more than the 48 simultaneous connections. the admin page works with a mac/firefox/safari, and vonage doesnt cause it to crap-out either (like it did with the 1.1.14).

    can anyone convince me that i need to move forward?

    does anyone want/need a copy of my 1.0.15 firmware?
     
  62. micrisc

    micrisc LI Guru Member


    I have tried many time using many different methodes to report the bug with this router. Every time I do linksys tells me they do not support the rvs4000. Maybe this is why noone can give you a ticket number. If you dont believe me, try it yourself on there website. It will tell you this router is not supported by linksys, please contact the reseller.
     
  63. micrisc

    micrisc LI Guru Member

    I bought it 2 years ago specificly for the IPS functionality. If they can't get all the features working don't advertise it with those features. The piece of junk sits on a shelf and I now use an IPCop router to act as my IPS firewall. Plus side is it also allows me to use VPN, Content filtering, etc. and is much faster. Needless to say I have not bought a linksys product since. If I need DD-WRT I use another brand like buffalo which also work much better.

    linksys = :thumbdown:
     
  64. rgould

    rgould LI Guru Member

    i can confirm turning on the IPS did not affect my download or upload rates on comcast (15Mbps/6Mbps).

    i was also mistaken, i am limited to simultaneous 48 connections.
     
  65. pwalhovd

    pwalhovd Addicted to LI Member

    RVS4000 problems with 1.2.10 firmware

    I have installed the latest firmware and the router does now not seem to freeze like before.

    Unfortunately there are two issues that are a big problem to me:

    1. Turning on IPS takes the speed down to just under 17MBps (I have a 30/30Mbps line). Turning it back off immediately takes the speed back to just under 30Mbps.

    2. The router a lot of the time does not answer incoming traffic on redirected ports. I have a web, mail and ftp server on the backside of the router, and sometimes it works but a lot of the times it does not. Then you try a little later and it all of a sudden works again.

    I am in a testing phase on this, but it seems like turning back on IPS has solved the port forwarding issue?
    So maybe I have to choose between being able to use my line to the full or have services available on the inside? If that is the case I cannot use this router.

    Does anyone have similar experiences?
    Yes I have reset the router after installing the firmware.
    Maybe I should install the firmware again and then reset again?
    I have read that it was an issue with the port forwarding earlier.

    Pleas help with any suggestions or experiences with similar problems.

    Thanks

    Petter
     
  66. pwalhovd

    pwalhovd Addicted to LI Member

    I can confirm that turning on IPS took my rate from 29.7 (30/30Mbps line) to around 17Mbps.

    So unless you have a faster line than that you should be fine.

    However faster than 17 still is a problem for me.
     
  67. cavementech

    cavementech Addicted to LI Member

    I am trying to connect to a RVS4000 with the current firmware using QVPN on Vista Ultimate. I am still unable to connect. It continues to stick on Verifying Network, then gives me the message "The remote gateway is not responding. Do you want to wait?" I am new to this, so i don't know what other information you need. I know Toxic asked for as much detail as possible. Can you maybe ask me questions instead because i am not sure what you need. Thank you for your help!
     
  68. Toxic

    Toxic Administrator Staff Member

    The IPS feature inspects every incomming packet. of course there will be a slowdown. this is the same on even the Cisco 800's that have a much better CPU.

    Unless you are going to upgrade to a serious IPS like mcAfee Intrushield hardware at 10's of thousands of dollars, you will always get a performance hit on inspecting packets.

    you could if you must have IPS setup a PC to do the IPS/IDS and this shold not effect the throughput too much.
     
  69. Toxic

    Toxic Administrator Staff Member

    Version 1.2.11 now offcially released

    The subject firmware was released to fix a SSL certificate issue, which could prevent users from activating the ProtectLink Gateway service. Other than that, it is the same as firmware 1.2.10.

    the new firmware is available from linksys.com
     
  70. thebeck

    thebeck LI Guru Member

    In response to Jamesss' Oct 13th, 2008, 5:56 am post, I am running into the same issue. My RVS4000 never connects to my DynDns.org service. After pressing the connect button, it just states "Please wait..." on the WAN Setup screen. I have confirmed from my DynDns.org online account that the RVS4000 is not registering itself with the DDNS service. In fact, the last time DynDns.org got anything from the RVS4000 was when it was running the 1.1.14 firmware. Is anyone else running into this 1.2.10 (and also on 1.2.11 after just upgrading to it) issue?
     
  71. Ironwalker2

    Ironwalker2 LI Guru Member

    Newest firmware and IPS work just fine with top tier OOL Boost.
     
  72. markbjohnson

    markbjohnson LI Guru Member

    Been running with dyndns service and RVS4000 1.2.10 just fine since it came out. No issues whatsoever. This is a PPPoE connection through a DSL modem.
     
  73. reQuorter

    reQuorter Guest

    Where I can download _OLD_ IPS Signatures?
     
  74. nitehawke

    nitehawke LI Guru Member

    I've also been using DynDns service and RVS4000 with no problems; I can recall it working just fine for me on the following firmware versions:
    1.1.14
    1.2.6
    1.2.10
    1.2.11 (currently in use)

    FYI: I'm using Comcast Residential Highspeed Internet.

    I had some pretty nasty things to say about the RVS4000 in the past, but since firmware v1.2.10, I haven't had nearly as many problems as I did before.
     
  75. minibit

    minibit Addicted to LI Member

    2 problems

    i have RVS4000 with
    Firmware Version: V1.2.11

    my problems are.

    when i try to enter an ftp i connect to the first page of the ftp i log and then i received timeout for everything i try to do.

    anyone know what do i need to do ??..

    and my second problem is that i need to block messenger for a range of ip, how can i do this ??

    thanks.
     
  76. minibit

    minibit Addicted to LI Member

    anone ???
     
  77. nitehawke

    nitehawke LI Guru Member

    1) Regarding FTP--check yor IPS settings to see if FTP packets are being analyzed. You might try disabling this.

    2) Regarding blocking IM--IPS has settings to block IP, but it applies to your entire population. Instead, you will need to determine what ports each IM appication uses and use ACL's in the Firewall to define each IM as a service, then deny access to tha service for the specified IP's. I think you have to enter each IP individually as I didn't see any option for IP range.
     
  78. cmajewsk

    cmajewsk LI Guru Member

    You may want to turn off MAC Address Clone:

    Setup>>MAC Address Clone>>Select Disabled and click on "Save Settings". It was what worked for me.
     
  79. Heritage

    Heritage Guest

    RVS4000 Firmware Version: V1.2.11 - 22mb DN CAP

    Recently I upgraded my home Comcast Residential to the new DOCSIS 3.0 Speed of 50 mbs down and 10 mbs upload.

    However, to my disappointment when IPS is enabled there is a cap on the down of 22 mb. Seems the upload is fine and even with all anomaly detection disabled . . . there still is a cap of 22 mb.

    When the IPS function is disabled. The router is fine at speeds of 52 Mbs down and 10.5 Mbs up.

    A while back I updated the firmware to Firmware Version: V1.2.10 so when connecting to a VPN on Vista Business everything would work (seems Vista Home premium had no issues; nor did my G5 Mac). So today I updated the firmware to Firmware Version: V1.2.11 and still there is a cap of 22mb down when IPS Function is enabled (even with each individual anomaly dections disabled).

    I have two RVS4000 (one in PA and one in IL at my brothers). Guess I will have to ditch these or . . .

    Fortunately I had my wireless Wireless-G Broadband Router WRT54G Firmware Version: v1.02.5 and it seems to have no issues with the new DOCSIS 3.0 Speed of 50 mbs down and 10 mbs upload.

    I would love to keep both my brother's and my RVS4000 as our main firewall(s) and VPN. Any suggestions? Anyone?
     
  80. linksys_rvs4000

    linksys_rvs4000 Addicted to LI Member

    Has somebody any information if they still work on the firmware for RVS4000 or has it been discontinued since the linksys->cisco change?

    There are still quite a bunch of known issues in the latest firmware. Are they planning to fix them or was this the last update?
     
  81. bighan1105

    bighan1105 Addicted to LI Member

    WRVS4400N firmware release V1.00.16

    do you have WRVS4400N firmware release V1.00.16? if yes, would you please share with me? thanks in advance
     

Share This Page