1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

linksys WRT54Gv3 router just stopped routing

Discussion in 'Networking Issues' started by peterius, May 8, 2008.

  1. peterius

    peterius Addicted to LI Member

    I have a WRT54Gv3 running dd-wrtv23 wsp2. Its an inner gateway, 10.0.1.1 to 10.0.1.0 network which it does dhcp/nat for. It routes outward to an apple airport base station which thinks the linksys is 192.168.1.5 or something, its a dhcp client outward. The apple airport is 192.168.1.1 and then out to the internet. There's no wireless involved, the radio on the linksys is off.

    Both the 192.168.1.0 and 10.0.1.0 are still working perfectly.

    The problem is that I went to sleep last night, woke up this morning and the linksys no longer has a WAN IP. I dreamt of flying mice last night so I thought maybe one chewed through the cord.

    I'm so annoyed because this took me so long to setup and get working the way I wanted it and its been working for 6 months. Literally NOTHING changed while I slept.

    The only hint I've gotten is that when I ping 192.168.1.1 from the 10.0.1.0 network I sometimes get, instead of destination unreachable: "Redirect Host(New nexthop: 192.168.1.1), interspersed sometimes with unreachables. But I get the feeling that this is just because the linksys has no proper netmask.

    The linksys routing table has two entries and not of its interfaces are on the 192.168.1.0 network. I used to do all this stuff when I was young, fix all this internet crap but now I just want it working and I've forgotten exactly what the routing table entries mean. Particularly like the interface. Does that mean thats the interface used to get to that destination network?

    Further, in DD-WRTs web control panel, I never understand the "Gateway" entry under "Router IP" under "Network Setup". I've tried it both as 192.168.1.1 and 10.0.1.1 and I can't remember which it is that's been working for 6 months.

    So any help would be great. Why did this break for no reason all of a sudden and how do I fix it. (I think there's also surge protectors on the ethernet to the airport meaning that its unlikely that a surge came through the airport and fried the linksys ethernet interface._
     
  2. peterius

    peterius Addicted to LI Member

    Forget it. In trying to fix the thing, I did ifconfig eth0 down and that made 10.0.1.1 inaccessible. So I reset it and its lost all my settings but at least its working now.
     

Share This Page