1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Linksys WRT54GX-v2 v2.00.20 (May 1, 2007)

Discussion in 'Linksys Official Firmware' started by Toink, May 25, 2007.

  1. Toink

    Toink Network Guru Member

    Latest WRT54GX-v2 v2.00.20 (May 1, 2007)

    Download the latest firmware HERE then select version 2


    Release Date : May 1st, 2007
    Current Firmware : 2.00.20
    Product PartNo : WRT54GX1v2

    1. Fixed UPnP vulnerability issue.
    2. Fixed Wireless Network Access GUI issue
    3. Modified UPnP device info.
    4. Fixed DMZ Host IP issue
    5. Fixed Router Port Forwarding Range issue


    WARNING!! This firmware is for version 2 of WRT54GX ONLY. Flashing your router with a firmware other than that for your model will kill it. You've been warned.
     
  2. bspape2

    bspape2 Guest

    I have a question about the file name for this download. All previous firmware updates for WRT54GX v2 have had "USA" in the file name. I noticed the latest version dated 05/01/07 for v2 has "EU" in the file name. Is it ok to use the "EU" file for a USA customer?

    The current firmware I am running is named:
    WRT54GX_V2_USA_2.00.19.bix

    The file available for download for v2 is:
    WRT54GX_V2_EU_2.00.20.bix

    Note: I have "United States" selected for country when viewing www.linksys.com
     
  3. Toink

    Toink Network Guru Member

    Yes it's safe to use the EU. They're actually inter-changable. With EU, you get 2 additional channels...

    TIP: if you wish to get to your wifi interface, type http://192.168.1.1/wifi.asp (or replace the 192.168.1.1 with whatever you are using.
     
  4. pifaffle

    pifaffle Guest

    DNS issues

    I have just added V2.00.20 and most seems to work OK. The version I was using before was fairly old.

    I have been left with one problem. This version does not appear to pass on the domain from you ISP and now my email does not resolve.

    The main domain is rogers.com, but a local sub-domain was associated with connection and this was used. Don't remember what it was, but it was rather long.

    settings on our email pop and smtp worked fine before, but not now. There seems no place to set a connection specific domain in dhcp on the router. I can't find anything, is there something I am missing?

    Rogers will not provide support if you are not using a single windows pc for the connection.

    Any help would be appreciated.

    Running ubuntu, windows vista, mac osx. no joy on any platform.
     

Share This Page