1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Loading 3rd-Party Firmware from V4.00.7

Discussion in 'Linksys Official Firmware' started by joep96tt, Jul 20, 2005.

  1. joep96tt

    joep96tt Network Guru Member

    Hi there - has anyone tried to install 3rd-party firmware on a WRT54G that's running the official V4.00.7 Linksys firmware ? I used to be able to flash firmware at will, but since installing V4.00.7 I cannot install any other firmware other than Linksys V4.00.7 (the firmware upgrade fails), regardless of whether I try from the WRT54G's web page or via TFTP. Any ideas ?

    Regards
    Joe
     
  2. bigbird090

    bigbird090 Network Guru Member

    I also get the same problem. I've tried Alchemy and HyperWRT. Luckily, the installation fails but the router still works fine.
     
  3. jagboy

    jagboy Network Guru Member

    look int he dd-wrt v23 progress report and im that thread should be a dd-wrt v23 flash with that. then flash fomr ther to what ever firmware. i just encountered this problem. linksys firmware is starting to be a pain in the but.
    -jag
     
  4. joep96tt

    joep96tt Network Guru Member

    Thanks jagboy! I couldn't find any v23 downloads, but your v22 pre-final5 did the trick. Linksys V4.00.7 GONE (& never to be reinstated).

    Regards
    Joe
     
  5. jagboy

    jagboy Network Guru Member

  6. joep96tt

    joep96tt Network Guru Member

    Hmmm, just had a brief look at the dd-wrt prefinal5. I'm rather inclined to keep it :)

    Cheers
    Joe
     
  7. bigbird090

    bigbird090 Network Guru Member

    no go

    I've tried the firmware listed in the post, but i still get a "upgrade failed" dialog. By the way, i'm using v4 of the WRT54G router.
     
  8. bigbird090

    bigbird090 Network Guru Member

    i'm actually using v3
     
  9. joep96tt

    joep96tt Network Guru Member

    I did take the precaution of resetting the router back to factory default settings (by holding the button on the back in for 10secs) & then wiping out the password before attempting the upgrade, although the firmware didn't seem to let me wipe the password out (when the page refreshed there was still a password there).

    Cheers
    Joe
     
  10. bigbird090

    bigbird090 Network Guru Member

    fixed

    I was able to flash this after all..... i had to download the firmware auto-upgrade executable from linksys (which reverts the router to an older firmware), then upgrade to alchemy.
     
  11. __nbd

    __nbd Network Guru Member

    These problems seem to be specific to Alchemy and HyperWRT (as well as maybe some other Linksys-based stuff). The addpattern tool that OpenWrt has been using for quite some time now generates images that can be flashed from the Linksys v4 firmware without any problems. Maybe the other firmware projects should release some updates :)
     

Share This Page