1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

LuCI remains after OpenWRT to Tomato

Discussion in 'Tomato Firmware' started by Menkatek, Dec 22, 2013.

  1. Menkatek

    Menkatek Network Guru Member

    I moved to Tomato Toastman from OpenWRT after I found it was too slow due to kernel 2.6 (WRT54G v2.0). I like Toastman a lot but when I load in the web browser, it loads the LuCI web configuration and stays loading until it times out. The only way to access the web admin is to load a specific page. I tried clearing NVRAM (via "mtd-erase -d nvram" and web admin) and even flashed the firmware twice. What can I do? Thank you for any assistance.
  2. koitsu

    koitsu Network Guru Member

    It's fairly obvious the router is not changing firmwares. Please contact the OpenWRT folks (they have a forum) and ask them how to switch away from their firmware to another firmware. You may have to resort to using TFTP during the very short boot_wait phase, followed by 30-30-30. Good luck.
  3. jerrm

    jerrm Network Guru Member

    You never actually see a LuCI page? Only the browser loading message? Have you tried another browser or clearing the cache?
  4. Mate Rigo

    Mate Rigo Serious Server Member

    It is not because the router does not change fw.
    It is caused by some kind of symlink for the address
    Quick workaround is to use anothe browser, or to use privacy mode.

    I experienced this first hand myself.

    I'll come back later with an explanation to solve this permanently.
  5. Victek

    Victek Network Guru Member

    clear browser history and then it's solved..
    darkknight93 likes this.
  6. RMerlin

    RMerlin Network Guru Member

    Did you assign a static IP to your computer? Toastman's ships with DHCP disabled out of the box.
  7. Mate Rigo

    Mate Rigo Serious Server Member

    I am back with a workaround as promised. This does not require to clear browser history.

    If you are on chrome:
    1. Add the following URL: view-source:
    2. Hit enter
    3. You'll see some html code, which has a redirect to the former openwrt admin page
    4. Hit F5 for reload
    5. The redirect should be deleted now.
    Now you are able to use the address normally.
    Last edited: Dec 23, 2013
  8. Menkatek

    Menkatek Network Guru Member

    Thank you all for your responses! What a great community. I failed to mention that I cleared the browser cache once but it didn't fix the problem. So I tried loading the web admin today and now it's working. Thank you again!

Share This Page