1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MiniUPnP & UPnP Port Works

Discussion in 'Tomato Firmware' started by feynman, Jun 24, 2007.

  1. feynman

    feynman Network Guru Member


    I tried to use the WinXP command line tools MiniUPnP (miniupnp.free.fr) and UPnPPW (www.upnpworks.alcidelic.com) to set port forwarding in my WRT54G v2.2 with Tomato 1.07.
    Although the port forwarding seems to be correctly done (it shows up in WinXP and in the router's "UPnP Forwarded Ports" page) it is not really active and I cannot access the net using the opened ports unless I set the port forwarding manually, without using UPnP.
    A similar problem also happens with Xlight FTP Server. It reports the router as supported, opens up the ports (they really show as opened), but the FTP server cannot be accessed from outside my LAN.
    Has anyone run into this kind of problem? Does anyone know what could be wrong?
  2. roadkill

    roadkill Super Moderator Staff Member Member

    I got UPNP working flawlessly Azureus have no complaints and every application I used that has UPNP Support worked without problem.
  3. GeeTek

    GeeTek Guest

    Please tell us that you have forgotten to do an nvram clear after flashing.........
  4. feynman

    feynman Network Guru Member

    I did a nvram clear when I first flashed my router with Tomato. I never did that again when upgrading Tomato versions.
    Other software I use (an eMule mod, uTorrent and ApexDC++) all set port forwarding correctly and work ok. I only had problems, so far, with the tools I mentioned. I think I'll try to clear nvram again and see what happens...

    EDIT: Did an nvram clear and reconfigured my Tomato 1.07. Everything stayed the same. Port forwarding is added by Xlight FTP (for instance) but I cannot connect to my running FTP server from the outside. If I add the port routing manually in Tomato, everything is ok!
    Is it possible that Tomato isn't compatible with Windows UPnP implementation? The 2nd vbs script here http://www.knoxscape.com/Upnp/NAT.htm also opens ports using uPnP but it doesn't seem they are really open (I can't connect).
    I'm really puzzled!

    EDIT 2: Noticed what might me a small bug, probably unrelated. In the "UPnP Forwarded Ports" page, pressing "Delete All" doesn't seem to delete the rules added by the apps I mentioned. Pressing "Save" and then "Refresh" makes the rules appear again. Deleting by pressing the red X does work ok!
  5. roadkill

    roadkill Super Moderator Staff Member Member

    you got xp firewall on?
  6. feynman

    feynman Network Guru Member

    I have Win XP firewall disabled.
    Thanks for trying to help!
  7. feynman

    feynman Network Guru Member

    My problem remains... :(
    I tried everything except reverting to Linksys stock firmware.
    Could someone try with Xlight FTP (www.xlightftpd.com) and see if they have the same problem? (Ports reported as open but seem not to be. Manual port forwarding makes everything ok.)
    Other software such as MiniUPnP (miniupnp.free.fr) and UPnPPW (www.upnpworks.alcidelic.com) give the same results but uTorrent and Azureus are ok.
    Should I assume the problem lies with errors or limitations of software implementations?
  8. roadkill

    roadkill Super Moderator Staff Member Member

    I think the problem lies within your chosen programs I know UPNP is naturally a flaky feature but I got it running and working with Tomato with several non standard gadets (XBMC,Symbian Phones,WM5)
    I think you should seek support for your programs since UPNP is obviously working like you said
    I personally haven't come across a compatibility issue with UPNP on Tomato versus Linksys original firmware.

    If you do eventually find the root cause please update the thread so others could benefit.
  9. feynman

    feynman Network Guru Member

    I feel like I'm flooding this thread!... :)

    Has anyone ever suceeded in opening ports via UPnP using the interface supplied in WinXP? (Internet Gateway/Connection icon in Network Connections)
    I tried it and got the same bad results I mencioned above (ports look as opened in Tomato but in reality are not).

    Could someone please verify whether this is expected behaviour or is just something gone wrong in my config?


Share This Page