Monitor mode not working in Tomato - prism0 interface does not appear

Discussion in 'Tomato Firmware' started by Groovemaster, Nov 26, 2012.

  1. Groovemaster

    Groovemaster Serious Server Member

    Hi,

    I am trying to get monitor mode working on Tomato, by giving the commands

    wl promisc 1
    wl monitor 1

    It works fine in the v1.28.0023 Teaman-SDHC-VLAN-SNMP-PPTPD ND VPN build for the WRT-54GL. The prism0 interface appears in the ifconfig list, like it should, and can be used to capture 802.11 packets. Also on OpenWRT and DD-WRT it works.

    However, on all other Tomato builds that I tried the prism0 interface does not appear after activating monitor mode.

    The builds that I tried are:

    WRT54GL:
    TomatoUSB: tomato-K26-1.28.9054MIPSR1-beta-Std.trx

    E2000:
    * Toastman v1.28.20111009 MIPSR2-beta-tomato-RT-GIT K26 Std
    (Linux kernel 2.6.22.19 and Broadcom Wireless Driver 5.10.142.0 updates)
    *Tomato Firmware v1.28.2025 MIPSR2Teaman-RT-VLAN-PPTPD K26 USB VPN-NOCAT
    (Linux kernel 2.6.22.19 and Broadcom Wireless Driver 5.10.147.0 updates)
    * Also not on 9055 build, teaman 2021 and 2025, and shibby 102 builds

    It does work on the E2000 with DD-WRT v24-sp2 (04/13/11) big - build 16785 (kernel 2.6.24.111)

    Anyone have a clue how to solve this problem with Tomato or get a bit further towards a solution?

    Thanks.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice