1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Motorola WR850G Upgrade Help

Discussion in 'Tomato Firmware' started by mrralan, Sep 14, 2011.

  1. mrralan

    mrralan Networkin' Nut Member

    Please direct me to the correct forum if this is the wrong one...

    I have the Motorola WR850G v.3. I recently upgraded the stock 6.14 firmware to DD-WRT v24 SP1. I first upgraded to the special mini Motorola DD-WRT and then upgraded to the standard DD-WRT. I would like to change the firmware to Tomato 1.28.

    What is the best way to do this and is there anything I need to watch out for?
    Can I just upgrade from where I am or do I have to go back the stock 6.14?
    Do I need to do any special resets?
    Will the Tomato firmware make the LEDs not function anymore?

  2. Sunspark

    Sunspark LI Guru Member

    I have one of those lying around (with 32megs ram). I bricked it changing the CPU speed, so don't do that one particular thing.

    The LEDs worked when I went from stock to tomato. Should be able to flash to it directly from dd-wrt's upgrade function, but many ways to go about it.

    You will of course want to do a nvram full clear once tomato is installed. This is customary to do when changing firmware distros no matter what router you have (and sometimes versions).
  3. mrralan

    mrralan Networkin' Nut Member

    I'm having trouble. From the dd-wrt upgrade function, I get "Upgrade Failed" after several moments. I tried to tftp at boot but this is also problematic. First I tried to tftp the stock Moto firmware and although the transfer was successful, the router's power light turned red and would not turn back green. I tried to reset it but that wouldn't help. Then I tried to tftp the Tomato firmware but I got the same results. Then I tried to tftp the dd-wrt firmware and that was successful. All my settings were still there.

    I can upgrade to any dd-wrt, e.g., mini, standard, but I can upgrade to anything else. Any thought what might be wrong?
  4. mrralan

    mrralan Networkin' Nut Member

    I got it. Because I was already on dd-wrt, I had to use a generic tomato firmware instead of the motorola specific one. Thanks for the help!

Share This Page