1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Motorola WR850G working? Not for me. (It is now!)

Discussion in 'DD-WRT Firmware' started by wwalcher, Nov 14, 2005.

  1. wwalcher

    wwalcher Network Guru Member

    Does anyone have the DD-WRT firmware working with the Motorola WR850G? I just received one today and loaded the 11/11 firmware on it. You have to change the extension portion of the name to have it load from the GUI. It said it successfully loaded, but the router never responded after that. I tried resetting numerous times and recycled the power, to no avail.

    Is there anyway you can unbrick these units?

    Edit: This unit is now working! See my post about 6 messages down.
  2. sufrano63

    sufrano63 Network Guru Member

    I did the exact sme thing to mine. The instructions said to use tftp to flash and since I didn't know how to use tftp I saw a post somewhere that said to change the extension to .trx and went ahead and did it and get the same results as you, but the router never recover for me. I hope someone has a better instructions on how to flash with the moto wr850g.
  3. BrainSlayer

    BrainSlayer Network Guru Member

    tftp -i put binary.bin
    this works on the first 3 seconds of booting of the WR850G.

    note also that there are 3 revisions of the WR850G and i dont know if every revision is supported
  4. wwalcher

    wwalcher Network Guru Member

    Current status - wireless works - Ethernet ports do not

    I saw a post elsewhere saying that the wireless interface works on the WR850G after flashing DD-WRT from the Web GUI. Sure enough, I was able to get into the configuration program by manually setting my Wireless card IP to an address in the network and accessing I was able to go in and make some changes (I boosted the signal strength on the radio). However, I still cannot get the wired interfaces to work. Also, when I tried to flash either Motorola or DD-WRT firmware, it quickly errors out. I am also not able to TFTP an image to the router from the ethernet interface.

    So, I am currently stuck with a nice Access Point that can't plug into anything. I little bit better than a total brick, but not much.
  5. mandylion

    mandylion Guest

    Ok, I'm posting here too, so as you guys said , after flashing no ethernet comunication at all :(
    BrainSlayer's router works fine as he said to me on the irc , but mine doesn't work at all :(
    On the radio interface it's totaly accessible ...
    My router's version is : WR850Gv2
    One thing I have discovered , is that it never resets entirely after the hardware reset or the firmware changeing ..

    Hope to make it work in the end somehow , maybe BrainSlayer will find the problem .
    Anyway, I thank him and the crew working on this project .

    All the best!
  6. Spippolator

    Spippolator Guest

    Hi! There are three WR850G versions:

    v1 is based on the Broadcom 4710 board. 125MHz CPU, 4Mb flash and 16Mb SDRAM. The wireless NIC is a mini-PCI card.

    v2 is based on the Broadcom 4712 board. 200MHz CPU, 4Mb flash and 16Mb SDRAM. The wireless NIC is integrated to the board.
    It's housed in gray plastic and sports a reverse SMA antenna connector.

    v3 same CPU, flash and SDRAM. It's housed in black pastic and has a hard wired non removable (without desoldering) antenna.

    BrainSlayer, do you have the v1, v2 or v3?
  7. BrainSlayer

    BrainSlayer Network Guru Member

    starting with todays build its working
  8. wwalcher

    wwalcher Network Guru Member

    It is now working!!!

    Confirming Brainslayer's post, I got my previously semi-bricked router working this morning, thanks to instructions from the man himself. I downloaded the 11/18 fw version, and tftp'd it to the router. Boom! It works just like the WRT54G.

    A couple of notes to those who try this:

    1. The WR850g's default IP address is, as opposed to for the Linksys routers, so keep that in mind when you do your TFTP. Use this command for your upload:
    tftp -i put binary.bin
    with "binary.bin" being whatever name you end up giving the fw.

    2. As of right now, the router defaults to using the DNSMasq, but is not working properly yet and causes DHCP to not work. So, when you initially login, you must set your computer to a static IP address in the network. Once you login, uncheck the "use DNSMasq" option on the main setup page and save your settings. You may also have to cycle the power on the router. After this, DHCP should work.

    3. The default password for the WR850g is motorola.

    4. Use the "right" antenna option in the advanced wireless settings for the single external antenna.

    Much thanks to Brainslayer for getting this working! I tested it today in the Client mode and it seems to work similarly to the WRT.
  9. warezdude

    warezdude Guest

    hmm i'm going to flash my wr850 soon.. just looking for the mini-moto.bin

    will report more info as soon as i can!
  10. gaster

    gaster Network Guru Member

    you need to download the mini zip file. you got the standard one instead. check the download area again. there is a std., mini, etc.
  11. danr

    danr Network Guru Member

    Any idea, at this point, if all three are compatible -- and how this unit compares with the WRT54G?

    With the final and SP1 (beta) versions - other than not using
    "mtd nvram erase" -- any other caviots? Do I still need to use tftp
    for the initial firmware loading?


  12. danr

    danr Network Guru Member

  13. danr

    danr Network Guru Member

    Antenna setting

    Also, I read that this has one external and one internal antenna...

    IF this is true, do we really want to only set one as active in the firmware settings?
  14. danr

    danr Network Guru Member

    Re: It is now working!!!

    ok - I just updated a WR850G v2 from Motorola 6.14 to the
    DD-WRT Jan 16 SP1 beta. (I wasn't going to try today's beta on 'new' hardware just yet.)

    As per the Wiki, I WAS able to use the Motorola UI to update to the
    dd-wrt[1].v23_mini_moto.bin firmware.

    As mentioned in wwalcher's post, but NOT the Wiki, I needed to set my PC to a static IP address in the beginning.

    Besides the aforementioned DnsMasq not being activated prior to doing a factory reset, the IP settings were bogus. The starting range was something like: .

    The factory reset via the UI changed them to the WRT54G defaults and I enabled DnsMasq and all was ok. For some reason, holding the reset button for 30 seconds didn't seem to actually reset everything. I needed to use the UI... As warned, I did NOT use the mtd command to clear NRAM!

    I'm still not sure if I should be keeping the Antenna settings as Auto or only right. Changing to left does reduce the SNR as opposed to Auto or Right. So don't know if there is a gain over using Auto versus Right.

    Besides that, all seems successful!

  15. whatsthedeal

    whatsthedeal Network Guru Member

    Re: It is now working!!!

    i'm in the same boat - did you tftp via wireless?
  16. jmalone68

    jmalone68 Addicted to LI Member

    WR850G half bricked

    Hello All,

    I've got several Motorola WR850G routers that are half-bricked and I just can't get them to play nice on the wired ports.

    I'm running dd-wrt v24 5/24/2008.

    Any suggestions would be greatly appreciated.
    Thanks in advance,

Share This Page