1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mtu problem - with Tomato and DDWRT (1456 instead of 1492 on pppoe)

Discussion in 'Cisco/Linksys Wireless Routers' started by fced, Mar 23, 2009.

  1. fced

    fced Network Guru Member

    Hello
    i have installed Tomato latest version on my WRT54GL, and also DD-WRT SP1 and SP2 latest std version.
    i have constated, the MTU is on 1456...
    I have tried to fix it in manual mode, but it's same...

    then, i have tried to go in telnet to do an :
    ifconfig pppo mtu1492

    and after an ifconfig, i constated MTU have been fixed to 1492

    ppp0 Link encap:point-to-Point Protocol
    inet addr:41.250.104.62 P-t-P:41.250.104.1 Mask:255.255.255.255
    UP POINTOPOINT RUNNING MULTICAST MTU:1492 Metric:1
    RX packets:80575 errors:0 dropped:0 overruns:0 frame:0
    TX packets:27908 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:17638658 (16.8 MiB) TX bytes:2161369 (2.0 MiB)

    and if i ping my isp with dont fragment setting from my computer :
    ping -D -s 1464 212.217.0.x

    here are the result
    MacBook:~ ced$ ping -D -s 1464 212.217.0.3
    PING 212.217.0.3 (212.217.0.3): 1464 data bytes
    1472 bytes from 212.217.0.3: icmp_seq=0 ttl=250 time=40.855 ms
    1472 bytes from 212.217.0.3: icmp_seq=1 ttl=250 time=40.493 ms

    mtu size appear to be 1492 (MSS 1464 + 28) so it's appear to be ok,

    but on speedguide.net,
    mtu size appear to be on 1456 ...
    If i set the WRT54GL on auto mtu, it remain to 1456 according to the results of speedguide.net...

    What do this mean ?
    on my gateway (netgear dg834gt, and dlink dsl740b) mtu is 1492 in the router and also in speedguide.net...


    Any idea ?
    is it an bug ? or may be the wrt45gl have detected better results with an smaller MTU ?

    Thanks

    Ced

    ps : sorry for my poor english speaking (french guy)
     
  2. fced

    fced Network Guru Member

    any idea ?
     
  3. fced

    fced Network Guru Member

    Hello
    i'm still here,
    anyone can help me to understand why mtu is set to 1492 if i use an adsl modem router (like the dg834gt; or the Dlink 2740b) and to 1456 if i use WRT54GL + one of those modem router in bridge mode ?

    here are the routing table for the two configurations (telnet -> route)...
     

    Attached Files:

Share This Page