1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My routeur gets crazy after one week of P2P !

Discussion in 'HyperWRT Firmware' started by Nomalz, Sep 8, 2004.

  1. Nomalz

    Nomalz Network Guru Member

    Hello

    I have a WRT54G router v1 with the HyperWRT 1.3 firmware, which i find very cool because it solved all my wifi problems. But i got another problem.

    I'm always running P2P (emule & bittorent) on my computeur (windows 2000), that means 24/24h 7/7, and i haven't got any problem until i started using HyperWRT for about a month. Someday, i found my internet very slow ; lot of "site not responding" and others problems. After checking of lot of stuff, i found that the router web admin was slow too ! But it's local, so it couldn't be slow ! I tried to ping my routeur and i discovered that i got about 80% packet slow (local ping !). I closed emule & bittorent, and the routeur started to work correctly again (no ping loss, webadmin very fast). I opened emule again, and the same problem got back.

    Then, i decided to flash my router again, with the same firmware (HyperWRT 1.3) : after that, everything worked well again. My P2P hasn't any problem and i had no packet loss to my router.

    But about one week after, i started to have exactly the same problem. I flashed again, and it solved the problem again. One week after (today), same problem, same solution. So i decided to post here.

    Before using HyperWRT 1.3, i used the official firmware, which didn't had this problem with P2P, but had lot of problem with my wifi network. So i want to use HyperWRT to use correctly my wifi network. But i can't flash my router each week to have my internet working well ! :/

    I don't know why this problem appears : it seems that, after one week, the router is overloaded : too connections used in the same time ? or maybe logs which are full (but logging is disabled on my routeur) ?

    Thanks for help.
     
  2. grem

    grem Network Guru Member

    You have to re-flash the router? That sounds very odd. Next time, try just resetting the router my pressing the small inset button on the back of the router for 2 seconds.
     
  3. OPaul

    OPaul Network Guru Member

    I have the exact same problem, I'm going back to the official firmware now to see if the problem goes away.

    UPDATE
    Doesn't look like the problem has gone away. I have Emule and Azureus both open but they are only downloading at a total of 32kB/s and uploading at 10kB/s. I have Cable Internet. As soon as I close both applications my browsing returns to normal. I never had a problem like this when I was directly connected to the Internet.
     
  4. Nomalz

    Nomalz Network Guru Member

    What is the version of your router 0Paul ?

    I've got so much problem with my routeur v1 (problem described in the first message and lot of wifi problems) that i think i'm going to buy another one v2. :?
     
  5. OPaul

    OPaul Network Guru Member

    Mine's a version 2.
     
  6. Nomalz

    Nomalz Network Guru Member

    ARG !!!

    Does i really need to use something else than a linksys router to have the basic features working ? :evil:
     
  7. OPaul

    OPaul Network Guru Member

    I'm not so sure it is a problem with the router though, I've seen no one else describe these problems and it's a very popular router.
     
  8. OPaul

    OPaul Network Guru Member

  9. Xiphiplastron

    Xiphiplastron Network Guru Member

    When using a BEFRS41 and logging with WallWatcher, I noticed lots of NAT entry updates. (I turned on full logging in the secret settings page for this router)

    As soon as I turned off Shareaza, the router cooled down.

    It would stand to reason that the NAT (or would this be PAT?) table on the router wasn't very large (I suspected <400 entries).

    I wonder if this is the same problem you are encountering on this router?

    Since I haven't found an effective monitoring solution for the WRT54G (despite following the instructions for getting it to work with WallWatcher), I haven't been able to see if I'm running into the same thing.

    I also haven't been doing large-scale file sharing while having this router, either.
     
  10. maxxed

    maxxed Guest

    is this problem fixed in 1.4? im having the same issues...
     
  11. elguaxo

    elguaxo Network Guru Member

    I experienced the same problem for the first time. I have:
    WRT54GS with HyperWRT v1.4

    I have this line in the startup script:
    echo 8192 > /proc/sys/net/ipv4/ip_conntrack_max
    (and it works, I checked it with cat /proc/sys/net/ipv4/ip_conntrack_max)

    I have 4 wired machines connected to my WRT54GS and 2 wireless. All running Windows 2000 PRO SP4.

    Emule Plus and Azureus were running in a machine for 4 days. After that everything slowed down, not just the Internet connection, but also the whole LAN! Any hints?

    Thanks.
     
  12. elguaxo

    elguaxo Network Guru Member

    BTW QoS is/was DISABLED
     
  13. dummyx

    dummyx Guest

    I have the same problem which happen every day.
    I solve it by power cycle the router.
    But I'm using offical firmware.
    Right now, I burn the HyperWRT 2.0 for less than a day. Hopefully it don't have this problem.
    If happen, maybe a cron job to reboot the route everyday is needed.
     
  14. mattpwill

    mattpwill Network Guru Member

    Same issue here. Please fix it someone!

    It makes a shared WRT54G router unusable
     
  15. HillJack

    HillJack Network Guru Member

    I too had this problem before switching to HyperWRT. Adding the following line to the router startup script solved my problem:

    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    The important part of that line is the 1800 - this is the default TCP timeout for the WRT. My understanding is that Linksys, by default, has set the TCP timeout for established connections through the WRT as 5 days - so your WRT is tracking connections (even dead ones) for 5 days, and with P2P running, you'll get ALOT of connections, which slows the WRT to a crawl. Turning that down to 30 minutes has solved all my problems! All hail HyperWRT :)

    My entire startup script is...

    echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    Both my WRT 1.1 (the one P2P runs through) and 2.2 are currently running perfectly...

    7:17am up 17 days, 22:22, load average: 0.10, 0.06, 0.01
    and
    7:17am up 4 days, 1:23, load average: 0.00, 0.00, 0.00
     
  16. mattpwill

    mattpwill Network Guru Member

    You're my new god. Thank you!
     
  17. rogkm

    rogkm Network Guru Member

    Does it help the disconnection issue with eMule too?

    echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts


    Just copy and paste that into my startup script and reboot the router?

    thanks.
     
  18. HillJack

    HillJack Network Guru Member

    I can't say for sure since I dont use eMule, but I would imagine it would help (solve in my case) all TCP connection issues in general, related to the Linksys router, eMule or BT or whatever; tracking timed-out TCP connections for 5 days is bad regardless!

    Yup!

    Just to update my router stats...

    WRT54G v1.1 (BitTorrent): 12:29am up 20 days, 15:32, load average: 0.02, 0.01, 0.00
    WRT54G v2.2 (General): 12:29am up 6 days, 18:32, load average: 0.00, 0.00, 0.00

    Definitely kicks on the 5-day maximum from the default Linksys firmware :)
     
  19. _Shorty

    _Shorty Network Guru Member

    what do the gc_thresh<x> values dictate?
     
  20. rogkm

    rogkm Network Guru Member

    I think my problem is a little bit different. I usually loose my internet connection after around 2 hours of eMule even tough my connection does not have any issues while I'm browsing or gaming.

    I'll give my router a 30sec reset, reconfigure it and use those lines in my startup script and see what happens.

    thanks.
     
  21. rogkm

    rogkm Network Guru Member

    I just reseted my router, installed the new 2.1b1 firmware, reseted my router again, put those lines on my startup page, and everything seems to be good now...

    1hour and 30 minutes running eMule without a disconnect.

    I hope it stays like this!
     
  22. OPaul

    OPaul Network Guru Member

    Can you explain what the other commands do?
     
  23. Dippo

    Dippo Network Guru Member

    I inserted those lines in my startup.

    AND WOW!

    My router has been working great and emule is working better than ever.
    (Downloads seem to be much fast and I am not losing the server connection every 15 minutes)
    I have over 2 days uptime even with intense P2Ping!

    Before my router would freeze after about 12 hours of P2P...
     
  24. ravn

    ravn Network Guru Member

    Mine too! Before it was killed in a few days of bittorent. But now it just keeps going :)
     
  25. Dippo

    Dippo Network Guru Member

    Now 12 days uptime...

    The startup code fixed my problems, thanks!
     
  26. wrt54gs

    wrt54gs Network Guru Member

    Woh! Great!
    I will try it as last night I experienced same problem.Mine is WRT54G V2.2

    Thanks.
     
  27. Jon12

    Jon12 Network Guru Member

    Hi everyone, I'm having a problem with my router and have been told to try out this code change described in the above replys. The only problem is that I don't know how to edit the start up script or even know where to find it.

    I've tried finding the answer online and tried searching the pc for it but I can't find it. I'm using the latest Linkys firmware and really want to try this. Can anyone spell it out for me? Sorry to be a pain.
     
  28. ravn

    ravn Network Guru Member

    Hint: the name of the forum section you are in :)

    You have to get the HyperWRT firmware...
     
  29. hOrnizuka

    hOrnizuka Network Guru Member

  30. Dippo

    Dippo Network Guru Member

    Now 20 days uptime without any problems!!!
    Plenty of P2P without a hitch...

    I recommend this startup code for anyone having any problems related to P2P.
     
  31. ooofest

    ooofest Guest

    I, too, am thankful for this startup script being shared here - one of my computers is a work system, and the VPN connection to my office network was timing out something fierce in recent months. Just so happened to coincide with some increased P2P traffic on my home system, but I figured that the router should be able to take it easily (wasn't terribly demanding throughput, just large numbers of potential connections).

    I didn't even realize that an alternative to the Linksys firmware was available - this stuff is terrific thus far. My work VPN connection went through quickly and has yet to disconnect since I've been testing today.

    - ooofest
     
  32. akshay18

    akshay18 Network Guru Member

    That doesn't help. Where do you find this startup file??

    I got problem with my alchemy latest firmware.. router is virtually unusable. I had to reset it and flash it so many times.

    I used to use HyperWRT before it used to work great.. until recently it was slowing down LAN (with 2 PCs on it) if one of the PC tried to use BitTorrent.

    So I swithced to Alchemy.. but the problem is worse... I came across this thread.. and was told that I could even add the startup script in alchemy too.

    Please someone tell me where I can find this scrip in the first place. Don't tell me you're talking about the actual firware file (.bin).



    Edit:
    Ok I found out how to do it, thanks to Disman_ca in another thread. You have to go to the diagnostics page of the router settings and enter the code there and click on save startup and then reboot the router. but sorry... it didn't help. connection is still very slow.
     
  33. spline

    spline Network Guru Member

    Hi all,

    i had the same problem with the router than many of you.
    After 1-2 hours of emule the router reboots and all connctions where lost.
    Yesterday i updated to HyperWRT 2.0 (stable), put the code (provided somwhere here) into the startup script and rebooted the router using the "Reboot router" button within the HyperWRT GUI.
    I verified that the code is really in the startup script by pressing the "Startup" button again and the code was there (BTW: Where can i find the startup script when telnetting to the router??)
    Sorry to say: It doesn't fix my problem :-( Router reboots every 1-2 hours.
    Do i need to upgrade to the unstable version of HyperWRT to use this code or does it also run whith the version i use (2.0)?
    Emule settings are: maxcon = 400 maxconn in5 sec = 20

    Regards

    spline
     
  34. Dippo

    Dippo Network Guru Member

    Be sure to do a hard reset every time you update your firmware.
    You will have to reinsert the startup code after the hard reboot and then soft reboot and it should work.
    [One router I had was still locking up even after the firmware upgrade and startup script. After the hard reset, I didn't have anymore problems]


    I have done this to 3 routers, 2 are in the 35+ days uptime while the other has just past 15+ days uptime. This is with plenty of eMule that used to kill the routers within a day.

    Your eMule settings are even less than what I use, so that shouldn't be the problem.
    (mine is 500 Max and in 5 secs = 50)
     
  35. spline

    spline Network Guru Member

    Hi,

    i've done this yesterday. I upgraded to HyperWRT Beta, pressed the Reset button for half a minute, unplugged the power (still pressing the reset button), waited for 1 minute (pressing the reset button), pluged power back and released the reset button after 20 seconds.
    Than i insert the lines in the startup script, used the "Reboot Router" button in the GUI and ....... problem still exists!
    I send the router back this morning and ordered a new one from another seller (but Linksys - i will give them another try).
    Next solution will call Netgear.

    Regards
     
  36. MilesTEG

    MilesTEG Network Guru Member

    hello, can somebody explain a little the lines of the startup script ?
    I don't know what they are doing...
     
  37. djynen

    djynen Guest

    You can add my positive feedback to the list also.

    Configuration:
    Linksys WRT54G Router (with HyperWRT 2.0 Firmware)
    PC with Windows XP SP1 (with Minitar MNP54G Wireless NIC)
    Laptop PC with Windows XP Pro SP1 (with Linksys Wireless NIC)

    Running eMule (Hard Limit: 300, Max Connections: 250)
    Also ran BitComet and Azureus BitTorrent clients on Wireless PC.

    With the original Linksys 2.0.2 Firmware, both eMule and Azureus would force the Router to disconnect after about 2-3 hours of continuous use. I managed to run all P2P Clients over 12 continuous hours, and still surf the web. So I can confirm that the startup script works extremely well. Great job.

    UPDATE (19-5-05): 3 days later and eMule is still up and running - that's a record for me! I'd say the fix is definitely working.
     
  38. MilesTEG

    MilesTEG Network Guru Member

    Just back to the HyperWRT (after a half week using Freeman 1.02, and 3 weeks using DD-WRT)

    I put the rules into the startup scripts, and i will see this afternoon the effects ^^
     
  39. Menkatek

    Menkatek Network Guru Member

    I also would like to know if a knowledgeable person could explain what each line does.
     
  40. mrfritz379

    mrfritz379 Network Guru Member

    ok, here's my setup:
    Linksys WRT54G router
    Linksys WUSB11 adapter (wireless B adapter)

    We have one person hardwired to the router and two wireless connections. I've installed the HyperWRT firmware, reset the router, inserted the startup script and reboot the router. Nothing. I don't know why, but the moment I start up emule (or direct connect or any p2p) my bandwidth plummets, even before I've started downloading anything. My download speeds on the p2p networks are ok, but nothing so substantial that they should take 90% of my bandwidth, but even when my d/l speeds are at something like 2k/s my internet speeds are atrocious. I've tried setting the port forwarding on the router, then tried the DMZ route, just using the windows XP firewall (SP2). I've also tried running both emule and DC++ in passive or lowID mode with no open ports. With every attempt, the same results. I'm at a loss.
    Could it be a problem with my adapter at all (using wireless B adapter with wireless G router)?
     
  41. _Shorty

    _Shorty Network Guru Member

    gc_thresh1 - no garbage collection is done if # is below this limit
    gc_thresh2 - soft limit for garbage collection - it tries to keep them around this limit
    gc_thresh3 - hard limit - absolutely no going over this limit
     
  42. mrfritz379

    mrfritz379 Network Guru Member

    For Windows XP Pro users, I ran across this tweak that fixed my problem. I don't even have the startup script on my router anymore, and emule seems to be running fine.

    http://www.theeldergeek.com/qos_manipulation.htm
    &
    http://www.microsoft.com/technet/prodtechnol/windowsserver2003/library/TechRef/450c1fec-d358-42f4-b7e4-18b3f47ef6ff.mspx

    It limits the number of packets and connects, just like the startup script, but the changes are on the computer instead of the router.

    Also, for those who would like to know what the various settings in the startup script are doing, this site gives some brief descriptions of the commands:
    http://howtos.linux.com/howtos/Adv-Routing-HOWTO/lartc.kernel.obscure.shtml
     
  43. _Shorty

    _Shorty Network Guru Member

    so, rather than simply config the router, you'd rather config every single machine that uses it? ok. heh.
     
  44. mrfritz379

    mrfritz379 Network Guru Member

    Well, if the computer's going to pull the information from the router at the maximum available rate, Microsoft's default bandwidth limit has to be adjusted whether you've adjusted the router or not; evident from the fact that after I applied the startup script solution, I still had problems. I'm also running a home network with 3-4 computers on at any given time. Not a big deal to configure them all, although I've only had to apply the fix to one.

    But I do find it comforting to know that when I posted asking for advice 4 days ago, I got no response, but once I found a solution that worked for me and posted it so that it might help other non-networking gurus who just want to get their home network set up correctly, a whopping 40 minutes was wasted before being criticized as a dumb idea.
     
  45. _Shorty

    _Shorty Network Guru Member

    bwahahha, sorry for not reading the forums every second of every day just waiting for you to ask a question so I can pipe up if I have something to add the instant you ask it...
     
  46. South

    South Network Guru Member

    Well I say thanks for the info tried it out. Waiting to see effects....
     
  47. elguaxo

    elguaxo Network Guru Member

    Since I began using HyperWRT I had only few problems while using P2P (emule plus and/or azureus). But since Azureus began with DHT my network became SLOW after 1 day of Azureus. I tried your startup script and after 2 days of Azureus/Emule Plus everything works perfect. Thanks!
     
  48. mattpwill

    mattpwill Network Guru Member

    My connection slows to a crawl whenever BitComet is running. (It only normally downloads at 10kb/s, so I should have plenty of bandwidth available to "surf")

    The startup script is great, but I still have this problem. I was thinking that maybe a change in some numbers might cure the problem. I've tried using a software firewall in case of it being a security problem, but it doesn't help.

    1) What's the cause of the over-the-top slowdown? (is it hardware-restricted or firmware-related?)

    2) Is there a way of making general surfing normal with BitComet in the background?

    Thanks
     
  49. _Shorty

    _Shorty Network Guru Member

    turn on QoS, put in 85% of your actual download/upload figures, and add bittorrent and any other P2P stuff to it at 'bulk' priority. Works great here. I can even play Counter-Strike Source without my downloads affecting gameplay with my custom CSS pattern set to 'premium' priority.
     
  50. mattpwill

    mattpwill Network Guru Member

    Thanks for the tip. I actually fixed it by using Sveasoft Talisman firmware (search for sveasoft freeman). It's surprisingly very good, and stable. Good work Sveasoft
     
  51. ABX

    ABX Network Guru Member

    This definity fix the problems.
    But i have another question, is there any way to limit the number of connection from windows 2000 server?

    P.S: Found

    TcpNumConnections

    Key: Tcpip\Parameters

    Value Type: REG_DWORD—number

    Valid Range: 0–0xFFFFFE

    Default: 0xFFFFFE

    Description: This parameter limits the maximum number of connections that TCP can have open simultaneously.
     
  52. frode3

    frode3 Network Guru Member

    WRT54G v2.2

    when i ad
    echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    the ipphone addapter wont connect, when i only ad echo "600 1800 120 60 120 120 10 60 30 120"> /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts the addapter works fine is there anything i could make with script so my grandsteam 286 ipphoneaddapter would work with whole script? it seems with script that i surf faster so i would love to use it all, any help?
     
  53. _Shorty

    _Shorty Network Guru Member

    the ip_conntrack_tcp_timeouts one is all you need anyways, the router can't even deal with fiddling with the gc_thresh values without it hurting performance anyways. Besides, none of the things mentioned will affect your connection's performance in a good way, so anything you notice while browsing is coincidental. If you want to improve your quality of service, then you might want to use the QoS (yep, quality of service) features to do so. But these things mentioned here do nothing to improve throughput. In fact using the higher gc_thresh values only makes it worse, the defaults perform better. If you want your browsing to behave better than your P2P traffic then you should use QoS and make the P2P traffic 'bulk' priority.
     
  54. frode3

    frode3 Network Guru Member

    thanks :D
     
  55. bazai

    bazai Guest

    My router has the same problem of slowing down when I ran Azureus bittorent. However, my router is the WRT54GS (speed booster). Can I use the same start up script with my router?

    Thanks for any help.
     
  56. magnus33

    magnus33 Network Guru Member

    as long as your useing a version of hyperwrt or other firmware that lets you use startup scripts then yes.

    yours is basicly the same with only minor hard changes.
     
  57. nb-magnum

    nb-magnum Guest

    Hi!
    I'm new here and new with the Linksys router.
    Where can I find the start up scripts?
     
  58. magnus33

    magnus33 Network Guru Member


    copy and past this.

    echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    administration tab/startup

    thats all there is too it.

    of course you need to be useing a firmware that lets you do this.
     
  59. _Shorty

    _Shorty Network Guru Member

    you really only need/want the ip_conntrack_tcp_timeouts line, if you use all those lines the router's performance takes a nosedive. At least my WRT54GS v1.0 does. The modified gc_thresh values just wreak havoc on performance, and there's no reason the default 1024 value for ip_conntrack_max wouldn't be good enough once you've got the modified ip_conntrack_tcp_timeouts value in place.
     
  60. magnus33

    magnus33 Network Guru Member

    makes sense now that i actually think about it.
     
  61. Spontex

    Spontex Network Guru Member

    Cannot access webinterface

    Hello,

    i´ve the same problems using p2p on my WRT54G v2.2. So i copied that lines into the startup script. After this the router ist running well but i cannot access the webinterface any more. Any suggestions about this?
    I´m runnig the HyperWRT 2b1 Firmware from Rupan with v4.20.6 codebase.

    Greets
     
  62. _Shorty

    _Shorty Network Guru Member

    you could always hold the reset button in for 30 seconds to reset *all* settings, so you could access the web interface again. You'll have to set all your stuff again, of course.
     
  63. Spontex

    Spontex Network Guru Member

    Yes, thats what i have done. But do you know on which command(s) this failure depends? Because now i´m back on the webinterface but my p2p problems are also back without the startup script.

    First time i had left the lines below:
    Code:
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses 
    Because in the HyperWRT in use you can filter multicasts. And i don´t know what the second command is doing.

    How can i lookup the current ip_conntrack_max value over the command shell? I think in HyperWRT the value for ip_conntrack_max is already at 4096 ....
     
  64. _Shorty

    _Shorty Network Guru Member

    well, the only one you really need (and as far as I'm concerned, the only one that should be used) is the ip_conntrack_tcp_timeouts line. It's the one that makes sure things related to dead connections don't stick around for too long in memory. And this is what solves the P2P problems.
     
  65. Spontex

    Spontex Network Guru Member

    Mmhh ok, now i only have the timeout line in my startup script. But the problem exists further - this trouble seems to be a little bit crazy. Because at heavy traffic load not the whole route reboots, i lost only my PPPoE Connection one time an hour ... 8O
     
  66. _Shorty

    _Shorty Network Guru Member

    which P2P software are you using that's causing this? I suppose you could try lowering that 1800 to 1200 and see what happens. But which P2P?
     
  67. SombaSan

    SombaSan Network Guru Member

    I updated to the following: Firmware Version: v3.03.6 - HyperWRT 2.1b1 however I do not know where the scripts are loacted there for i cannot add the following code/commads: echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts or :

    echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts if someone would please tell me when excatly or rather how to get to the "ROUTER SCRIPT PAGE or FRONT PAGE" as u all describe it thx.
     
  68. Spontex

    Spontex Network Guru Member

    Bittorrent with latest Azureus Client ...

    Administration -> Management -> Hit the "Startup" Button
    A new window pop up, where you can edit your Startup script.
     
  69. SombaSan

    SombaSan Network Guru Member

    thx, also what would be the best set up for P2P, and making GAMING (probably the larger packets) the 1 priority.
     
  70. SombaSan

    SombaSan Network Guru Member

    Alright here is the deal I installed everything and even put in the router script listed in this thread. However while in game my router will shoot from 36mbps to 54 RAmdomly and fuck up my rate of ping. And i never even had that problem playing on my Extreme G D-link and airlink network card. This v3 router and my WRT54G are not playing well at all, Im fixing to take something back to the store, what else do i need. ???????????? is there a better made script for this FREAKING router. please help.
     
  71. _Shorty

    _Shorty Network Guru Member

    as I said several times, you only want that one line because the other lines screw up performance...
     
  72. SombaSan

    SombaSan Network Guru Member

    ahh right
     
  73. vibe666

    vibe666 Network Guru Member

    been having the same problems, just trying your startup script now. will test for a few days and see what happens!

    thanks in advance, this has been driving me nuts for ages. :cheer:
     
  74. pill

    pill Network Guru Member

    Thanks HillJack, I'll try this out! I run a lot of proxy scanning programs and p2p and this hopefully solved my problem everyone else has been having.. :D
     
  75. pill

    pill Network Guru Member

    in the connection line..

    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    If i were to change the 1800 to say.. 660 would it be more effective than the line above? It would only be 11 minutes compared to 30, right?
     
  76. magnus33

    magnus33 Network Guru Member

    its sort of running the line between is it dead or just dropped off for a few mintues.
     
  77. vibe666

    vibe666 Network Guru Member

    :cheer: :clap: :cheering: :thumb: :thumbup: :rockon:

    another big positive here!

    WRT54G V2 with the HyperWRT 2.1b1 firmware and it's been up 5 days now with heavy P2P'ing with Bitlord, and still able to surf fine with both my wired desktop and wireless laptop.

    Thanks a million!

    P.S. Couldn't give a toss what the code does, I just know it works.

    people are far too curious these days. :D
     
  78. Zandinga

    Zandinga Guest

    I am having the same problem but with the WRK54G router

    Can i use this process (the line in the startup) to fix my problem?

    Thanks
     
  79. vibe666

    vibe666 Network Guru Member

    the startup script is specifically for versions of the WRT45G and other products using the hyperwrt firmware, or other firmware which allows you access to a startup script in the config.
     
  80. cjb110

    cjb110 Guest

    Just to point out that those links contradict each other, one says to reduce the QoS bandwidth reserved, but the MS one correctly points out that this bandwidth is not reserved if there isn't anything using it.

    So that setting will make naff all difference to 90% of people, and if your one of the 10% that are using it then this change will make things worse!
     
  81. Nizetti

    Nizetti Network Guru Member

    Hi there, I just wanted to add that I managed to solve my QoS problems with this HyperWRT 1.4 firmware and this startup script - I can now download Japanese Dramas via bittorrent, without making the internet connection unusuable for anything else. (I set the bittorrent port 8951 to low priority)

    The other thing I did was increase the number of half open ports allowable from 10 to 50, and allowed Bitcomet to use 25 of them. (WinXPSP2 limits to 10 and I used the LvlLord patch)
    http://www.bitcomet.com/news/20040908_xp2_4226.htm
    http://blog.davidkaspar.com/archives/2005/04/windows_xp_sp2_and_event_id_4226.php
    http://lvllord.de/?lang=en&url=downloads

     
  82. GaryKing

    GaryKing Network Guru Member

    1.4 firmware? Isn't the latest 2.0?

    Also, I have the startup script installed, but I still have the same problem. Well, similar.

    My problem is that after an hour or two of BT, all things internet becomes slow (even the web admin.) I have to restart my computer for the problem to go away (even after closing BT).

    Any suggestions?
     
  83. Nizetti

    Nizetti Network Guru Member

  84. GaryKing

    GaryKing Network Guru Member

    Strange - I set the my BT port to low priority as well, and only my HTTP port to HIGH priority, and yet I am still having this problem.
     
  85. Nizetti

    Nizetti Network Guru Member

    If you're using XP, did you try the Lvllord patch? The only things I did to get those dramas flowing without knocking itself or anything else out, was to:

    patch XP's TCP/IP stack with the Lvllord thing

    set that startup script into HyperWRT.

    Nizetti.
     
  86. GaryKing

    GaryKing Network Guru Member

    Actually, I used the LvlLord and set it to 200 (which is the # of connections I allow my BT to have) and that seemed to do me some good. I also have the entire startup script installed, and that seems to do me good, too.

    So far, I don't really have any problems.
     
  87. whozyodaddy

    whozyodaddy Network Guru Member

    I installed the latest firmware, reset the router, inserted the one line of startup script, then rebooted the router from the gui, enabled QoS and set my Azureus port to "low", cut the max global # of connections in Azureus by half (from 400 to 200), and internet speeds have drastically been improved, Azureus no longer kills my internet access.

    ALTHOUGH, after about 30 minutes or an hour, my internet dies! I can't view any websites and my dl speeds drop to 0. The ONLY way to get internet back is to unplug power to my cable modem then plug it back in.

    Somebody help me?
     
  88. whozyodaddy

    whozyodaddy Network Guru Member

    bump, this thing is really f**king annoying, after 10 mins it just kills everything
     
  89. i just have a quick question as to where you get this firmware that you are talking about to edit the file thats being talked about to fix the P2P problem???
     
  90. magnus33

    magnus33 Network Guru Member

    hyperwrt firmware. and just click on the downloads off to the left here.
     
  91. magnus33

    magnus33 Network Guru Member

    hmmm are you on cable or dsl?

    could be problem with it rather then the bittorent issue.

    had a bad line running to the house with my dsl that would cause so much noise that it caused the modem to go flacky.
     
  92. whozyodaddy

    whozyodaddy Network Guru Member

  93. whozyodaddy

    whozyodaddy Network Guru Member

    It seems to be working now... what I did was two things:

    - Uninstall my AV (NOD 32)
    - Use the lvllord patch (http://lvllord.de/)

    Although my internet does not die, my internet download speeds drop alot. Any known cures?
     

Share This Page