Need advice-WRT54G SES button question...

Discussion in 'DD-WRT Firmware' started by boobear, May 2, 2007.

  1. boobear

    boobear LI Guru Member

    Hi Everyone,
    I've just upgraded my wrt54g v4 to dd-wrt standard.v23.sp2. The upgrade was successful as shown by the message at the end of the process.

    I've -
    1. enabled the SES button to be the wireless on/off switch.
    2. loaded the following in startup script.

    --------------------------------------------
    #!/bin/sh
    I=`nvram get wl0_ifname`

    while sleep 1; do
    if [ "`wl assoclist`" != "" ]; then
    XFER=`ifconfig $I|grep bytes`
    if [ "$XFER" != "$PXFER" ]; then
    LED='gpio disable 3 ; gpio disable 2'
    PXFER=$XFER
    else
    LED='gpio disable 3 ; gpio enable 2'
    fi
    else
    LED='gpio enable 3 ; gpio enable 2'
    fi

    if [ "$LED" != "$PLED" ]; then
    eval $LED
    PLED=$LED
    fi
    done
    --------------------------------------------

    My question is-

    After the router booted up, the SES button lid up in amber always. There wasn't any client connected, is it meant to be this way?

    Is there a way to off it?

    I thought it should only light up in amber when there is wireless connection? and

    light up in white when there is data transfer.

    thx...
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice