1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help! Looking for stable firmware

Discussion in 'Tomato Firmware' started by MarkyMark19, Nov 14, 2008.

  1. MarkyMark19

    MarkyMark19 Guest

    Hello,

    I need your guys advice. I have a Linksys WRT54GL v1.1. I have 4 connections on it. A wired PC, wireless dell laptop, wireless Xbox 360 connection, and a wired vonage VOIP phone service. I've had this router for over a year. Went months with no disconnections with the linksys original firmware. Started disconnecting, I would have to reset the firmware to get it back online. I had enough of that so started researching and loaded DD-Wrt v23 sp2. Would still disconnect on me. sometimes 2 or more times in one night while I'm on the Xbox live or on my laptop.

    Then I downloaded the Tomato firmware. Same thing, not stable. It would disconnect on me. Then I found these forums. I was reading a thread that said the problem could be my wireless card in my laptop, it's the intel 3945ABG. They suggested to download the ND firmware. I did that last night. Downloaded the Hardcore Speed mod 1.21 New driver firmware. Today, just now got a disconnect. 3 disconnects. Had to unplug the router and my cable modem each time to get it back online.

    All i'm looking for is a stable firmware! I don't need anything special. As long as it runs consistently while I'm online. I hate losing connection playing in a good match on Xbox LIve. I hate this. Someone please help me!
     
  2. ifican

    ifican Network Guru Member

    tomato is extremely stable, reset nvram if that does not fix it then its something else, either hardware going bad or modem or cable between the too. When it disconnects can you still ping your router, your modem, anything? After rereading your post, if you dont play xbox, just surf the net and make calls does that help keep it stable?
     
  3. agentsky1919

    agentsky1919 LI Guru Member

    Did your router start disconnecting when it has still the original firmware or when you flashed it with 3rd party firmware?

    Did you reset nvram after flashing?

    Have you tried connecting to the internet directly to your modem and experience the same disconnection?
     
  4. baldrickturnip

    baldrickturnip LI Guru Member

    is your modem set up as pure bridge with the WRT54 handling the connection ?

    maybe you should also look to see if your modem is causing you a problem.
     
  5. jersully

    jersully LI Guru Member

    I have the same router, Tomato 1.19, and nearly the same clients as yours. My laptop has a different wireless card, and I in addition to your clients I've got a couple of TiVos, another wireless PC, a Wii, a Buffalo NAS, and an HP JetDirect.

    Tomato has been rock solid for me. In six months I've never had to reboot the router because the router needed it.

    Have you tried another Wireless NIC, or have you noticed if you have problems when your laptop is not on the network?

    I very highly recommend this Edimax wirless PC card, which uses an Ralink chipset. Ralink is a great chipset, especially for Linux support.
     
  6. joeyford1

    joeyford1 LI Guru Member

    I agree. It sounds like your modem is having issues. If it did it with the OEM firmware, and it still continues after 2 different firmwares.
     

Share This Page