Need help resetting groups/users

Discussion in 'Cisco/Linksys Network Storage Devices' started by byKnight, Dec 15, 2004.

  1. byKnight

    byKnight Network Guru Member

    I think I mangled up my users and groups today, but I'm having trouble reconstucting what I did.

    Here's what I'm experiencing now:
    • With the NSLU2 web admin interface, if I try to access the Users page, I get a "Page Not Found" error. The link I'm clicking on goes to:
      http://192.168.1.77/Management/file_sharing.cgi?next_file=users.htm. I've verified that file_sharing.cgi and users.htm are both present.
    • Also, when I go to the Groups or Shares pages, I get a pop-up with the message: "Error: Fail to get user list". The pages load, but I get that pop-up.
    What I'd like to do is reset the users and groups of the factory defaults. I tried "Restore Default Config" on the System page and even doing a "fis erase -f 0x50040000 -l 0x20000" to erase configuration data from flash. But the existing group and user data remains.

    I've searched and haven't found any other suggestions for resetting this info. Can anyone offer a suggestion?[/list]
     
  2. byKnight

    byKnight Network Guru Member

    Fixed things up by telneting into RedBoot. There I found what appeared to be backups of the group, usrgrp.info, and smb.conf files in /share/hdd/conf. These backups all had ".ttt" appended to their names.

    I mv'd group, usrgrp.info, and smb.conf aside and cp'd group.ttt usrgrp.info.ttt, and smb.conf.ttt in their place. Rebooted and everything worked as it had prior to my mangling the user/group permissions.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice