1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

NEW Beta Firmware for WRT54G/GS

Discussion in 'Linksys Official Firmware' started by mstombs, Apr 23, 2005.

  1. mstombs

    mstombs Network Guru Member

  2. Toxic

    Toxic Administrator Staff Member

    Now also added to linksysinfo downloads.


    WRT54G/GS v4.00.5_US_code.bin firmware

    no changlog however I did notice the following:

    WPA2 Support:

    Ez-setup

    2 types of QoS Wired and Wireless QoS:

    Wired QoS

    Device Priority : You may specify priority for all traffic from a device on your network by giving the device a Device Name, specifying priority and entering its MAC address.

    Ethernet Port Priority : You may control your data rate according to which physical LAN port your device is plugged into. You may assign High or Low priority to data traffic from devices connected on LAN ports 1 through 4.

    Application Priority : You may control your data rate with respect to the application that is consuming bandwidth. Check Optimize Gaming Applications to automatically allow common game application ports to have a higher priority. You may customize up to eight applications by entering the port number they use.

    Wireless QoS

    Wireless QoS is also referred to as Wi-Fi MultiMediaTM (WMM) by the Wi-Fi AllianceTM. Select Enable to utilize WMM if you are using other wireless devices that are also WMM certified.

    No Acknowledgement : Enable this option if you would like to disable acknowledgement. If this option is enabled, the router will not re-send data if an error occurs.
     
  3. Toxic

    Toxic Administrator Staff Member

    come on guys, lets gets some feed back on this new firmware from v2.2-v3.0 WRT54G and v1.1-v2.0 WRT54GS users alike
     
  4. lluner

    lluner Network Guru Member

    lluner

    it wanted to know if and possible to install this firmware WRT54GV3.1_4.00.5_US_code.bin in WRT54G v 2.0
     
  5. jdepew

    jdepew Administrator Staff Member Member

    As per our news post its only intended for v2.2-v3.0 in the G line and v1.1 and v2.0 in the GS line - this may change as this firmware moves towards a more final release, as Linksys tends to release firmware revisions that accomodate all existing hardware revisions as it makes things easier on the consumer and reduce support costs.

    That said, as Toxic said, he was able to load it onto his Gv2.0 without incident and was still able to see the new features.

    Jim

    PS - If you're willing to give it a shot on your 2.0 - more power to you, just be careful as this is beta firmware and we can't guarantee its quality. If you do load it we *expect* a full report on how it works for you ;-)
     
  6. devil-strike

    devil-strike Network Guru Member

    OK i have upgraded my router with the latest firmware all ok
    But now i will be back to DD-WRT but thats not working anymore??

    whene i upgrade to DD-WRT it just failed (upgrade failed)

    Please help me out.
     
  7. MilesTEG

    MilesTEG Network Guru Member

    Hello, is that firmware compatible with a WRT54GS v1.1 ??

    And is the problem of wifi loss connection when transfering solved ?
     
  8. Toxic

    Toxic Administrator Staff Member

    do a hard reset firstbefore you upgrade again.

    I just flashed back from the new 4.00.5 to ddwrt then back to the new beta without any problems.
     
  9. devil-strike

    devil-strike Network Guru Member

    OK, thx its worked :D
     
  10. pegajoso

    pegajoso Network Guru Member

    This time, it seems to have resolved the wireless drop issue... mine is a new (two weeks old) WRT54gV2.2. I have tested hyperwrt, alchemy final and previous linksys firmware, all of them presented the drop issue... also checked to cool the device with an external fan, no difference. It seems that it is a firmware issue after all.

    Saludos desde Panama!
     
  11. peterfry

    peterfry Network Guru Member

    WRT54G v2.0 fixed throughput problem

    Hello everyone,

    I haven't posted much here, but I read all the time. I have a WRT54G v2 (v2.2 per the label, but v2.0 per the serial #) and had the high throughput problem. It was killing me, I couldn't deal with it... I was just about to order a new wireless router from netgear, but I decided to check the fourm once again.

    I couldn't believe my eyes when I saw the post with the supposed fix!

    I flashed WRT54GV3.1_4.00.5_US_code.bin, reset to factory defaults, and crossed my fingers.

    I can't believe it, but it works. I'm incredibly happy \:D/. Hearing that it was a hardware problem, and seeing that it had existed for so long without a fix, I had begun to lose hope.

    I have a small network with a few boxes wired to the router and a wireless notebook, which I use as my primary computer. I always Radmin to the wired computers with my notebook, and that had always killed my WRT after a few minutes of use. I also use my wired boxes for file storage (mp3, video, database backups), which I access from my notebook. That was another thing which was sure to take my router down.

    Now, I'm able to do anything I can imagine. As soon as I flashed the new firmware, I tried to hammer the router. I transferred gigs upon gigs of many random files/folders (wired --> wireless, and wireless --> wired), Radmin'd to multiple computers, started downloading windows updates, streaming music, and surfing simultaneously. She didn't crash. And I was amazed.

    I've beeen using it for over a day and it's been great so far.

    The only thing I have to complain about now is the factory firmware wireless range... because I had been using DD-WRT before @ 85 db. But I'm happy to have something that WORKS! FINALLY! :D

    I think that this board played a big role in pressuring/influencing Linksys to first realize and admit (admit to some extent), and now fix, the problem.

    At any rate, this is a great forum and all of these firmware projects are exciting. I can't wait til the new code is released & integrated into some projects here. :)

    -Peter
     
  12. RyFeR

    RyFeR Network Guru Member

    WRT54GSv1.1 with beta firmware solved issue

    Hello all,

    Just posted my story in the "WRT54G High load causes disconnect" thread, but here's just the outcome of my testing:

    The new beta firmware flashed in my WRT54GSv1.1 router (and a 30-second reset afterwards) solved my issue (copy of certain files caused SMB reset, ping / http traffic was unaffected) completely.

    Very happy now!
    Ferry.
     
  13. ericchang591

    ericchang591 Network Guru Member

    My story is that I have a WRT54G v3 and the first time I used the beta firmware, my router stopped working, and I had to use the Linksys automated firmware application to revert back to the original official firmware. I tried it again today after a factory reset, and it failed in the middle of the update, and now my router is a brick as no amount of resetting will help since my router is now not detected by anything and is essentially a doorstop. Perhaps this was a blessing since I now am the happy owner of a Netgear router which I went out and bought since I got fed up with running in circles with Linksys support and this stupid router. Hopefully others will have more luck that I did, but I would recommend waiting for the official firmware update if you have a v3, as there was someone else in that high-throughput causes disconnect thread that also had the same experiences I had.
     
  14. Manip

    Manip Network Guru Member

    Resolved the wireless dropout for me no problem. :)
     
  15. Partizan

    Partizan Network Guru Member

    I still get wireless and wired dropouts on my v2.2. So this firmware didn's solve anything for me.

    Regards, Partizan
     
  16. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    well same result for me...
     
  17. desconosido

    desconosido Network Guru Member

    my router v 2.2 still hang up. But works a litle better, I think. Is anybody with v 2.2 with the same problem ? Maybe somebody know how to resolve this problem ?
     
  18. devil-strike

    devil-strike Network Guru Member

    i have also a v2.2 and no problems here, i have 40GB transfered from wireless to wired without dropouts.
    load avg, 0.11
     
  19. bigbaraboy

    bigbaraboy Network Guru Member

    Ok,
    It seams that this firmware has solved problem to many of you, but to someone from us did not.
    I have also tried to upgrade firmware and then tried to check if problem is there, and it was there but I didn’t do something.

    If you carefully read previous posts everybody who have succeeded to resolve problem have done reset to defaults with reset switch (30 sec) after upgrade.
    We who didn’t resolve problems did not do this (I didn’t, I have only done reset defaults before upgrade).

    So this will be first ting that I will do when I get home, and hopefully I will repair my Router v.2.2.

    Regards BB
     
  20. enx23

    enx23 Network Guru Member

    Up-side down

    I have a WRT54G v2.2 (firmware v3.03.6). I experienced also wireless high-throughput disconnects even in "only-B" mode with WEP 128 bit or WPA.

    I have tried to change the seetings RTS threshold, beacon, etc... but I was not happy with it because it slows down the transfer speed for wireless connection even that the disconnects are gone.

    Finally, I tried to position the router upside-down (the side with leds is downwards like in the picture http://www.angelfire.com/ga/govandy/junk/vertical_linky.jpg ; the picture is by http://www.dslreports.com/profile/565882 ) and the router works perfectly now and no more drop-outs.
     
  21. bigbaraboy

    bigbaraboy Network Guru Member

    Now I have again upgrade my router to this beta firmware, reset router and start coping files.
    After coping some 3-4 Gb of Mp3, iso, vob ,… files everything was working, no disconnect for almost 3 hours. I was very happy.
    After that I have started coping hall bunch of files and go to sleep with smile on my face.
    In the morning I have found our little message “the remote machine… “, ok it was disconnected at 98 % of coping, but it was disconnected.
    So let’s wait new firmware from Linksys
     
  22. RyFeR

    RyFeR Network Guru Member

    Hello all,

    Reported earlier that, with the new beta firmware in my WRT54GSv!.1, the "specified network name is no longer available" error (and SMB session disconned) problem was over... Well, that's no longer the case :-(

    I can copy the files that gave me the error previously, but other (new) files still give me the same error...

    So LinkSys made some progres, but they are not quite there yet...
     
  23. beebobby

    beebobby Network Guru Member

    Successfully flashed from DD-WRT pre 4 to Beta on a GS v1.0 and back to DD-WRT pre 4 with 30sec reset in between and after.
     
  24. jhugues

    jhugues Network Guru Member


    I own a WRT54GS V1.1 and I just tried the Beta software. It worked!.

    I have no more high thruput disconnect when using Microsoft Backup from a wired LAN to a Wireless NAS.

    It is very clear to me that Linksys is on its way to finding a solution to our problem.

    Thanks for who ever posted that Beta release.
     
  25. kickerspot

    kickerspot Network Guru Member

    I own a WRT54G V2.2. I get disconnects while transferring large files, watching video or using VNC. No problems while surfing the web.
    The beta firmware did not solve the problem for me :(. I will return to the WRT54GV2_3.01.3_US_code.bin since i have the feeling that it works most stable with this firmware.
     
  26. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    GUYS i have a very good news for you!!!!!!!
    gaogi just mailed me the latest Beta FW of WRT45G, i tried it and guess what :D not even one disconnection on serval files via wired/wireless on local server HTTP and netBios and i didn't have any problem
    i asked him to mail me the WRT45GS FW
    i hosted the Firmware on http://www.siemens-mobiles.org/linksys/
    filename : WRT54GV3.1_4.00.7_US_high.code.bin
    description : WRT45G 4.00.7 BETA Firmware

    Please WRT45G owners try this and tell me about the results
    thank you
     
  27. JohnSK

    JohnSK Network Guru Member

    I'd love to try the newest beta FW but is there a way to select RX/TX antennae in official FW's? That's the only thing holding me back..
     
  28. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    no there's not this feature, i think you need to wait for an unofficial FW comes out based on this one, or just switch to wired just to try this and confirm it works
     
  29. TFMegatron

    TFMegatron Guest

    I have a v2.2 and with this upgrade I still experience the same problems. I'm going to take mine out back and play baseball.
     
  30. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    well actually you are the only one who still experience the problem are you sure you loaded the right FW file???
     
  31. m00n

    m00n Network Guru Member

    Gandalf, i to expierence some problems with the latest firmware.(and all the other) Not the wireless part (never tested it so can't say i had it and can't say i didn't had that problem).

    My problem is that after a couple of mbs downloading my connection to the router jaimes,... i have to disable/enable my ethernet card to get it working again....

    Never had this problem with the BEFW11S4...

    When i'm home i have to do a hard reset and change the mtu values (thats wat linksys told my @ live support). Let's hope it works (guess not but i'll see)
     
  32. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    hmmmmmm... this new FW should fix it hmmmmmmmm... y you still have this problem!!!!!
    because this problem is the same as everyone's problem, i was disabling / enabling wireless to get back before the new beta FW, now it's gone
     
  33. m00n

    m00n Network Guru Member

    I have it when i'm wired connect... Could it be the ethernet port? or cable thats mailfuntioning?
     
  34. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    is it possible for you to try wireless?? using someone's portable for example?
     
  35. m00n

    m00n Network Guru Member

    I've got two pc's @ home that are wireless connected, but i don't download with these, they are from my father and mother so :).

    But when the connection from my pc to the router hangs/drops/jaimes, the wireless pc's just keep going.

    But i can see where youre going, if the connection hangs/drops/jaimes when downloading wireless it's the same kind of problem, if it doesn't... i don;t know what then :).
     
  36. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    well exactly, if the wireless keep connected than it's maybe, a problem with the LAN ports, cable or even the Network card of your PC, so you need to isolate the problem's part by trying for example another PC with wired connection, and then try using another cable etc...
     
  37. m00n

    m00n Network Guru Member

    I already tried a other ethernetcard, and lan port, so. Maybe it's the cable...
     
  38. Gandalf_SX1

    Gandalf_SX1 Network Guru Member

    maybe, u use a cross-over cable no???
     
  39. m00n

    m00n Network Guru Member

    Would it even be able to download when it's a crosscable or visa-versa. In any cause if it's the wrong cable (crossover or the other one, i can't remember the name) i wouldn't work in the first place aitgh?

    I can download 500 mb or so, and then it drops, and it doesn't connect again.

    Started yesterday to download something, it stopped after 10 x 50 mb, and never connected again... i had to manually disable/enable the ethernetcard (i said this like a 100 times but oke :)))) )

    I can play online games for hours, but downloading it cracks....

    On the linksys live support chat they told me to change the mtu size.. (whats is it, and whats does it do????) and to try to doe a hard reset. 30 secs reset button, power off keep de reset button down, power on, and release the reset button
     
  40. xb0xb0y

    xb0xb0y Network Guru Member

    i posted in the other "throughput" thread. but i'll post here as well. beta 7-highcode seems to fix both v2.2 and v3.0 WRT54G for wireless reboot problem in both routers. i'll try the beta 7-lowcode later tonight as well. this beta firmware also lights up that "new" mysterious button on the v3.0. it glows orange and flashes white when pressed. kills all connections while it's flashing though, have no clue what it's doing. i have to pull the plug to make it stop. :p
     
  41. MrPr0ky

    MrPr0ky Guest

    Flashed the beta7 'hicode' firmware on my WRT54G 2.0. Seems to work just fine.

    I was mostly interested in the new, enhanced QoS features and so far I'm impressed. You now have much more granular control over priority and are able to enter a lot more custom applications. I'll have to try playing games torrenting some linux CDs and see how it works.

    The only bug I've seen so far is that some of the selection dropdowns appear 'blank' after you load up an option page. Everything is working as it should, however.

    No problems with wireless, but I did not have any problems before either. Tivo, laptop, and palm all connect as they should.
     
  42. tekknix

    tekknix Network Guru Member

    Yes, Beta-Firmware has fixed the Problem

    Yes that absolutely right. My Tests right now has shown no Problem at all (My Router is passive cooled) and seems not to be very "hotter" as before.

    But, if i assume it right, the only Change was to overclock the Router. Nothing more, no other Change.

    Would be nice, if we can get a Firmware of Hyper-WRT or DD-WRT which integrate an overclock-Option in the GUI.

    Maybe it's possible ?

    Best regards
    Tekknix (now with a Full-State of the Art Router WRT54G v2.2 and not a brick)
     
  43. enx23

    enx23 Network Guru Member

    Beta-Firmware v4.00.7 low clock rate

    I tested "WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]" with my WRT54G v2.2 and it works fine for LAN and WLAN transfers!!! I had no problems or disconnects with it yet.
     
  44. m00n

    m00n Network Guru Member

    I had a queue of 23 gig and it stopt with 9 left. The connection bricked and had to reset it this morning.....

    GOing to RMA the router on advise of LinkSys. Asking for a 2.0version ...
     
  45. Rudi1

    Rudi1 Network Guru Member

    Hi!
    can someone explain what is different about this 2 version:

    WRT54GV3.1_4.00.7_US_code.bin and
    WRT54GV3.1_4.00.7_US_high.code.bin

    I use adsl with PPPoE,which one is better to upload?

    Thanx
     
  46. m00n

    m00n Network Guru Member

    One is overclocked (240mhz) The high one,

    The other is lowclocked (216mhz).

    One the longer run the high one can damage your router... so thats why gandalf posted the low one...
     
  47. Rudi1

    Rudi1 Network Guru Member

    really thanx for this info,becouse I love my router :)
     
  48. pharma

    pharma Network Guru Member

    M00n,

    Glad to see your problem was not with your router, since the same thing happened when you removed your router from the equation.
     
  49. APE992

    APE992 Network Guru Member

    My problem is with a single wired box, it randomly pings out and reconnects. No method to any of it aside from when pinged with 999 packets it always returns with 26 dropped. Wireless works fine on my laptop, two other boxes work fine. Just this one has issues. I'll give this firmware a shot and see if it helps, if not I'll continue the RMA process with linksys.
     
  50. Cyberian75

    Cyberian75 Network Guru Member

    It'd be an issue with your NIC then.
     
  51. APE992

    APE992 Network Guru Member

    Maybe, possibly, doubtful. I swapped it out with a d-link, it had the same problem. The problem machine has a realtek 8139, dont know the revision. A third box on my network has the 8139 onboard but its an A and works fine. I flashed the new firmware on it and I can ping the problem box just fine from the one I'm currently on. When the problem box pings the wrt it gets large sucessfull blocks of pings and large blocks of time outs. However it can ping the old router thats hooked up through it with 100% sucess. The problem box is plugged into the old one. Just swapped it into the new wrt to see if the issue continues.

    UPDATE: Problems still exists. Swapped from realtek to onboard via card. Same problem with added bonus of flashing like mad on the wrt. This thing is a royal pos.
     
  52. bigclaw

    bigclaw Network Guru Member

    After installing the high-clock-speed firmware, my v3 router's Cisco logo now lights up. It's an amber light. I definitely didn't notice this before. Is this normal?
     
  53. APE992

    APE992 Network Guru Member

    It did the same thing to mine. When you run the SES it will flash white for a while. No idea why. Oh and the thing is still being a piece for me.
     
  54. mr_magicfingers

    mr_magicfingers Network Guru Member

    If I install this firmware on my v2.2 router, should I then install the dd-wrt v4 prefinal afterwards, or does that overwrite the benefit of the linksys firmware.

    I really like the QOS options with the dd-wrt firmware, but would like to get the newer lynksys firmware for the fact that it fixes some problems on this router.

    Thanks,

    Justin.
     
  55. Cyberian75

    Cyberian75 Network Guru Member

    That bricked my router. :(
     
  56. mr_magicfingers

    mr_magicfingers Network Guru Member

    What was it that bricked it? installing the linksys firmware or the dd-wrt?

    Thanks,

    J.
     
  57. Cyberian75

    Cyberian75 Network Guru Member

    I bricked it when I tried to go back to the Linksys firmware.
     
  58. enx23

    enx23 Network Guru Member

    Re: Beta-Firmware v4.00.7 low clock rate

    After more testing I had the first disconnects (network not found) also with "WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]". I transferred around 5 GB both ways (wireless<->wired computer) and after this I let my laptop to be connected via wireless more than 24 hours. After 24 hours the first disconnects appeared. The router used is WRT54G v2.2 and WEP 128 bits.

    It seems that the beta 7 firmware with low clock rate doesn't solve the problem completly!!! I really hope that the next firmware will solve it.
     
  59. Cyberian75

    Cyberian75 Network Guru Member

    Any possibility to add a static DHCP feature in the next beta???


    Mike
     
  60. Pibe38

    Pibe38 Network Guru Member

    I have a v2.2 and was not able to install any of these files. 1 second after the update started it said it failed and did nothing.
     
  61. mstombs

    mstombs Network Guru Member

    For those that doubt the authenticity of this source - I can now confirm that I have also received the beta software direct from Linksys -

    WRT54GSV2.1_4.50.5_US_code.zip

    I haven't yet done a byte comparison but dates looks the same etc.
     
  62. xb0xb0y

    xb0xb0y Network Guru Member

    FYI, if you turn off your wireless network in the web control panel, the amber lights turns off! :)
     
  63. jsimmons

    jsimmons Network Guru Member

    When you install a firmware image, it overwrites any previous installed firmware.

    To get the benefits of the new Linksys firmware, you must run it, or wait until the 3rd party firmware gurus incorporate the Linksys "fixes" into their own code base.. Or they incorporate their changes into the new Linksys code base and release their own version.
     
  64. jsimmons

    jsimmons Network Guru Member

    WRT54GS V1.0 - Should I test?

    Does the beta: WRT54GSV2.1_4.05.5_US_code.zip run on the V1.0 version of the WRT54GS ??

    I ask only because I have a v1.0 router and have consistently experienced throughput loss during large file transfers (> several hundred Meg). Link speeds are 54 Mbps at start of transfer and actual throughput is the 20-23 Mbps range. But eventually Link speed drops and drops till it hits 1 Mbps and stays there until I disconnect/reconnect to the WRT. Then speeds are back to normal.... until I do another large transfer.

    If the new beta code will run on the V1.0 hardware, I'll flash it and see if the update resolves my issue - which I know is quite different from the newer HW versions that rebooted under load.
     
  65. MFox

    MFox Guest

    what's the benefit of using the overclock version? is that overclocked by a user or from linksys itself?
     
  66. jsimmons

    jsimmons Network Guru Member

    These beta firmware releases came directly from Linksys. I do not know what raising the clock speed does with respect to the bugs that have been reported. Would be nice to know, though.
     
  67. PingLocalHost

    PingLocalHost Network Guru Member

    Best Security Settings? WRT54GSV2.1_4.05.5_US_code.bin

    Well Long Story Short I bricked my WRT54G 1.1 So I upgraded

    to the WRT54GS 2.0 I did not know about the High Throughput causes

    disconnect until I tried sending big files over the network wireless. The

    New WRT54GSV2.1_4.05.5_US_code.bin beta firmware is great flash and reset

    the router works perfect. In the Wireless Security Settings tested out the

    Security Mode: WPA2 Pre-Shared Key Mixed, WPA Algorithms: TKIP+AES.

    I got my 54g wireless card to connect with the security settings which is

    great my old WRT54G 1.1 WPA I could never get to work.


    I am very happy Thanks to Linksys for the beta firmware and

    Linksysinfo.org and the people that helped push the Linksys beta firmware

    out. Anyone else messed with the security settings?

    I was just wondering what the best and highest security is for the

    WRT54GS v2.0 / WRT54GSV2.1_4.05.5_US_code.bin

    Security Mode:

    I know the WP Algorithms: TKIP+AES is a really nice feature ;)

    -PingLocalHost
     
  68. pharma

    pharma Network Guru Member

  69. dondondon

    dondondon Network Guru Member

    I tried the new beta firmware (high clock version) on my WRT54G v3. I am still getting wireless disconnects.

    I will try the low clock version on the router later tonight.
     
  70. UniqueLink1

    UniqueLink1 Guest

    WRT54GV3.1_4.00.5_US_code.bin Firmware build "IT WORKS

    Hey huys this new firmware build has done the trick for me, It WORKS.......

    I do large manufacturing networks and I was having problems with Wireless Serial lan devices going off line. I put 2 weeks into this and for the last 5 days the units have not dropped offline. Ialso have pumped .5 Meg files back and forth and have had no data lost.

    I just want toy say thanks to everybody for all the info.


    UniqueLink1
     
  71. Argo

    Argo Guest

    Code:
    Antwort von 192.168.1.1: Bytes=32 Zeit=4ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=2ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=2ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=1ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=3ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=2ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=371ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=107ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=90ms TTL=64
    Zeitüberschreitung der Anforderung.
    Antwort von 192.168.1.1: Bytes=32 Zeit=39ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=1ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=1ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=2ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=1ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=1ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=2ms TTL=64
    Antwort von 192.168.1.1: Bytes=32 Zeit=1ms TTL=64
    
    Still timeouts .... :(
     
  72. wreko

    wreko Network Guru Member

    Friggin' Sweet! Would love to see a 3rd party firmware based on that, wpa2 from the original + Dhcpd + more port forwards and all of the other good stuff the 3rd party ones have would be gold! ;)
     
  73. jagboy

    jagboy Network Guru Member

    the new dd-wrt does all this
     
  74. wreko

    wreko Network Guru Member

    Stable or test?
     
  75. jagboy

    jagboy Network Guru Member

    test and it bricked my router
     
  76. gotamd

    gotamd Network Guru Member

    However, hopefully a stable version will be out sometime in the near future :)
     
  77. SimonMackay

    SimonMackay Network Guru Member

    UPnP behaviour with new firmware

    Hi!

    Does anyone know if a router flashed with this new firmware makes itself discoverable in My Network Places like what has happened with the BEFSR41?

    THis is because my WRT54G which is flashed with the latest official Linksys firmware (3.03.6) doesn't seem to use a UPnP "Presentation Page" setup which exposes it in My Network Places. It can be managed by programs that use NAT Traversal and by the Internet Gateway Device Control Point in WinXP.

    With regards,

    Simon Mackay
     
  78. mstombs

    mstombs Network Guru Member

    No the WRT54GS with latest beta firmware doesn't show up on my XP SP2 machine in "My Network places". If I uninstall my software firewall it does show up as an Internet Gatway in "My Network connections" - see further the thread in WRT54 routes on "Internet Gateway dissappearing"
     
  79. dimaki

    dimaki Network Guru Member

    It WORKS !!!!

    Hi,

    the new beta firmware for he WRT54GS works great! No wireless connection errors caused by high throughput any more. I can transfer GBs of data without any error.

    But I also had to reduce the MTU size to 1492.
    Otherwise e.g. a 'ping -f -l 1472 microsoft.com' shows fragmentation.
    (ping size is 28 bytes, so 1472 + 28 = 1500 and that seems too large for my network)
     
  80. orion6192

    orion6192 Network Guru Member

    So... On a WRT54G V3 - is it advisable to try the new Linksys Beta firmware? My biggest issue is the random wireless disconnects. I have a thread under wireless adapters: WUSB54G V4 . I have 2 routers - my phone company sent me another one last night but didn't ask for the 1st one back or send a call tag :) Maybe I get to keep both and play.

    I just want my disconnects to go away!!! I don't know if its the adapter or router - I'm pretty sure now it's the router.

    Your thoughts?
     
  81. MilesTEG

    MilesTEG Network Guru Member

    hello,
    I was having trouble too with wifi...
    I contacted linksys french support by mail ( :? :| :roll: we have only mail or phone...) and they reply me including this firmware : v4.50.5 (WRT54GSV2.1_4.50.5_US_code.bin)
    and they told me to set "Beacon Interval" to 50 (default is 100)...

    And for the 1.5Go transfert I test, and the printing whitch crashed wifi yesterday, they worked without crashing wifi...

    So I hope It will continue...
    And I hope 3rd party firmware will move soon to this source code of the firmware...

    ++
    Miles
     
  82. orion6192

    orion6192 Network Guru Member

    Okay - tonight I downloaded WRT54GV3.1_4.00.7_US_code.bin from the link at the beginning of this thread - I chose the low clock rate version. So here is how the installation went. By the way - I have a WRT54G V3.

    Download bin from http://www.siemens-mobiles.org/linksys/index.php?dir=WRT45G/Official/ and proceeded to update my firmware via the firmware update in the router settings. So... it flashed - it rebooted - I rebooted it myself for 30 secs holding in the button and proceeded to set-up my security setting and SSID and such.

    Here's where the fun begins: Changed the SSID, changed the default password, changed the IP, changed to G only, left it on channel 6 for now and enabled WAP with AES with an 18 character password and enabled MAC filtering and left SSID to broadcast for now. HEY - I've got an amber light behind my Cisco Logo!!! After I enabled my security settings - not before - odd. I was intrigued. I rebooted my computer, made sure my other two computers could connect wirelessly (one laptop one desktop - desktop has WUSB54G V4 with 2.00.0 driver version.) and both connect fine. Life is good.

    Then I see the Amber light - just sitting there... a bump in the night, I push the button concealed behind the glowing amber light / cisco logo and it starts blinking bright white!!!!! WHAT HAVE I DONE!!!! Well - check the other wireless desktop- disconnected! Damn! Checked for wireless AP in the area and one shows up Linksys - a bunch of letter and numbers following it - a strange SSID!!!! and it was open - no security - I connected to it once I clicked on it. I rebooted my main wired desktop and the router by just unplugging it for 10 seconds or so - went into the settings and the SSID was changed and the passkey had changed also but the encryption remained - just didn't really work - odd again. Everything else remain the same - clicked on the SMS button and reset all security settings - just to make sure - when I clicked on G only there was nothing that stayed on the box saying G only - so I clicked on B, it showed up, clicked back on G only and now it showed it, until I hit save. If that is the only issue - life is still good.

    So - hard to test connection without a large time span - so let's try to transfer a large file - a movie - a 4.7GB movie. Transfered in 27 minutes - never stopped, glitched or nothing. WOW - I usually don't transfer large file but did check it before and I could not - so this is nice!!!!

    Now connectivity - disconnected after one hour :( I thought I was onto something.

    I chatted with Linksys techs and this is what told me:

    Roeland V(19468): I would forward the request - expect the firmware within this day - Thank you very much

    So - I leave you with this - what actually is the amber light and why did it blink white when I pushed it and what the hell is up with the disconnects still?

    Just wanted to give my feedback.

    Any further feedback would be great - especially on the damn disconnects!!!

    orion6192
     
  83. enx23

    enx23 Network Guru Member

    WRT45G 4.00.7 BETA Firmware [HIGH CLOCK RATE] works fine!!!

    I've tested "WRT45G 4.00.7 BETA Firmware [LOW CLOCK RATE]" with my WRT54G v2.2 and I had several wireless high-throughput disconnects during one week.

    I've tested "WRT45G 4.00.7 BETA Firmware [HIGH CLOCK RATE]" (file: WRT54GV3.1_4.00.7_US_high.code.bin) and I had no more disconnects during more than one week. Finally my router works fine.

    The beta firmwares are here from here:
    http://www.siemens-mobiles.org/linksys/index.php?dir=WRT45G/Official/
     
  84. enx23

    enx23 Network Guru Member

    Orion6192, you could try this firmware: WRT54GV3.1_4.00.7_US_high.code.bin
     
  85. orion6192

    orion6192 Network Guru Member

    Doesn't the high clock version burn your router out eventually because it's overclocked?
     
  86. enx23

    enx23 Network Guru Member

    Not yet :wink: :wink: :wink:
     
  87. orion6192

    orion6192 Network Guru Member

    I know it's "unofficial"firmware but it is from linksys - is the high clock from linksys also or just the low clock? They still haven't sent me the firmware like they said they would :(
     
  88. dondondon

    dondondon Network Guru Member

    Can't connect to Xbox Live with beta FW

    I have a WRT54G v3 using beta FW 4.00.7 LOW CLOCK.

    Ever since I updated the FW, my Xbox has been unable to connect to Xbox Live. Anyone else experiencing this issue?
     
  89. mr_rmg

    mr_rmg Network Guru Member

    Hi,

    I was having trouble with large wireless data transfer disconnects.

    Linksys WRT54GS, hard wired to modded xbox and wifi'd to PC using a generic 54g dongle.

    Internet was fine but my connection crapped out on large transfers like ISO's and FTP file transfers (from PC to xbox)

    Oddly enough streaming divx etc seemed ok, it was large numbers of files that brought it to its knees.

    I went from HyperWRT latest (with Kai interface) to the beta WRT54GSV2.1_4.50.5_US_code.bin and it now seems to be ok, I will do some more testing tonight. Now I have to work out how to embed Kai into this new beta firmware ;-)

    edit: I havent tried xbox Live yet, but will tonight if I get the chance!
     
  90. shygrouch

    shygrouch Network Guru Member

    Is the WRT54GV3.1_4.00.7_US_code.bin firmware compatible with a v1.0 router. I only ask because someone is trying to help me out with an unrelated problem, and is using a spare WRT54G v1.0 router. Just wanted to check before they risk bricking their router.
     
  91. rtoledo

    rtoledo Network Guru Member

    What program do I need to use to load a bin file tftp?

    what are the commands needed?

    does this software enable WPA-preshared?
     
  92. rtoledo

    rtoledo Network Guru Member

    Re: Best Security Settings? WRT54GSV2.1_4.05.5_US_code.bin

    BE AWARE, that these files ONLY work 100% on HP laptops, I know cause I tried using them on a brand new Gateway 7426gx, and they worked with mixed results and the tray app kept bombing big time.

    I've been going back and forth with Gateway, they sell their top end laptops thru resellers but fail to put ANY download info on the web site.

    I id a backup of the files tha came on the drive , and after installing XP PRO, had a heck of a time reinstalling the drivers and noticed that the wireless drivers are 3.4, but the laptop had 3.7 loaded.

    so far those idiots at Gateway continue to tell me, that they will eventually post it. if this laptop wasn't so kick ass, I would have taken it back the same day.

    and then there's Broadcom, they post ZIP! it's up to the hardware maker or eat S--T
     
  93. jamaica

    jamaica Network Guru Member

    No WPA-PSK does not work. Windows XP SP2 connects and says "Getting ip address" and then disconnects. Had to go back to 3.37.6 since I for one do not want to have an open wireless network. COME ON Linksys :(
     
  94. Juanj

    Juanj Network Guru Member

    SES option on http://192.168.1.1/Wireless_Basic.asp

    Hi,

    I have 2 questions

    1. Whats this for...?
    [​IMG]
    It reports "SES inactive"

    I pressed the green picture with my mouse button... then it reported something like, "now accepting clients"
    but since then i was unable to connect to my wireless network. (a reset was needed)

    Though a wireless network with '_ses_' in the SSID appeared... but my network key (if it was the same i used for WPA) was not accepted..

    Could anybody explain this option to me? a step a step explenation, and also the purpose of this option..

    2. Is there a 4.50.5 for the WRT54G? (v2.0)
    Or is it possible to flash the WRT54GSV2.1_4.50.5_US_code.bin to a WRT54G?


    Greetings
     
  95. mstombs

    mstombs Network Guru Member

    Site Survey page gone?

    Still successfully using

    WRT54GSV2.1_4.50.5_US_code

    &

    http://192.168.1.1/SysInfo1.htm

    till works

    uptime=1319971;

    but what units is this in, seconds I guess?

    But

    http://192.168.1.1/Site_Suvery.asp

    no longer works. You used to be able to search for strings in the .bin file to find the non-linked web pages, but the new .bin file obviously uses compressed web pages , the above no longer works but doesn't 404. Anyone found the new name?
     
  96. aardvark718

    aardvark718 Guest

    i haven't tried it as i don't have that firmware installed but on other devices I have wget -r 192.168.1.1 or equivilent normally works for finding hidden pages
     
  97. Juanj

    Juanj Network Guru Member

    Hi,

    1. What do you mean by "wget -r 192.168.1.1" ? is that a tool?

    2. Does any1 have a awnser to my previous questions? 3 posts ago?
     
  98. mstombs

    mstombs Network Guru Member

    wget is a GNU project to automate retrieval of files over web

    http://wget.sunsite.dk/

    You need to add username and password and output to a logfile to do the command in 1. - but I don't yet see the option to find hidden files...

    2. SES is Linksys' SecureEasySetup

    http://www.prnewswire.co.uk/cgi/news/release?id=141674

    It obviously needs SES clients as well.
    Seems a good idea, but can't this let a hacker in as well?

    3. No there isn't a 4.50.5 for the WRT54G, there are newer (by date) 4.00.7 high clock and low clock versions. The WRT54GS has more memory available so wouldn't expect a happy result from trying to run GS code in a G
     
  99. Juanj

    Juanj Network Guru Member

    Thank you very much for the awnsers... great help!
     
  100. orion6192

    orion6192 Network Guru Member

    I posted the feedback a few posts above - and just wanted to follow-up. I ended up calling my DSL company where I purchased my WRT54G and WUSB54G and explained that Linksys says the USB adapter is not for "long term" connections - that was said from a Linksys Tech after hours of support. They recommended a PCI card - WMP54G - so after talking to my DSK company they swapped out my WUSB54G for a WMP54G - V2!!!!! Not a V4 - the thing is great!!!!! I didn't want a V4 but figured thats what I'd get, I'm still using WRT54GV3.1_4.00.7_US_code.bin and I haven't lost a connection in days (except when use my 2.4ghz phone :( )

    Just wanted to give an update for what's it worth.

    orion6192
     

Share This Page