1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New firmware for RV0xx series x.x.x.19-tm

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Jul 30, 2009.

  1. Toxic

    Toxic Administrator Staff Member

    Cisco are due to release new firmware for the RV042 RV082 and RV016 shortly.



    more info here:

    http://www.cisco.com/en/US/products/ps9923/prod_release_notes_list.html

    Downloads are available here:
    note: you will need to register for a Cisco account (free) to access downloads section.

    http://tools.cisco.com/support/downloads/go/Redirect.x?mdfid=282413304
     
  2. Toxic

    Toxic Administrator Staff Member

    These firmwares have now been released.
     
  3. sterner

    sterner LI Guru Member

    Thanks, I will update the routers and let you know if it fixes the VPN tunnel problems or not....
     
  4. netlinker

    netlinker LI Guru Member

    I tried to download. But yesterday the site would not work at all (some kind of server error message). Today after again digging down through many layers of webpages and disclaimers (why does Cisco have to make this to horribly complicated?) I get the following message. Note: I entered all required information and there is nothing I could add.

    ERROR: Your profile information with us is incomplete.
    Please take note, the Street Address, Country and Email ID are required fields. Kindly update your profile at Cisco.com User Profile.
    After successfully updating the profile, close the current browser session and try to download the software in a new browser session.
     
  5. fermat69

    fermat69 Addicted to LI Member

    I had download firmware flashed without problems but something is going wrong...it does everything fine but time by time (sorry for my english) it restart itself (about an hour or less restarts). I should return to 1.3.12.6 and wait for fixes
     
  6. fermat69

    fermat69 Addicted to LI Member

    Because i had two RV042 working, i flash the remaining and guess what...it´s working fine, without problems. The one that restarts it ends been reflashed with 1.3.12.6 but not without dificulties, because it hangs and only showed the firmware upgrade screen. Flash it and now is ok, but with the old firmware.
     
  7. franki_hk

    franki_hk LI Guru Member

    I have updated two RV042. Both has been worked very well for 4 hours.

    I will then update one RV082 tonight.
     
  8. franki_hk

    franki_hk LI Guru Member

    I have three RV042 and one RV082. Those have been updated the firmware without problem for one day.

    There is only a little bit display problem occurred on one RV042 as previously reported at
    http://www.linksysinfo.org/forums/showthread.php?t=58211

    The upper menu image of the "ProtectLink" icon was corrupted. However, it is only occurred at one RV042, but not at another one.
     

    Attached Files:

  9. fiat

    fiat Network Guru Member

    If you have trouble wading through the Cisco web pages try using Internet Explorer.

    When I registered I used another browser and when I went back to my profile in Internet Explorer I saw options that weren't visible the first time in the other browser.
     
  10. Sfor

    Sfor Network Guru Member

    Indeed. The Opera did not work correctly with Cisco pages.

    Isn't the RV042 firmware based on the Linux code?

    Cisco does not seem to provide the source code and asks to accept a lot of user agreement related forms.
     
  11. sterner

    sterner LI Guru Member

    Anyone here with VPN tunnels between an RV016 and 1 or more RV042 other than myself? I am still having sporadic problems with the tunnels between the 2 different model units using IKE Keying mode, they drop but still show connected in the VPN Summary. When this happens, I get this entry in the logs:

    ignoring Delete SA payload: IPSEC SA not found (maybe expired)

    Has anyone's VPN tunnel problems strictly between RV042 units been resolved?

    Thanks,
    Sterner
     
  12. Toxic

    Toxic Administrator Staff Member

    unfortunately I have no control over Ciscos website, it is a minefield of data and false links. I wish they would just sort it once and for all:)
     
  13. Sfor

    Sfor Network Guru Member

    I've loaded 1.3.12.19 firmware in to two RV042 routers. Everything seems to be working correctly. The NAT traversal problem has been fixed in this firmware. I'm able to connect from an RV042 behind a NAT to another RV042 through a G2G IpSec VPV tunnel, now.

    I do not know if the previous firmware versions were affected, but now I'm unable to block incomming through a VPN tunnel traffic using access rules function.
     
  14. dengrong

    dengrong Guest

    It can't work!

    The VPN connection is still intermittent.
    We use two RV042 at HK. ISP is PCCW. Broadband is ADSL, Fixed IP.
    VPN setting:
    1. IKE with preshared key
    2. Phase1: Group1, DES, MD5, 28800
    3. No PFS
    4. Phase2: DES, MD5, 3600
    5. Aggressive Mode, Compress, Keep-Alive, DPD 10
    I wrote a program to monitor the tunnel, ping the remote gateway every 5 seconds.
    The tunnel will be broken from time to time.
    When it broke, it can't ping the remote gateway, but the vpn_summary.htm shows it is still connecting.
    If click disconnect button on the page, the tunnel will connect again by itself. But after some while, it brokes again.
    This problem exists so long time. From the firmware 1.3.9 to 1.3.12.19.
    Please fixed it ASAP.
     
  15. Toxic

    Toxic Administrator Staff Member

    linux? dont think so it uses OpenRG as far as I know.
     
  16. tdacosta

    tdacosta Network Guru Member

  17. Toxic

    Toxic Administrator Staff Member

    it maybe based on Linux but full source code is not available to compile your own. I think thats what Sfor was referring too.
     
  18. franki_hk

    franki_hk LI Guru Member

Share This Page