1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New Linksys Firmware requiring signed firmware update files

Discussion in 'Linksys Official Firmware' started by Ernest Aleixandre, Apr 30, 2017.

  1. Ernest Aleixandre

    Ernest Aleixandre New Member Member

    Hi everyone, I'm posting this to both DD-WRT and Tomato firmware forums as I believe this affects all of us.

    I have a Linksys EA6500 v2 router, but I think my problem isn't specific to my router but to new Linksys firmware in general. I saw another similar post on DD-WRT forums related to the EA8500 having the same problem.

    In short, I'm running the latest Linksys firmware on my router: 1-1-40 build 176451.

    I tried flashing it with Tomato and then DD-WRT. Both firmware uploads resulted in the router saying: Invalid Firmware File This firmware file won't work on this router. If you downloaded it from linksys it might have become corrupted.

    In the other thread talking about an EA8500 router, someone mentioned that Linksys is now signing their firmware files and the router requires the downloaded firmware to be signed or it won't flash it. I contacted Linksys this morning and confirmed that lucky me, my current firmware is the first firmware requiring that firmware files be signed, so there is no way for me to upload either DD-WRT or Tomato from the web interface.

    I located the previous firmware version through Archive, but I get the same error trying to flash the router to an older Linksys firmware. Even tried uploading the older Linksys firmware via T-FTP and the T-FTP program errored out saying: Unable to get responses from the server. Had a static IP and everything set and could ping it.

    I'm out of ideas. Anyone have any idea how to flash this router to an older non-signed Linksys firmware that doesn't require firmware files to be signed so I can get DD-WRT or Tomato working?

    Thanks,

    Ernest Aleixandre
     
  2. _s3n0_

    _s3n0_ New Member Member

    Hi there,

    please don't remember to do a factory reset (erase NVRAM) - before and after flashing too (just to be sure). Many manuals include the warning about the factory reset and/or NVRAM reset.

    Flashing over the T-FTP protocol is more complicated. You must use the one TP cable connected between your PC and router. Your PC must have a fixed (static) IP address set up. Which operating system you want to use for connect to the router? What procedure did you use for T-FTP? Did you follow all the steps?
     
  3. RMerlin

    RMerlin Network Guru Member

    Linksys will no longer support third parties firmware on their Smart WiFi products. Only the WRT product line will be supported.

    Sent from my Nexus 5X using Tapatalk
     
    Jose C likes this.
  4. Ernest Aleixandre

    Ernest Aleixandre New Member Member

    Thanks for the help... I managed to to use the router's restore previous firmware function under troubleshooting. that reverted me to a pre digital signature firmware.
     

Share This Page