1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New official NAS200 Firmware 3.4r79

Discussion in 'Cisco/Linksys Network Storage Devices' started by Mercjoe, Jul 20, 2009.

  1. Mercjoe

    Mercjoe Network Guru Member

    Things are so slow around here that we seemed to have missed it.

    Here is a changelog:

    V3.4R79
    1. Update Media Server to fix the interoperability issue with PS3.
    2. Fix the issue that no email notification when disk failure is detected under RAID-1.

    Not much but it is nice to know that they still think of us.

    Here is the link:

    http://www.linksysbycisco.com/US/en/support/NAS200/downloads
     
  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    It came out while I was on vacation, that why I didn't know until last week. :wink:

    Anyway, I downloaded the tarball and unpacked it, and already ran into a few problems. First of all, it generates a number of errors when you try to unpack it: "Cannot open: Not a directory". As far as I can tell, the Linksys (Sercomm?) engineers updated the tarball after it was created, so sometime during decompression, symlinks are created in two locations (as far as I can tell) that tar -x later tries to use as directory. A tar -d (=diff) yields no problems so I'm going to assume that the errors can be ignored.

    Next, when trying to compile, I ran into two familiar problems: the first is that the kernel compilation barfs on scripts/mod/sumversion.c because MAX_PATH is undefined. Simply adding #include <limits.h> fixes that one. The second problem is that at the end of the build, source/mksquashfs doesn't run on my system. This is also easily fixed by running make in the squashfs-tool directory and placing the resulting mksquashfs in the source directory.

    I haven't checked if the binary that results from this compile will actually install and run; I see a large number of files and directories that have a fairly recent timestamp, which might be a sign that a number of bugs were fixed. I haven't had the opportunity to run a full diff between R75 and R79 yet so I don't know if a self-compiled R79 will install successfully. If you remember correctly, the R75 source tarball was missing a bunch of stuff so it compiled correctly but bricked the NAS as soon as you tried to install it. Ouch! I will make sure that doesn't happen this time...

    I intend to do a diff between the R75 and R79 sources to find out what's different, and if I'm confident that a self-built R79 won't brick your NAS, I'll let you know. I'll probably make a Jac3 release before I return to work on OpenWRT.

    ===Jac
     
  3. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Differences between R75 and R79

    I ran a diff between the source tarballs of R75 and R79. Here are some conclusions:
    • Apparently Sercomm wanted to make sure that we know it was them (not Linksys) who put the firmware together. They added headers to many source files asserting their ownership.
    • They are also making a genuine effort to comply with the GNU GPL and other licenses. The COPYING files which were missing from some projects, were restored, and in one instance (tzo_ddns sources) the license text that had been deleted from a header was restored too. Furthermore, they created a file with all the license texts.
    • The tarball contains the Crosstool sources which were previously distributed separately. Also the ecos tree contains sources for the toolchain that was used to compile it. Unfortunately this makes the source tarball more than 400MB, about twice as big as R62 and R75, for which Crosstool was distributed separately.
    • All the scattered CVS directories that were part of the R62 and R75 tarball are no longer there.
    • The Busybox build system was cleaned up a little; unfortunately "make menuconfig" still doesn't work...
    • Instead of the "date" subdirectory there now is "sh-utils-2.0.15".
    • Instead of the "sfdisk-3.07" subdirectory there now is "util-linux-2.10m".
    • The target-default.tgz file which contains the root file system, has been updated and appears to contain what it's supposed to contain, including the updated Twonky server.

    After making some small changes (see previous post) to make the compilation succeed, the tarball builds to a working binary that can be downloaded to the NAS200. The Twonky server can be controlled from the Twonky Media Manager (you still have to use the NAS200 web GUI to set the media directories)

    Conclusion: Sercomm did a much better job wrapping up the R79 release than the R75 release. I had the feeling that R75 was rushed out (it was sloppy in some places and it took a while before the sources were online and then it still bricked your box if you compiled it), but with R79 they put in some effort to deliver a project that looks finished. Enthusiasts can build their own firmware (they way they're supposed to be able to) and it will work, pretty much out of the box. It doesn't really matter if this is because there were only a few requirements for this release (basically just a Twonky update for PS3 owners and some bug fixes), or because EFF is suing Cisco/Linksys for GPL compliance.

    A big :thumbup: thumbs up from me on this release. Well done Linksys and Sercomm!

    ===Jac
     

Share This Page