1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New Release: V23 beta 21.11.2005 Bug Reports Here!

Discussion in 'DD-WRT Firmware' started by Cyberian75, Nov 21, 2005.

  1. Cyberian75

    Cyberian75 Network Guru Member

    21.11.2005:
    - openvpn tunnel route introduced
    - dnsmasq lease delete recoded, handling of lease files improved
    - various build oriented problems fixed
    - changed kernel module handling to get down the binary size

    0000232 VPN Version (11/18/05) disconects...
    0000231 VoIP-Version on 18/11/2005 bricked WRT54GS !!!
    0000229 DNSMasq seems not to give out IP addresses (Nov 18)
    0000242 Disabling logging
    0000240 can't connect via https
     
  2. 4char

    4char Network Guru Member

    I think the FTP uploading has problem. It stuck at uploading voip zip file for a while now. None of zip files are complete yet. :sad:

    All the files are available now. :thumb:
     
  3. Toxic

    Toxic Administrator Staff Member

    your downloading the file as it is being uploaded. be patient.
     
  4. BrainSlayer

    BrainSlayer Network Guru Member

    no bug yet?
     
  5. onesolo

    onesolo Network Guru Member

    Hello,
    I'm fairly new to this type of firmware. I have a wrt54gs v1.1 and some days ago I just updated from the latest original firmware to the last dd-wrt firmware. I loaded the mini version cause I updated it from the webinterface. Now I want to upload a non generic firmware. Do I have to do it by tftp?? Can anyone explain me how to do it (the command) ?

    I tried tftp PUT name_of_file ip_of_router but didn't give me positive result.
     
  6. Toxic

    Toxic Administrator Staff Member

    if your using ddwrt firmware now then you can use the gui interface to upgrade again.
     
  7. Couledouce

    Couledouce Network Guru Member

    Mini seems to be working fine on my WRT54G v2.0 with WDS WEP.

    Only thing I noticed was that the font size of the GUI is larger, don't know if that is intentional?

    Thanks BrainSlayer :clap:
     
  8. Cyberian75

    Cyberian75 Network Guru Member

    I've used the web interface to flash the standard edition with no problems.
     
  9. 4char

    4char Network Guru Member

    I flashed the gs std version (gs v3 router) and it seems the dnsmasq is ok for the wired client. But I'm having trouble getting IP for wireless client. It timed out waiting for the DHCP/dnsmasq (I tried both setting, with or without "Use DNSMasq for DHCP" checked) to give out IP.

    The 11/18 version (same setting), at least gave out IP with DHCP for wireless client.

    Anyone else?

    Thanks
     
  10. MattLL

    MattLL Network Guru Member

    I am new to all this wireless stuff and I sorta dove into all this head first....I have a wrt54gs and a wusb addapter only for about 3 months. I was informed of the DD-WRT upgrade and decided to give it a try..So far it seems to be working great..I have 100% signal and a solid 54mbs to my 2nd pc......The only glich I have encounterd is that the router will sometimes give a NO ACESSES or a Limeted Acesses to the net....I enabled the WDS/Connection Watchdog and so far no disconnects......Is that gonna be a problem that is gonna be fixed in the next firmware upgrade?
     
  11. Cyberian75

    Cyberian75 Network Guru Member

    That's probably due to a bug with the DHCP Server. Try configuring each computer with static IP addresses. This way, the router doesn't have to assign them every time it reboots or detects a client on the network.
     
  12. groupdelay

    groupdelay Network Guru Member

    Strange issue with Factory Reset on WRT54GS

    Upgraded to this latest version on my WRT54GS v2.0 and all went fine, until I did a factory reset (after the upgrade). After the reset it now indicated is was a WRT54G and no longer a WRT54GS, in the status menu. The Cisco light in front ceased working. It did read fine before the factory reset. Tried doing hard reset on rear of unit and it really hosed the router up until I let it sit with no power for a few minutes. Re-flashed back to HyperWRT and did a factory reset and got it back to indicate it was a WRT54GS in the status menu.

    Any ideas?
     
  13. matthiaz

    matthiaz Network Guru Member

    Where do you find that status-menu?
     
  14. Sjowhan

    Sjowhan Network Guru Member

    Flashed this morning, got no disconnects yet (it was more than 5 each day with the 10.11 version).
    No problems so far..
     
  15. sufrano63

    sufrano63 Network Guru Member

    UPnP is not working. Can someone confirm?
     
  16. 4Access

    4Access Network Guru Member

    Found a bug. When in Client Bridge mode the 'Setup -> Basic Setup' page looks like...

    This in Firefox 1.0.7:
    [​IMG]

    And this in IE6:
    [​IMG]

    I'll open a bug report if someone can confirm. (I was testing with a WRT54G v4)
     
  17. gaster

    gaster Network Guru Member

    I saw the DHCP menu under IE in the 18-11-05 build for Client Bridge mode too. I did not check in Firefox though.
    Once I disabled the DHCP server the router has been working fine though.
     
  18. daenigma

    daenigma Network Guru Member

    I am sorry the trouble I was having was due to downloading and installing the October 21st build so the problems below can be ignored... with the exception of "if I try to enable the internet UPnP icon in my network places then the icon will go away and the UPnP daemon will crash and restart" this is using the Nov 23rd build.

    I also seem to have a problem with UPnP which is odd... The router gets the port mapping but it does not seem to route the data. This is with the Nov 21st build, but with the Nov 18th build it worked fine except if I tried to enable the internet UPnP icon in my network places then the icon would go away and the UPnP daemon would crash and restart.
     
  19. Chryx

    Chryx Network Guru Member

    I've got a glitch with firmwares since Brainslayer redid the config file format (I've been hard resetting and reentering settings manually - so it's not that, but that's when it started happening) where things will time out regularly, large downloads are impossible to finish, that sort of thing...

    suggestions?

    rolling back to a build from the beginning of the month fixes it btw.
     
  20. MattLL

    MattLL Network Guru Member

    I will give that a try as soon as i get some more free time.
    I will let ya know if that will keep me online without the connection watch dog
     
  21. Killermac

    Killermac Network Guru Member

    I am using a WRT54G V4.0 and flashed using the mini generic 21/11 build and it has been up and running for 24hrs without any issues. I have wireless MAC setup and working using WPA preshared key and no issues. All of my DHCP clients recieve addresses with out a problem.

    Km
     
  22. lore

    lore Network Guru Member

    Does it provide an IP address promptly (i.e., less than 5 seconds) or does it take 15-30 seconds?
     
  23. Cyberian75

    Cyberian75 Network Guru Member

    I'd keep using the Connection Watchdog. It is very useful indeed!
     
  24. gaster

    gaster Network Guru Member

    I flashed my Motorola to the 21-11-05 and tried to set it up in Client Bridge mode. It would not work for some reason. I flashed back to 18-11-05 and it worked.
    It's possible I made some mistake, but I thought I had the right settings each way. Anyone else with this problem?
     
  25. 4Access

    4Access Network Guru Member

    I don't have a Motorola but Client Bridge mode worked on a WRT54G v4 with WPA here. (Although there was a display problem as I noted a few posts above.)
     
  26. Cyberian75

    Cyberian75 Network Guru Member

    JFFS seems to be read-only.

    Can anyone confirm?
     
  27. StoneRoses

    StoneRoses Network Guru Member

    Mine works well, I just install new kaid on JFFS (21-11 mini) and it runs fine.
     
  28. LiOn

    LiOn Network Guru Member

    I'm using Beta build from 21.11 on WRT54G V3.1 and router hangsup every few hours?!? The router not responds and I must do Power Off/On to get it online again. Linksys logo is up all the time but router is dead. After Power Off/On everything is back to normal for few hours and then hangup again. Anyone else have simmiliar problems?
     
  29. Sjowhan

    Sjowhan Network Guru Member

    Well, since i'm using dd-wrt, i got many disconnects every day. That wasn't when using the official linksys firmware.
    The router reboots, and losts for a few seconds the internet connection.
    I have a WRT54G V2.2
     
  30. Josito

    Josito Network Guru Member

    inconsitent dataflow

    I had v22 prefinal 5 talismen, 2 routers on wds yesterday I updated the firmware to v23 beta 2 21.11 and now I get very strange signal in netstubler as well as inconsistent data flow with dumeter, 10 kbs downloadn then 0 then 15 then 0 then 7 then 0 , very stranget, this issue is happening with my intel 2200 bg , with the senao 2511 it happens but less.

    As well the gui stops working and I cannot do telnet to the router connected to the internet.

    Also when I open the 192.168.1.1 in the innet the page is loading by parts, that I assume is due to the inconssitency of the data flow
     
  31. Krip

    Krip Network Guru Member

    I'm using a GS v1.1 and around once a day my net access starts to crawl, web sites are very, very slow to come up and often timeout. Sometimes, during this time, I cannot use the routers web UI.

    The issue is fixed by telnetting into the router and rebooting. Everything is then fine again for another 24 hours (ish).


    K.
     
  32. GoldServe

    GoldServe Network Guru Member

    Alot of ppl are getting tripped with the low number of active connections. Set it to 4096 and timeout to 120 and enjoy!
     

Share This Page