1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New Victek releases

Discussion in 'Tomato Firmware' started by mpegmaster, Jul 2, 2009.

  1. M_ars

    M_ars LI Guru Member

    A second dhcp would be the best solution but with the possibility to connect the "guest network/ssid" to the "private network"
    By default i would isolate both networks/ssids
     
  2. Low-WRT

    Low-WRT LI Guru Member

    Is there a version available for the RT-N12 that includes VPN?
    The only one I see is NO USB + CAPTIVE PORTAL.
    NO USB + VPN would be great:biggrin:
     
  3. Victek

    Victek Network Guru Member

    No USB + NOCAT + VPN available now .. updated.
     
  4. Low-WRT

    Low-WRT LI Guru Member

    :bow::bow::bow:
     
  5. The Master

    The Master LI Guru Member

    @victek...

    where is the new version.. i am blind ..sorry?!
     
  6. Victek

    Victek Network Guru Member

  7. The Master

    The Master LI Guru Member

    sorry then i misunderstood the "nocat" info. i looked for a NO Captive Portal Version because i don´t need it and i take a lot of ram :D

    bdw whats new??
     
  8. Victek

    Victek Network Guru Member

    Sorry, nocat don't dismiss RAM if you don't activate... it's loaded as module. If you compare size from diferent releases you can see small dif.
     
  9. The Master

    The Master LI Guru Member

    ah ok...

    so nocat=captive portal....
    my problem is that the adblock script use a lot of ram and with the nocat i have to disable 1 host list...
    my problem would be solved if there is a tomato version for the e1000 V2 :D... but there will be no update from any progger...:(
     
  10. szfong

    szfong Network Guru Member

    Thanx.. I was restricting my MIPS1 routers to K24 editions cuz I got the impression that the newer wireless drivers & kernel had stability issues with older hardware.

    So, it is no longer the case? I still have 2 whr-hp-g54 and 1 WRT54G v2 rev xh (4MB flash, but 32MB RAM)... These are fairly old units though....
     
  11. Victek

    Victek Network Guru Member

    Give a try ... surprise!
     
  12. seraphsf

    seraphsf LI Guru Member

    I will chime in and say that Tomato RAF. Captive Portal. Last Release. K-2.6.22. MIPSR1.(NO VPN) has been working for me on my WRT54GL. Previous K-2.6.22 did not work for me at all but not this one. I upgraded from K24 1.28.8515 and my only problem was a failure to do a NVRAM erase but once that was done it is as responsive as before.

    Great job Victek!

     
  13. Victek

    Victek Network Guru Member

    Thanks for the feedback, I tested deeply to ensure a new life for WRT54Gx routers, I'm happy to see how our old router survive :wink:
     
  14. kthaddock

    kthaddock Network Guru Member

    HI Victek

    Firs I must thank you for a very good sw, I'm using 057 AIO on RT-N16 for the moment.

    Is it possible to update "Limit Connection Attempts" I have written about in this tree: http://www.linksysinfo.org/forums/showthread.php?t=66872
    It's a good solution to use "recent" module and "bruteprotect" function.

    regards
    kthaddock
     
  15. kbsao

    kbsao Networkin' Nut Member

    Hi Victek,
    Can i have the Tomato RAF 1.28.9006 (ONLY FOR 8MB Flash (MIPSR2.Kernel 2.6) Extended + VPN + USB + Captive Portal) for Asus N16 in ND version?

    Currently i am using Tomato_RAF-K26-USB-1.28.8650MIPSR2_RAF-VPN.

    Thanks.
     
  16. seraphsf

    seraphsf LI Guru Member

    I spoke too soon about the stability on WRT54GL. I have had the router lock up twice in the last 4 days. It works for about two days before it locks up. I'm not sure what is causing it but the router would remain stable and then I can't even access the Tomato web pages. This forces me to unplug the router which causes me to lose any logging that might have shed any light on the issue.

    Anyone using the latest 1.28.9006 build successfully on WRT54GL?
     
  17. M_ars

    M_ars LI Guru Member

    I upgraded my old WRT54GL like two days ago. Running great. but i have to say, that the router is turned off by night, so the wrt is runnung only 8-12 hours every day...
     
  18. The Master

    The Master LI Guru Member


    i had the same problem.... my problem was the adblock script... i used list 1-4 @ the script but now i have not enouth ram to have list 4 with the new fw.
     
  19. MaX PL

    MaX PL Networkin' Nut Member

    hey folks,

    just upgraded to tomato raf 1.28 from dd-wrt after endless stability issues with my E3000.

    came here through some google stalking of Vitek, lol.

    anyway, running fine right now, but my i cant get it to run at 300Mbps. have it at 144Mbps after setting it to 40Mhz with AES encryption just like i did with dd wrt to get 300Mbps.
    the basic page shows 40Mhz as the channel width yet the overview page shows 20Mhz, so i guess that's the problem.

    is there a way to fix this? I've tried power cycling but that didnt help.

    are resets and power cycles like with dd wrt? 30 seconds for power cycles and 30-30-30 for resets?

    thanks
     
  20. seraphsf

    seraphsf LI Guru Member

    Thanks for the feedback The Master. I am also using the adblock script using the top four lists. I'll try it without the four scripts and report back.
     
  21. QSxx

    QSxx LI Guru Member

    If you remove every single one of scripts, adblock script won't work. What you might try to do is lower it's memory footprint - try getting only no 1, then add 2 and optionally 3. all four of them won't work unless some serious cutting is done in RAF.

    Best idea would prolly be to make new build for WRT54G based on K2.4 since kernel 2.6 just eats up too much memory...

    I own one WRT54G V2 core_rev=7 and i run it on old RAF since i can't use newer ones (with adblock script)...
     
  22. MaX PL

    MaX PL Networkin' Nut Member

    uhhhh.

    so i reset the router, cleared the nvram, and fixed the 40mhz issue.

    15 hours later and it changed to showing 20Mhz again and limiting me to 144Mbps.
     
  23. landa

    landa LI Guru Member

    I tried 1.28.9006 on a WRT54GL, but unfortunately, performance is reduced and the processor load is 1.39 / 0.90 / 0.52 with a 3.5mB/s download (this is the max download speed WAN -> LAN with this vers.) Now I use 1.28.121006 witch is the best!
     
  24. seraphsf

    seraphsf LI Guru Member

    After two days of running RAF 1.28.9001 MIPSR1_RAF_NOCAT K26 Std on my WRT54GL with the AdBlock script (minus one of the large host files) the router looks stable again. My processor load is around 0.20 / 0.08 / 0.02 with about 2MB free memory.

    I'll continue to monitor the stability but performance looks good to me thus far.
     
  25. Victek

    Victek Network Guru Member

    landa ... erase nvram please, this version is by far more stable and perform better than 121006 ...
     
  26. landa

    landa LI Guru Member

    I erased the NVRAM after I installed and I manually configured the router. Is not the first time I do this and I am familiar with the process.
     
  27. sppmaster

    sppmaster Networkin' Nut Member

    Can I use this version - Tomato RAF 1.28.9006 Captive Portal. Standard version + Captive Portal for WRT54GL/Buffalo/Ovislink WL1600G and non USB routers. Dated June, 13th, 2011
    on my WRT54G hardware version 2.2. I have two of them in WDS.
     
  28. kbsao

    kbsao Networkin' Nut Member

    Hi all,
    i tried to install Tomato RAF 1.28.9006 (ONLY FOR 8MB Flash (MIPSR2.Kernel 2.6) Extended + VPN + USB + Captive Portal. Updated June 13th.2011. For RT-N16/WRT610N) into the Asus N16. but i hardly to access the admin page, is it caused by the driver issue?

    The N16's wl0_corerev is 17, but the installer stated it is for RT-N16. i am not sure i using the correct version?

    Currently i am using Tomato RAF v1.28.8650 MIPSR2_RAF K26 USB VPN without any problem.

    Thanks.
     
  29. Victek

    Victek Network Guru Member

    kbsao, no reason for this behaviour, did you erased nvram prior/after firmware update? did you clean cookies in your browser?, please do.
     
  30. Victek

    Victek Network Guru Member

    sppmaster, sure. use it, good luck and enjoy it!
     
  31. kbsao

    kbsao Networkin' Nut Member

    I did click the erase tick box and I do telnet in erase and reboot the device.
    I am having any issue with tomato USB build 54, but I having the same
    issue in toastman and tomato RAF release.. Except the release I mentioned just now.

    Thank for your reply. I already took few weeks to research about this issue. I tot is ND version issue?
     
  32. kbsao

    kbsao Networkin' Nut Member

    I have installed the Tomato RAF 1.28.9006 (ONLY FOR 8MB Flash (MIPSR2.Kernel 2.6) Extended + VPN + USB + Captive Portal. Updated June 13th.2011. For RT-N16/WRT610N).

    I had try few laptop and mobile device trying to access the admin page.
    so far only IPhone is able to access the page within a second.
    Others browser such as Firefox 5,Chrome 12,Safari, IE and Android browser are hardly to access the admin page. it just able to go in single page by around 30-60 seconds tho LAN/Wifi

    But IPhone and Android are able to access the admin page tho DDNS smoothly.

    Others feature like network speed,Samba and Optware are working perfectly.
     
  33. sppmaster

    sppmaster Networkin' Nut Member

    1. Unfortunately after flashing /tomato-K26-1.28.9006MIPSR1_RAF-Std-NOCAT.trx/ I cannot access the web interface anymore. I have erased all data in nvram memory (thorough) before flashing. I have cleared browser cookies, temporary and session files. Tried with IE8, FFox 5, Chrome 12. None of them works. Router responds to ping.
    I have no idea what's going on.
    2. If I flash the router without erasing nvram it keeps the settings from previous firmware and works properly, but I am unable to access the web interface either.
    Fortunately, I was able to revert to previous firmware. Telnet and TFTP saved my day.

    I have to say that, in scenario 2, I am able to access the web interface only remotely via https /with preserved settings/. Access from my LAN /192.168.a.b/ is impossible.
    Any idea, Victek?
     
  34. valerima

    valerima LI Guru Member

    flash

    I did not try this either, but after last reflash with Toastman's firmware router e3000 behave similarly.
    It revived after I turned off and on fiber cable device.
    However recently this week I read on this forum that before rebooting it is important tick auto DHCP. I did not try it though.
    However last flash time prolonged for me up to 15-20 minutes. Was a bit scared.
     
  35. valerima

    valerima LI Guru Member

    Here is message of Toink from 15 of June

    You can try Toastman's build 1.28.7475.4 http://www.4shared.com/dir/v1BuINP3/...lds.html#dir=0 just make sure you select the file which explicitly say E4200 in the file name like tomato-E4200USB-NVRAM60K-1.28.7475.4MIPSR2-Toastma n-RT-Ext.bin

    CAUTION: You should enable DHCP immediately in Toastman's latest builds to save you some IP assignment troubles...

    Installing Tomato firmware from Linksys' stock firmware is a breeze.

    1. Reset your router to it's original settings.
    2. From the Linksys' WEBGUI select upgrade and load the tomato-E4200USB-NVRAM60K-1.28.7475.4MIPSR2-Toastma n-RT-Ext.bin.

    3. The update will take around 3 minutes --- just wait and let your router reboot and wait until the power LED has stopped blinking.

    4. Now go to Administration Tab

    5. Select Configuration. Under restore default configuration, select ALL DATA in NVRAM (thorough). click ok and wait for a couple more minutes.

    6. Your E4200 is now running Tomato. Final step is to enable DHCP in BASIC TAB. Click Save.

    7. Now you can tinker with your Tomato router settings...
     
  36. eahm

    eahm LI Guru Member

    valerima, ...the latest, and the one you linked, is 7476.
    Anyway, I thought this thread was for victek builds only?
     
  37. Victek

    Victek Network Guru Member

    sppmaster, please could you tell me your router model? I think you're talking about WRT54G .. ?
     
  38. sppmaster

    sppmaster Networkin' Nut Member

    Yes. That's it.
     
  39. valerima

    valerima LI Guru Member

    flash

    Well , yes, it is not really suited to your router, but I see that guidance should be helpful in majority of cases.
    I do have e3000 and will try this on next time when flash.
     
  40. Victek

    Victek Network Guru Member

    git updated with BusyBox 1.18.5 and CTF patch for BW limiter to avoid MARK break. I will create new Beta releases 1.28.9007.

    . Available for 4MB Flash non USB router MIPSR1 (Wrt-54GL and equivalent model).
    . Available for 8MB Flash USB router MIPSR2 (RT-N16 and equivalent model).

    Changelog: Read 'What's new.txt' file.

    Feedback Please.
     
  41. valerima

    valerima LI Guru Member

    e3000

    Waiting for e3000 suitable build...
     
  42. Victek

    Victek Network Guru Member

    valerima, beta test will be done with 'easy to recover' units, once it's tested release to other units will be easy. I don't have an e3000 to test myself.

    Best Regards
     
  43. sppmaster

    sppmaster Networkin' Nut Member

    Victek, all that I succeeded to view was this
    [​IMG]
    I've flashed my WRT54G v. 2.2 with the latest beta.
    K26-1.28.9007MIPSR1_RAF-Std-NOCAT(WRT54GL_4MB_FLASH).trx
    Most of the time, when I try to access the web interface, I only receive "Connection timed out".

    Edit: I have a partial success. If I click on reload page button several times the page sometimes opens.
     

    Attached Files:

  44. eahm

    eahm LI Guru Member

  45. Victek

    Victek Network Guru Member

    sppmaster,

    Update: I ran it in WRT54G V2.2, it works ... please use another browser.. (Chrome for instance) and test again. You had similar problems when you tested other releases?.. what browser do you use?

    [​IMG]
     
  46. sppmaster

    sppmaster Networkin' Nut Member

    Hi. I tried IE8, Firefox 5 and Chrome 12 as described in this post.
    http://www.linksysinfo.org/forums/showpost.php?p=377519&postcount=1053
    I think this issue is specific to my environment only, but I couldn't guess what the reason is.
    I am able to access the web interface remotely via https without any delay, but not from my LAN network. If I click on reload page button several times the page sometimes opens, but most of the time, when I try to access the web interface, I only receive "Connection timed out". Don't know what to do :huh:
     
  47. Victek

    Victek Network Guru Member

    let's start.. type netstat from cmd and verify what machines are using port 80, disable security suite, firewall if you have any..
     
  48. vanhh

    vanhh Network Guru Member

    Any browser's ad blocking or noscript running? picture show here looks like it has been blocked by noscript or an ad blocker.
     
  49. sppmaster

    sppmaster Networkin' Nut Member

    I've disabled AV, Windows firewall, adblockers.
    Here are the results. The picture is small but I think if you zoom you can see from netstat - 192.168.1.240 syn_sent. Still doesn't open. On the other hand I have netstat - 192.168.1.230 established /second WDS router running Tomato Firmware RAF1.28.121006/.
     

    Attached Files:

  50. motoolfan

    motoolfan Guest

    Which f/w

    For the Netgear WNR3500L/U/v2 ?

    Thanks,
     
  51. valerima

    valerima LI Guru Member

    Previous Viktek's build for e3000

    Dear Viktek,

    1. Where we can find previous your builds available, please?
    some members of my household complain the f/w use now and wants to back to previous of yours...Some of them fit extremely well....

    2. Could we have possibility also to try some more simple builds as -"ext" for example if some exclusive features are not used for the moment...

    Thank you so much .
     
  52. sppmaster

    sppmaster Networkin' Nut Member

    OK. After playing around with AV, Firewall, adblockers, etc., I have finally found what went wrong. WinXP Manager has modified default settings of WinXP for MTU-size, Windows TCP/IP Window Size and TCP/IP Timeout Life. I reset them and now it just rocks!
    Thanks.
     
  53. Victek

    Victek Network Guru Member

    1. Tell me what build do you need, after beta test of new version old build is deleted but I keep one copy.
    2. Extensive feature not used are inactive in the build, don't worry about, simply do not activate.
     
  54. shadowken

    shadowken Networkin' Nut Member

    @ Victek
    I have Tomato Firmware RAF1.28.9006 MIPSR2_RAF K26 USB VPN-NOCAT on Linksys E3000 and happy with it but i noticed that the BW limiter for the upload doesn't work + it seems the routing table in this build might be not right as it looks in the attachment .

    If you could please fix those :)
     

    Attached Files:

  55. Victek

    Victek Network Guru Member

    Please try 1.28.9007 in the beta area in my site and repport back please.
     
  56. shadowken

    shadowken Networkin' Nut Member

    Can i use this tomato-K26USB-1.28.9007MIPSR2_RAF-VPN-NOCAT(RT-N16_8MB_FLASH).trx for Linksys E3000 ?
     
  57. kthaddock

    kthaddock Network Guru Member

  58. Hexxer

    Hexxer Networkin' Nut Member

    Hi,

    cant find a answer - sorry.
    Im running latest tomato (v1.28.9052 MIPSR2-beta23 K26 Std) - can i flash that latest Victek relase (tomato-K26-1.28.9006MIPSR2_RAF-Std-NOCAT.trx) on my WRT160N ? Or do i have to do some extra steps bevor ? I like to test it but im not sure how to flash.

    regards
     
  59. Victek

    Victek Network Guru Member

  60. quirK

    quirK LI Guru Member

    How do I set up the tc-atm feature for ADSL?
     
  61. Victek

    Victek Network Guru Member

    Your model and firmware version? .. give more data... not blind questions..
     
  62. valerima

    valerima LI Guru Member

    migration back to Raf

    Migrated back to last build for e3000.
    Candy...
    Everything passed smoothly. fast and no worries.
    What a pleasure.
    Thank you Vicente!
     
  63. Hexxer

    Hexxer Networkin' Nut Member

  64. Victek

    Victek Network Guru Member

    Yes, steps between:
    - Change extensión .trx to .bin for the file to upgrade.
    - Erase nvram after upgrade and reconfigure by hand again, do not restore previous configuration.
    - And use search function in the forum for basic question...
     
  65. dart451

    dart451 Addicted to LI Member

    Linksys v2 help

    Victek,

    Hi, it's been awhile since I've been on the forum. Trying to find latest Linksys WRT54G v2 firmware for a friend. Can't seem to get your Victek link to work anymore...is there a problem with it? Absolutely love your E3000 firmware...runs flawlessly!
    Best Regards,
    Keith
     
  66. Victek

    Victek Network Guru Member

    Maintenance ... and changes :)
     
  67. dart451

    dart451 Addicted to LI Member

    Kinda what I thought! Thank you for the reply...I'll wait...no big hurry. Thanks.
     
  68. seraphsf

    seraphsf LI Guru Member

    I'm running RAF1.28.9006 MIPSR1_RAF K26 Std-NOCAT on my WRT54GL Broadcom BCM5352 chip rev 0 pkg 2. It has been running for the last 13 days without any issues, but I did notice an out of memory warning in the logs this morning. I am running the ADBLOCK script and I disabled one of the larger host files which was causing the router to reboot due to memory issues.

    Based on the log below is there something else on the router I can configure to limit this issue? THANKS!

    Code:
    Jul 11 04:00:02 tomatoRAF daemon.info pixelserv[824]: 31332 requests, 26 errors, 188 bad, 17676 gif, 13442 txt replies
    Jul 11 04:00:07 tomatoRAF user.notice root: ADBLOCK: http://pgl.yoyo.org/as/serverlist.php?hostformat=nohtml
    Jul 11 04:00:08 tomatoRAF user.notice root: ADBLOCK: http://mirror1.malwaredomains.com/files/justdomains
    Jul 11 04:00:09 tomatoRAF user.notice root: ADBLOCK: http://www.malwaredomainlist.com/hostslist/hosts.txt
    Jul 11 04:00:12 tomatoRAF user.notice root: ADBLOCK: whitelist http://dl.dropbox.com/u/1111111/whitelist.txt
    Jul 11 04:00:23 tomatoRAF user.notice root: ADBLOCK: 17677 entries
    Jul 11 04:00:23 tomatoRAF user.notice root: ADBLOCK: sorting hosts...
    Jul 11 04:01:43 tomatoRAF user.warn kernel: eapd invoked oom-killer: gfp_mask=0xa01d2, order=0, oomkilladj=0
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Call Trace:[<c02874b0>][<c028740c>][<c032d3f0>][<80001500>][<80001688>]
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Mem-info:
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Normal per-cpu:
    Jul 11 04:01:43 tomatoRAF user.warn kernel: CPU    0: Hot: hi:    0, btch:   1 usd:   0   Cold: hi:    0, btch:   1 usd:   0
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Active:1057 inactive:135 dirty:0 writeback:0 unstable:0
    Jul 11 04:01:43 tomatoRAF user.warn kernel:  free:127 slab:1239 mapped:2 pagetables:63 bounce:0
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Normal free:508kB min:508kB low:632kB high:760kB active:4228kB inactive:540kB present:16256kB pages_scanned:7201 all_unreclaimable? yes
    Jul 11 04:01:43 tomatoRAF user.warn kernel: lowmem_reserve[]: 0
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Normal: 1*4kB 1*8kB 1*16kB 1*32kB 1*64kB 1*128kB 1*256kB 0*512kB 0*1024kB 0*2048kB 0*4096kB = 508kB
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Swap cache: add 0, delete 0, find 0/0, race 0+0
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Free swap  = 0kB
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Total swap = 0kB
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Free swap:            0kB
    Jul 11 04:01:43 tomatoRAF user.warn kernel: 4096 pages of RAM
    Jul 11 04:01:43 tomatoRAF user.warn kernel: 0 pages of HIGHMEM
    Jul 11 04:01:43 tomatoRAF user.warn kernel: 731 reserved pages
    Jul 11 04:01:43 tomatoRAF user.warn kernel: 13 pages shared
    Jul 11 04:01:43 tomatoRAF user.warn kernel: 0 pages swap cached
    Jul 11 04:01:43 tomatoRAF user.err kernel: Out of memory: kill process 4538 (dnsmasq) score 78 or a child
    Jul 11 04:01:43 tomatoRAF user.err kernel: Killed process 4538 (dnsmasq)
    Jul 11 04:01:43 tomatoRAF user.warn kernel: klogd invoked oom-killer: gfp_mask=0xa01d2, order=0, oomkilladj=0
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Call Trace:[<80005c48>][<80001500>][<800032f0>]
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Mem-info:
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Normal per-cpu:
    Jul 11 04:01:43 tomatoRAF user.warn kernel: CPU    0: Hot: hi:    0, btch:   1 usd:   0   Cold: hi:    0, btch:   1 usd:   0
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Active:1057 inactive:135 dirty:0 writeback:0 unstable:0
    Jul 11 04:01:43 tomatoRAF user.warn kernel:  free:126 slab:1240 mapped:2 pagetables:63 bounce:0
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Normal free:504kB min:508kB low:632kB high:760kB active:4228kB inactive:540kB present:16256kB pages_scanned:7201 all_unreclaimable? yes
    Jul 11 04:01:43 tomatoRAF user.warn kernel: lowmem_reserve[]: 0
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Normal: 0*4kB 1*8kB 1*16kB 1*32kB 1*64kB 1*128kB 1*256kB 0*512kB 0*1024kB 0*2048kB 0*4096kB = 504kB
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Swap cache: add 0, delete 0, find 0/0, race 0+0
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Free swap  = 0kB
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Total swap = 0kB
    Jul 11 04:01:43 tomatoRAF user.warn kernel: Free swap:            0kB
    Jul 11 04:01:43 tomatoRAF user.warn kernel: 4096 pages of RAM
    Jul 11 04:01:43 tomatoRAF user.warn kernel: 0 pages of HIGHMEM
    Jul 11 04:01:43 tomatoRAF user.warn kernel: 731 reserved pages
    Jul 11 04:01:43 tomatoRAF user.warn kernel: 13 pages shared
    Jul 11 04:01:43 tomatoRAF user.warn kernel: 0 pages swap cached
    Jul 11 04:01:49 tomatoRAF user.notice root: ADBLOCK: hosts sorted.
    Jul 11 04:01:49 tomatoRAF user.notice root: ADBLOCK: 17261 entries
    Jul 11 04:01:52 tomatoRAF daemon.info dnsmasq[7180]: started, version 2.57 cachesize 2048
    Jul 11 04:01:52 tomatoRAF daemon.info dnsmasq[7180]: compile time options: no-IPv6 GNU-getopt no-RTC no-DBus no-I18N DHCP TFTP no-IDN
    Jul 11 04:01:52 tomatoRAF daemon.info dnsmasq[7180]: asynchronous logging enabled, queue limit is 5 messages
    Jul 11 04:01:52 tomatoRAF daemon.info dnsmasq-dhcp[7180]: DHCP, IP range 192.168.2.1 -- 192.168.2.100, lease time 1d
    Jul 11 04:01:52 tomatoRAF daemon.info dnsmasq[7180]: reading /etc/resolv.dnsmasq
    Jul 11 04:01:52 tomatoRAF daemon.info dnsmasq[7180]: using nameserver 208.67.220.220#53
    Jul 11 04:01:52 tomatoRAF daemon.info dnsmasq[7180]: using nameserver 208.67.222.222#53
    Jul 11 04:01:52 tomatoRAF daemon.info dnsmasq[7180]: read /etc/hosts - 2 addresses
    Jul 11 04:01:52 tomatoRAF daemon.info dnsmasq[7180]: read /etc/dnsmasq/hosts/hosts - 11 addresses
    Jul 11 04:01:52 tomatoRAF daemon.info dnsmasq-dhcp[7180]: read /etc/dnsmasq/dhcp/dhcp-hosts
    Jul 11 04:01:55 tomatoRAF user.notice root: ADBLOCK: dnsmasq is running
     
  69. MaX PL

    MaX PL Networkin' Nut Member

    hey victek,

    the wireless on my e3000, despite providing consistenly high speeds, shows a decreased signal strength from time to time.
    i've typically had 5 bars of signal in windows on past firmware, both ddwrt and stock, yet i drop to 4 bars and sometimes 2 with raf.

    my power is set at 42mW by default i believe as i'm in the USA. if i raised the power to 50mW, would i see an improvement, or should i keep at 42mW for stability?

    edit: to be clear. the majority of the time i have 5 bars, with the occasional 4, and very rare 2 bars.
     
  70. M_ars

    M_ars LI Guru Member

    maybe your environment changed... more wlans, bluetooth, microwaves... in your neighborhood.
     
  71. Victek

    Victek Network Guru Member

    MaX PL

    Did you fixed the channel and performed a wireless survey to see closer wireless networks around? Did you perform an Electrical noise offset? If yes then I agree with Mars about suddenly interferences can provoke this behavior.
     
  72. Victek

    Victek Network Guru Member

    seraphsf,

    Well .. evidence is clear and even kernel is seeking for alternative ram area the pool is exhausted. I can try doing some trick deleting services you don't use like CIFS.. but your router need some RAM vitamin .. migrating to one router with enough RAM to hold your scripts chain.
     
  73. MaX PL

    MaX PL Networkin' Nut Member

    i did a survey and most networks are on channel 6 with only one network using channel 11. so i tried to use channel 11 but it made little difference so i set it to auto hoping the device could figure out the best channel on its own.

    no new appliances in my home and the surrounding network count hasnt changed at all as most homes are pretty far away.

    dont know what you mean by testing electrical noise, but thanks for the suggestions.

    like i said, my speeds arent worse because of this, just my signal quality is lessened, but not by much. i'll just let things be as it isnt a huge problem; i just wanted some opinions.

    thanks
     
  74. Victek

    Victek Network Guru Member

    I suggest to fix the wireless channel, the drift in the wireless channel while interferences appear can provoke the signal strength drop you mentioned.

    You welcome.
     
  75. -=Renegade=-

    -=Renegade=- Addicted to LI Member

    Hello,

    When using your mod, can I use the USB port (e.g. Linksys E4200) as a printer server (for Canon MP190) too, or only as a storage link?


    Thank you in advance,


    so long,
    Renegade
     
  76. Victek

    Victek Network Guru Member

    Sure, USB printer driver is available also, look at USB option.
     
  77. sppmaster

    sppmaster Networkin' Nut Member

    Hi Victek.
    The quoted information from my earlier post is not fair enough.
    I have found out that the reason for not displaying the web interface properly was I had enabled previously "large TCP window support" option under Windows XP. I had no problems displaying web interface with older firmwares with the above option enabled though.
    Could this be related to a new versions (K26 builds) firmware bug .
    I am not a network guru just read some info here.
    http://www.psc.edu/networking/projects/tcptune/
    Enabling High Performance Data Transfers
    Negotiating TCP Large Windows options (RFC1323)
     
  78. KyleS

    KyleS Networkin' Nut Member

    Are there any plans on adding the new VLAN-GUI added by Augusto?
     
  79. seraphsf

    seraphsf LI Guru Member

    Just wanted to report back that since I had that out of memory issue the firmware cleared itself of the memory issue automatically (not sure how) and it is showing with an Uptime of over 16 days without any problems . Overview page also shows: Total / Free Memory 13.14 MB / 3,928.00 KB (29.18%).

    Great job on the firmware!
     
  80. wilsonhlacerda

    wilsonhlacerda Networkin' Nut Member

    I expect so. Nice feature on a nice mod! :biggrin:
    Any plans?

    Anyway, tks Victek for your tremendous effort on current firmwares!
     
  81. peter_m

    peter_m Addicted to LI Member

    VPN

    Helo,
    been trying to configure a VPN server on "Tomato RAF Firmware v1.28.8525 RAF ND VPN" on a WRT54GL and I've been unsuccessful.

    If I telnet to the router, where can I find the actual config (for OpenVPN) file that is generated by the router's GUI? I would like to look at it directly to make sure my client's config matches it.

    What version of OpenVPN does this firmware use?

    Peter_M
     
  82. roadkill

    roadkill Super Moderator Staff Member Member

    if you could post some details we might be able to offer some assistance, the config file is in /tmp I think
     
  83. peter_m

    peter_m Addicted to LI Member

    Found the config files and I was able to adjust the client config to reflect what is in the server. Works just perfectly. Even through a proxy server at work.

    Questions remain as I try to fully understand how the VPN works:
    What does the Automatic firewall setting do exactly?
    What routing changes does the server GUI put in place?

    Peter
     
  84. peter_m

    peter_m Addicted to LI Member

    To be accurate, they are under:
    /tmp/etc/openvpn/server1
    and
    /tmp/etc/openvpn/server2
     
  85. roadkill

    roadkill Super Moderator Staff Member Member

    you can examine the server's config file to receive some answers or you could post it here discarding RSA keys of course and I could assist with what I can,
    regarding the proxy most of them could be bypassed using the right configuration or routing the VPN tunnel through the proxy.
     
  86. Victek

    Victek Network Guru Member

    About VLAN-GUI from Augusto, I'm trying to include iface map for other models. I agree, it's a great step forward for routers in an office environment and the gate for guest wireless ... Great job Augusto, congratulations !
     
  87. KyleS

    KyleS Networkin' Nut Member

  88. Victek

    Victek Network Guru Member

    You can see by the option in the menu Adminstration/debugging/Download nvram Dump, it's simple and easy to access and keep in your files.
     
  89. neothemachine

    neothemachine Networkin' Nut Member

    I upgraded from 1.28.121006 to 1.28.9006MIPSR1_RAF-Std-NOCAT and to my surprise the speed indeed hasn't slowed down. Good work!

    I have a WRT54G 2.0 and basically upgraded because I wanted to try some of the new QoS functions. Unfortunately as soon as I enable QoS, my downstream drops from 38 to 24mbps. I think I can't do anything about it, I guess it's caused by the rather slow CPU. I already had to overclock from 200 to 216 to get near my ISP max of 40mbps (which I really get when directly connecting to the cable modem).

    Oh yeah, funny thing: The web interface displays "CPU Freq 252MHz" which can't be right, that's way too much. (Log also says "kernel: CPU: BCM4712 rev 1 pkg 0 at 252 MHz") When I read out the clkfreq value from nvram it says 216,108 like expected. No idea what's wrong, I guess it's reading out the 252MHz directly through some system call which gets it wrong.
     
  90. Victek

    Victek Network Guru Member

    The speed is not wrong, it reads directly from CPU sysinfo... ;). I did'nt know the high load of QoS in the global performance, what's the CPU Load when QoS is enabled?. Thank you for feedback.
     
    wlkn likes this.
  91. neothemachine

    neothemachine Networkin' Nut Member

    CPU load is as high as 1.4 during a speed test. I used ssh access and "uptime" to read out the load as the web interface has a bit of impact to the load. When the speed test was running the ssh access was nearly unresponsive, you could literally feel the load.
     
  92. neothemachine

    neothemachine Networkin' Nut Member

    Very strange.... when I set clkfreq to 200,100 then cpuinfo says it's 200MHz. But when I set it to 216,108 it gets up to 252MHz (250.67 BogoMIPS)
     
  93. gutsman7

    gutsman7 Networkin' Nut Member

    victek thnkz for the awesome firmware, i love it, just wanna ask about robsons script gen download script works on your firmwares exept for the upload one.
     
  94. Victek

    Victek Network Guru Member

    What router model are you using?. Why you don't use MAC/IP BW limiter?
     
  95. gutsman7

    gutsman7 Networkin' Nut Member

    thnxz for your reply victek im currently using a WRT310N V2 with Tomato Firmware RAF1.28.9006 MIPSR2_RAF K26 Std-NOCAT.your bw limiter works awesome i was just wanting to compare the difference between the both and i noticed this. also why is it tht when i limit tcp conns imy network comes to a standstill at times?
     
  96. shibby20

    shibby20 Network Guru Member

    K26 doesnt have ipt_IMQ module. When you create script using robsons gen, you have to change module name to xt_IMQ or just go to advanced firewall and enable imq module :)
     
  97. gutsman7

    gutsman7 Networkin' Nut Member

    hey thnxz shibby for your response. I also enjoy your awesome firmware, it rokz and its so small, I also noticed this in your latest build shibby, so how many imq modules do I enable in the firewall option, say for like 12 clients. thnxz shibby looking forward to your next build.
     
  98. Valbowski

    Valbowski Networkin' Nut Member

    Victek, thanks for the great work. I am also experimenting lower signal power using the 9006 build for a E3000. I tried fixing channels and increasing power but it did not improve. I tried other firmwares and power comes back to normal level. Any suggestions?

    Also, is the dlna server corrected for the problems with the PS3 getting 2104 errors? This problem is covered in the tomatousb forums.

    Thanks again.
     
  99. Valbowski

    Valbowski Networkin' Nut Member

    Now stuck with lower power in all Tomato builds? Even weirder.

    When I first got the E3000, I upgraded the firmware to 1.0.04. I was getting steady full 5 bars for 2.4 wireless from a specific spot. When I faced compatibility problems with the media server and because I'm a freak, I decided to try the tomatousb firmware (build 54), then tried the toastman latest build, then tried the latest DD-WRT Kong mod, Same power from all these builds. This is where I tried RAF 9006 and while it works fine, I definitely saw a decrease in power. I then reinstalled the Toastman build and saw that the power stayed low! The stock 1.0.04 and DD-WRT brings back the power but now both RAF and toastman experience low power and there is no way to bring it back. Could there be a reason for this?

    BTW, 30-30-30 and NVRAM reset on each change.
     
  100. Toastman

    Toastman Super Moderator Staff Member Member

    We all use the same base build - and wireless driver. You may find that experimenting with the settings in Advanced/Wireless helps, turn off any bells and whistles - particularly Interference Mitigation. I find the signal strength from the RT-N16 set to 60 to be approximately the same as a WRT54GL at 150.
     

Share This Page