1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New Victek releases

Discussion in 'Tomato Firmware' started by mpegmaster, Jul 2, 2009.

  1. Victek

    Victek Network Guru Member

    gsan, did you read Tomato wiki? I think there is one section dedicated to Access restriction with the variables and application to be fixed.
     
  2. bogderpirat

    bogderpirat Network Guru Member

    i was running Tomato Firmware v1.25.8515RAF ND, now i updated to the latest available .2 on your page. as i previously mentioned, i've cleared nvram twice in the mean time.

    what i'm just noticing now... when i go to "real time", the bandwidth logging there is going just fine, as it's real-time.
    when i however go to "last 24 hours", i can't find my wan-interface (ppp0) in the list of devices on the upper end of the graph.
    under both daily and monthly, i just see the table headers, but no rows. under weekly, i see the same picture, except that there is at every time only one row, containing zeroed values.

    since i just noticed the "last 24 hours" thing, i think it might have something to do with my setup:
    since i have a somewhat unusual way of dialing in (despite it still being pppoe), i'm not using the vlan1-vlan like the usual to dial out, but instead a vlan7-vlan that i created using nvram-variables. i've been using this ever since january of this year, but bandwidth logging only stopped near the end of may (still had 1.23 raf back then), a time to which i can however not attribute any other changes i've made.
    i've also changed the br0-configuration lately, but i did that long after the problems turned up.
    as there is no way of configuring rstats, i'm sort of at a loss how to debug this :frown:
     
  3. Victek

    Victek Network Guru Member

    Hmm, I think you should start from default configuration, check every step and see where the router behaviour and graph changed... mine is OK, and.. no graph for daily, weekly and monthly in 1.25 release

    Regards
     
  4. gsan

    gsan LI Guru Member

    for .2ND, the UPnP is not working on ASUS WL500gP V1. I'd clear nvram after upgrade.
     
  5. barry80

    barry80 Addicted to LI Member

    like what vic said.....Access Restriction is your only solution. but once u blocked the internet surfing, i think the msn also can't connect too :confused: msn with port 80 too?
     
  6. Toastman

    Toastman Super Moderator Staff Member Member

    You might do it with 2 QOS rules. hmmm thinking ....

    Something like, use the highest rule with his MAC and dest port 1863, place in a normal class to let him use MSN. Then immediately afterwards another rule, same MAC, all ports - all everything, dump that MAC in crawl class , say, (E) and then choke class (E) - place limits out and in to give him no bandwidth. To make sure they take hold, put them right at the top of your QOS rules.
     
  7. strike

    strike Addicted to LI Member

    Updated Tomato to RAF the other day...excellent so far!

    Was reading a little about P2P obfuscation, which is included...?

    Is this a configuration that needs to be set? How does it work?

    Thanks!
     
  8. Victek

    Victek Network Guru Member

    No, it's working by default but of course, it's very related to your ISP packet manipulation.
     
  9. QSxx

    QSxx LI Guru Member

    Vic, how close you are to that new RAF (the one that has captive portal and all other goodies)?

    Any etas?
     
  10. Victek

    Victek Network Guru Member

    Well, I had problem with Nocatsplash, and now I shfited to nodogsplah (more actual), I can't fix ETA for the moment, I do in my extra-spare time...
     
  11. strike

    strike Addicted to LI Member

    Thanks for quick response.

    As noted, very impressed...excellent, excellent work. I am now actively promoting Tomato/RAF with my friends.
     
  12. s0dhi

    s0dhi LI Guru Member

    Good luck and excellent work! :thumbup:

    I am eager to get the adblocking redirection and page hosting done right on the router!
     
  13. Victek

    Victek Network Guru Member

  14. peyton

    peyton LI Guru Member

    Sounds great !
    Good luck !
     
  15. QSxx

    QSxx LI Guru Member

    I see, one-router-ISP soon :) ! Great work and feel free to send me test version. I'm volonteering one of my WRTs to be a guinea pig test subject for new uber-RAF!
     
  16. The Master

    The Master LI Guru Member

    Hello Vitec,

    is it posibile to update the pptp interface client driver? Or change him to a not so CPU consuming on??

    Because with the build in one i have 1,50 - 1,70 cpu load.

    I hope you could help me.
     
  17. Victek

    Victek Network Guru Member

    I hope you have same behaviour as the official Tomato release, didn't touch anything in this section. I'm not working on it.
     
  18. Zoltair

    Zoltair LI Guru Member

    Not sure if anyone else has noticed this, (or if its just me, lol), I have been using the 1.23 version for a while, and it has been very stable, I recently upgraded to 1.25, now I notice on the live bandwidth graph I get an occasional data peek of a couple hundred Mb/s, most of the time I can see it go to 170-180 kps, (1.54Mb DSL here), but these peaks are enormous and infrequent, but never noticed them before on 1.23...... Any one else?
     
  19. The Master

    The Master LI Guru Member

    @Vitek

    i know you have not touch this part of the tomato FW. I ask if you WOULD :D... because i wrote the Coder from Tomato and he never answerd me, so i ask you and your magic fingers.
     
  20. Gold

    Gold Addicted to LI Member

    Where can i find the old Tomato RAF 1.23 ND firmware ??
     
  21. Victek

    Victek Network Guru Member

  22. GhaladReam

    GhaladReam Network Guru Member

    Thanks Vic! You been testing this one for a while! In the About screen it says the build date of this one is Mon, 06 Apr 2009 17:39:59 +0200!

    Changelog?

    NVRAM erase necessary when going from 1.25.8515.2 to .5?
     
  23. Victek

    Victek Network Guru Member

    :eek::eek::eek: Sorry, He asked for 1.23.8515.5 not 1.25 releases..!
     
  24. GhaladReam

    GhaladReam Network Guru Member

    WHOOPS! I knew I should have had that cup of cofee this morning. Just disregard my last post. How embarassing!

    My brain saw 1.25.8515.5 for some reason!
     
  25. Engineer

    Engineer Network Guru Member

    I almost did the same thing when I saw the .5 on the end. Was ready to jump all over this but caught the .23 just in time, lol.
     
  26. Gold

    Gold Addicted to LI Member

    Thanks Victek for the OLD Tomato RAF 1.23 ND firmware :)
     
  27. GhaladReam

    GhaladReam Network Guru Member

    At least you didn't go so far as to flash your router with it! I didn't even realize what I had done until I linked the supposed new version to a friend and she said "why did you send me a link to and old RAF version?" Then I realized.. oops... hehe

    *slaps forehead*

    I've since flashed back to 1.25.8515.2 :p
     
  28. Engineer

    Engineer Network Guru Member

    I'm curious why you would be going back to the old version.

    The reason I ask is that I have been experienceing freezes of webpages and have wondered if it were the 1.25 version or my ISP or something in the PC's (Flash, etc). I may go back to 1.23 to see if it makes a difference.
     
  29. Larix

    Larix LI Guru Member

    How can I see which Version I use? At the webpage is # Tomato RAF 1.25.8025.2
    # Tomato RAF 1.25.8515.2 ND and I use Tomato Firmware v1.25.8515RAF ND Built on Thu, 02 Jul 2009 18:01:15 +0200. Is that version the same?
     
  30. peyton

    peyton LI Guru Member

    Nop .2 is revision 2 for the same firmware.

    .2 is newer than your current version.
     
  31. Larix

    Larix LI Guru Member

    Whats new in the second revision?
     
  32. Victek

    Victek Network Guru Member

    Larix, changelog is posted some post back.
     
  33. Gold

    Gold Addicted to LI Member

    After opgrade to 1.25 i have lag in online gaming (lags spikes), i am running it as a wireless bridge. No spikes was on 1.23 so testing v 1.23 now.
     
  34. Larix

    Larix LI Guru Member

    Thanks I have looked for a changelog but I didn't find it. Now I have looked again and I have found the changelog.
     
  35. gsan

    gsan LI Guru Member

    tomato possible to implement below function?

    when no people surfing net, the bittorrent is running full speed but if there is surfing net and dl bittorrent at the same time, the priority goes to surfing net...

    is it the function of QoS ? if yes, how to set it?
     
  36. s0dhi

    s0dhi LI Guru Member

    Please start reading this excellent thread.
     
  37. jdub8

    jdub8 Addicted to LI Member

    Victek, since you are working on the ip/bandwidth management stuff already I have an idea/feature request.

    Is there anything wrong with having the router log active bandwidth usage for the last x minutes before you log in to the router and have it auto-populate in the graphs? I ask because 90% of the time I login its to check the bandwidth graphs and see if I can figure out which computer on my network I need to kick. This would be a great feature for many other people I'm sure.
     
  38. Victek

    Victek Network Guru Member

    No problem, just I have to fix a 'deja vu' graph of last 15 minutes for instance, it's what you wish?
     
  39. jdub8

    jdub8 Addicted to LI Member

    Yes please. :)

    I'm curious about how you plan on doing that. Will you change the default behavior so that in future releases everyones will do that? Or will it be an option to enable somewhere?

    How much space does 5-10-15 minutes of graphing take up? (is it stored as an image or text? svg is vector based IIRC) Just curious, I hope I dont end up robbing users of 300KB of RAM.

    Will you be coding it to just hard capture 15 minutes and auto plot that data? Or will it be set to save X minutes of data (x being how long the graph is set to plot). Put another way I'm curious if you will be modifying the graphing behavior or tacking something on to it.
     
  40. Victek

    Victek Network Guru Member

    jdub8, This feature is not new, older Tomato version had something similar to it (1.07), a kind of cron wiping the available tracking according to a time setting. Now, the main restriction will be related on; How many IP's/MAC are we able to keep in the buffer? so, the amount of 'deja vu' time graph can be set by the user but restricted by the available memory and consequently can vary from the fixed period by the user (if exceeds pool space) depending of number of trace connection, I'm expecting could be one smart and fuzzy approach to not penalize router memory .....
     
  41. jdub8

    jdub8 Addicted to LI Member

    If I read you right, you're saying if IMQ's are enabled up to 20 (or however many there are now) but only 8 IP's are in use... you can have it just store those 8 IP's graphs? Or fewer based on memory demands?

    Badass :thumbup:
     
  42. Victek

    Victek Network Guru Member

    No, you read me reverse, memory will keep all IP/MAC until the memory top capacity fixed by hardware or the time set fixed by the user is reached (what happen before).
     
  43. premudriy

    premudriy LI Guru Member

    Hey, Victek. I don't know if you remember, but sometime before in this thread I've posted about a problem with free memory - it was very low after only 2 days of use. Anyways, I did clear nvram once more, put in all my settings and scripts manually, and that problem never repeated and now I have 24 days uptime with 51% of free memory left, which is awesome! I don't know what happened that time, but ever since my router was running perfect. Thank you very much for this great firmware!!!
     
  44. Victek

    Victek Network Guru Member

    premudriy,

    Thank you for the feedabck, to be honest I didn't hear problem about memory leak but in 1.25.xx some patches done by TB was applied.
    For the other post reader I have good news since the WRT54GL throughput was an issue for some high speed connection, I tested WRT54GL with wide speed Internet connection and I can commit release 1.25.8515.2 ND is the top WAN-LAN firmware till now. Some images; Left image is WAN-LAN traffic, Right image is Wireless throughput. Connection specs was 50/3M.

    Some help... BAJADA= Download , SUBIDA=Upload

    LEFT

    [​IMG][​IMG]

    :thumbup::thumbup:
     
  45. WRobertE

    WRobertE Addicted to LI Member

    Version 1.25.8515.5 ?
     
  46. Victek

    Victek Network Guru Member

    Opsss, again, sorry, 1.25.8515.2 ND (I'm working in .5 release and the digit leaks in my posts...) :biggrin:
     
  47. WRobertE

    WRobertE Addicted to LI Member

    Looking forward to your next release...

    As I've said before, you're doing great things for many people. Thank you.
     
  48. peyton

    peyton LI Guru Member

    Great news ! :)
     
  49. LeoKesler

    LeoKesler Addicted to LI Member

    Can you help-me ?

    I have two routers:

    1. Dlink DIR-320, bridge, with UPnP and Firewall disabled, with DD-WRT, using amule to download some files. The program Amule is configured to use UPnP.

    2. WHR-G125, with UPnP and Firewall enabled, Tomato and log level setting to 5.

    When I am using amule, some messagens appears in log of Tomato:

    Aug 20 00:31:59 unknown daemon.notice miniupnpd[1928]: SUBSCRIBE not implemented. ENABLE_EVENTS compile option disabled
    Aug 20 00:32:02 unknown daemon.notice miniupnpd[1928]: QueryStateVariable: Unknown: ConnectionType
    Aug 20 00:32:02 unknown daemon.notice miniupnpd[1928]: QueryStateVariable: Unknown: PossibleConnectionTypes
    Aug 20 00:32:02 unknown daemon.notice miniupnpd[1928]: QueryStateVariable: Unknown: Uptime
    Aug 20 00:32:02 unknown daemon.notice miniupnpd[1928]: QueryStateVariable: Unknown: LastConnectionError
    Aug 20 00:32:02 unknown daemon.notice miniupnpd[1928]: QueryStateVariable: Unknown: RSIPAvailable
    Aug 20 00:32:02 unknown daemon.notice miniupnpd[1928]: QueryStateVariable: Unknown: NATEnabled
    Aug 20 00:32:02 unknown daemon.notice miniupnpd[1928]: QueryStateVariable: Unknown: ExternalIPAddress
    Aug 20 00:32:02 unknown daemon.notice miniupnpd[1928]: QueryStateVariable: Unknown: PortMappingLeaseDuration

    In UPnP window (in Tomato):

    4712 4712 192.168.10.101 TCP aMule TCP External Connections Socket
    65533 65533 192.168.10.101 UDP aMule UDP socket (TCP+3)
    65530 65530 192.168.10.101 TCP aMule TCP Listen Socket
    65531 65531 192.168.10.101 UDP aMule UDP Extended eMule Socket
    4711 4711 192.168.10.101 TCP aMule TCP Webserver Socket

    The real problem: The amule is unable to open UPnP ports in Tomato.

    Just for curiosity, Transmission (torrent program) running in DD-WRT, is able to open ports using UPnP.

    By the way, Amule and Transmission are installed in jffs in DD-WRT and not in my computer. Link
     
  50. Victek

    Victek Network Guru Member

    Quick answer, if Transmission runs fine BUT not Amule then it could be a program problem. Open ports through PF GUI.
     
  51. LeoKesler

    LeoKesler Addicted to LI Member

    I know, but if you have some time, can you look in UPnP compile options for this:

    Aug 20 00:31:59 unknown daemon.notice miniupnpd[1928]: SUBSCRIBE not implemented. ENABLE_EVENTS compile option disabled

    Anyway, I will look carefully in manual port forwarding.

    Thanks.
     
  52. bogderpirat

    bogderpirat Network Guru Member

    hey victek! these are exciting news about the throughput thing. are those speeds sustainable? what sort of connection was that on - normal dhcp'd ethernet or ppp?
    having a 50/10 pppoe connection myself, i'm quite excited to get my hands on that thing :)
     
  53. Victek

    Victek Network Guru Member

    Yes, are still sustained, connection is DHCP, cable modem at front.
     
  54. agentsky1919

    agentsky1919 LI Guru Member

    I just installed this firmware from 1.23ND and its rock solid as usual.

    My problem now is the LED script for Wireless in my Buffalo WHR-G125. I badly need it as indicator of my WiFi, anyone can help me with this. TIA

    What i want is:

    Wireless LED = On (if WiFi is enabled)
    Wireless LED = Off (if Wifi is Disabled)
     
  55. TVTV

    TVTV LI Guru Member

    Victek, here's what i get using official 1.25ND, QoS OFF, WRT54GL OC @ 240 MHz on a 50/50 PPPoE line. The upload seems to be crappy right now, don't know the reason, but it usually hovers at around 3 MB/s.

    [​IMG]
     
  56. Victek

    Victek Network Guru Member

    TVTV thank you, as you know sometimes depends on ISP traffic... but at least we can use this firmware/router with high speed connection, I was concern about it.
     
  57. bigjohn

    bigjohn Addicted to LI Member

    Ok.
    Newbie question.
    I have a wrt54gs. V1.1 I think.
    I know I'll have to clear NVRAM and re-enter my settings....So, is there a way I can output all the settings to my printer or a text file??
     
  58. gsan

    gsan LI Guru Member

    hope u can fix the upnp problem in the .5 release.
     
  59. landa

    landa LI Guru Member

    Go to Administration -> Debugging -> Download NVRAM Dump. All your settings are there.
     
  60. Toastman

    Toastman Super Moderator Staff Member Member

    The settings are there, but sometimes a screen snapshot of the setup pages is easier to use. (MWsnap3 is a good free screenshot program).
     
  61. Victek

    Victek Network Guru Member

    What problem? pls describe it or link me the related issue.
     
  62. bigjohn

    bigjohn Addicted to LI Member

    nice. I upload this firmware, and, because everything about it is TOMATO +++ stuff, I did not need to change / clear NVRAM. and the new radio driver is AWESOME!
    What I would like to know though - the 'per MAC bandwidth limiter' - how does that work with QOS?
    I have had QOS on Tomato working very well for a long time... 2-3 years?? This is an enhancement that I have always wanted to have.
     
  63. Victek

    Victek Network Guru Member

    Better work separate with QoS, it conflicts in some iptables.
     
  64. bigjohn

    bigjohn Addicted to LI Member

    Are you saying that I should NOT use the Per-IP limits along with standard QOS?
     
  65. Victek

    Victek Network Guru Member

    In fact you're cloning some rules if you use both.. so, better use separate and choice the best feature for your application.
     
  66. bigjohn

    bigjohn Addicted to LI Member

    Just to be clear then - If I have a rule that limits an IP to a class (class C for example), then I should not also have a bandwidth limit rule on that IP?

    Is it ok to use BOTH types of rule, just only one type of rule on a specific IP?
     
  67. Victek

    Victek Network Guru Member

    This case is very well applied, it can share both methods.
     
  68. bigjohn

    bigjohn Addicted to LI Member

    So my example is good.
    Thank you. Now i have a thing or 2 to try!
     
  69. jdub8

    jdub8 Addicted to LI Member

    Victek you have me curious now... do you like to roll all your work into new updates when an official tomato update comes out? Or do you have your own versions in between official tomato updates?

    Just curious how long it will be before I can have proper per-ip bandwidth graphs :biggrin:
     
  70. Victek

    Victek Network Guru Member

    Any RAF release appear when something interesting will help the user and has been tested and proven to be stable. IP/MAC Bandwidht traffic is stumped now by the Nocatsplash portal.

    This is the reason why I included (dot) between version. At the moment (today) Official Tomato is behind the mod version you saw in the forum because the (dot) between version correct and update some of the modules.

    No offense to Jon Zarate, I understand his position and choice to be a loner and work in his idea, but there are many other idea, this is the positive thing of the GPL, as Thomas Edison said; 'Genius is one percent inspiration, ninety-nine percent perspiration'.
     
  71. jdub8

    jdub8 Addicted to LI Member

    Would you expand a little on the nocatsplash problem? Does it look like there is no way around it? I'd like to help if possible. I might be able to take the time with some devs to find out more about how it works.
     
  72. Victek

    Victek Network Guru Member

    Source: http://cdn.adslzone.net/pub/repos/victek/Tomato/Tomato_RAF_1.25.8025.4_NoCat_Source_Code.tar.bz2 , modified/added files/directories are:

    Files changed/new files in Tomato RAF NoCat:

    tomato/release/src/router/Makefile
    tomato/release/src/router/glib
    tomato/release/src/router/glib-1.2.10-install
    tomato/release/src/router/httpd/Makefile
    tomato/release/src/router/httpd/misc.c
    tomato/release/src/router/httpd/nocat.c
    tomato/release/src/router/httpd/tomato.c
    tomato/release/src/router/httpd/tomato.h
    tomato/release/src/router/nocat
    tomato/release/src/router/nvram/defaults.c
    tomato/release/src/router/rc/init.c
    tomato/release/src/router/rc/Makefile
    tomato/release/src/router/rc/nocat.c
    tomato/release/src/router/rc/rc.h
    tomato/release/src/router/rc/services.c
    tomato/release/src/router/www/Makefile
    tomato/release/src/router/www/new-splashd.asp
    tomato/release/src/router/www/splash.html
    tomato/release/src/router/www/status-data.jsx
    tomato/release/src/router/www/tomato.js

    compile, nocatsplash is in New function menu, after activation & Save it takes 20 second to be active, once you see the welcome screen in your browser and press apply the.. nothing happen.. it's not resolving.
     
  73. gsan

    gsan LI Guru Member

    the upnp not working properly, some application cant be forwarded

    flashed back to non .2 release, upnp is working correctly
     
  74. Victek

    Victek Network Guru Member


    What version please, as you know there are many version, be explicit.
     
  75. jdub8

    jdub8 Addicted to LI Member

    ninja bump
     
  76. Toastman

    Toastman Super Moderator Staff Member Member

    ninja bump ???

    EDIT: What is ninja bump?
     
  77. Victek

    Victek Network Guru Member

    masked stranger .. ;), I'm working on it.. thanks 4 the reminder...
     
  78. bogderpirat

    bogderpirat Network Guru Member

    let's all chip in and help him work faster. i'll do your laundry!
     
  79. QSxx

    QSxx LI Guru Member

    Count me in for the dishes!
     
  80. jdub8

    jdub8 Addicted to LI Member

    I'll tend to the misses!
     
  81. Toink

    Toink Network Guru Member

    Ha-Ha-Ha-Ha!

    I HEART THIS THREAD!!! :hearts:
     
  82. Toastman

    Toastman Super Moderator Staff Member Member

    My cat volunteered ...
     
  83. ceevee

    ceevee LI Guru Member

    When I change a setting in port forwarding, the bandwidth limiter doesn't work anymore. I need to 'save changes' on the bandwidth limiter page so i could restart the services involved with the BW limiter.

    Is this a known issue or just a bug I have?
     
  84. Victek

    Victek Network Guru Member

    It's known issue corrected for the next release, thank you for pointing it.
     
  85. Dashiell

    Dashiell Network Guru Member

    Excellent! Thank you, Vic!

    I hate to be "that guy," but is there an ETA to the next version?
     
  86. Victek

    Victek Network Guru Member

    No, it's related to another features to be completed, but I think before Christmas?:biggrin:
     
  87. peter_m

    peter_m Addicted to LI Member

    Just set the channel to "AUTO" to work around interference in my area. It's really starting to become a problem. I am sure it is external interference because when it does happen, almost all the wifi in my area dissapear from the list of visible networks and on both wireless PCs.

    Any how, my question is about the New Drivers version of your firmware. What is the difference between ND and the regular version? I have Broadcom & Intel 2200bg wifi cards, does that make a difference on which firmware I should use?

    Also, the AUTO channel setting seams to choose channel 1 100% of the time in the last 18 hours. Has the AUTO setting been reported to have problems?

    And lastly, anyone know where I can get info or how I can run a socks5 or socks4 server directly on the WRT54GL? A VPN would also be nice if it's possible.

    Peter

    PS: Merci pour le superbe firmware!
     
  88. GhaladReam

    GhaladReam Network Guru Member

    I'm going to assume that Vic is going to at least wait until Official Tomato 1.26 is out so he can integrate those changes into his build before releasing a new build with all his new additions. That would make the most sense!
     
  89. Victek

    Victek Network Guru Member

    peter_m,

    1st- Your router model?
    2nd- If you have an Intel 2200bg card then you need ND version definitevly but depend of your router model and revision core of your wireless card. See post related to the issue.
    3rd- No, no problem related about.
    4th- A moded version derived from my mod built by thor2000 includes vpn I think.

    Thanks
     
  90. gogubeb

    gogubeb Addicted to LI Member

    Some messages

    Hi Victek,
    I use your last tomato RAF 1.25.8515.2 ND on a WRT54GL v1.1 and in logs i get some messeges. Could you explaine what it means and why they appear?

    Code:
    Sep  4 16:38:32 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:38:36 wire user.warn kernel: NET: 448 messages suppressed.
    Sep  4 16:38:36 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:38:41 wire user.warn kernel: NET: 241 messages suppressed.
    Sep  4 16:38:41 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:38:47 wire user.warn kernel: NET: 133 messages suppressed.
    Sep  4 16:38:47 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:38:53 wire user.warn kernel: NET: 213 messages suppressed.
    Sep  4 16:38:53 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:38:56 wire user.warn kernel: NET: 88 messages suppressed.
    Sep  4 16:38:56 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:02 wire user.warn kernel: NET: 300 messages suppressed.
    Sep  4 16:39:02 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:12 wire user.warn kernel: NET: 185 messages suppressed.
    Sep  4 16:39:12 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:12 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:16 wire user.warn kernel: NET: 289 messages suppressed.
    Sep  4 16:39:16 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:28 wire user.warn kernel: NET: 27 messages suppressed.
    Sep  4 16:39:28 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:28 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:32 wire user.warn kernel: NET: 13 messages suppressed.
    Sep  4 16:39:32 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:36 wire user.warn kernel: NET: 225 messages suppressed.
    Sep  4 16:39:36 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:41 wire user.warn kernel: NET: 453 messages suppressed.
    Sep  4 16:39:41 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:47 wire user.warn kernel: NET: 229 messages suppressed.
    Sep  4 16:39:47 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:51 wire user.warn kernel: NET: 170 messages suppressed.
    Sep  4 16:39:51 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:39:56 wire user.warn kernel: NET: 234 messages suppressed.
    Sep  4 16:39:56 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:40:01 wire user.warn kernel: NET: 289 messages suppressed.
    Sep  4 16:40:01 wire user.warn kernel: ip_conntrack: table full, dropping packet.
    Sep  4 16:40:06 wire user.warn kernel: NET: 347 messages suppressed.
     
  91. Victek

    Victek Network Guru Member

    Yes, as the message says the pool is full and packets are dropped, did you made an nvram erase when you updgrade to this firmware version? I think is quite difficult to reach more than 8.000 connection with peer to peer program...

    Thanks
     
  92. gogubeb

    gogubeb Addicted to LI Member

    Yes, i did a nvram erase after upgrade from FW_WRT54GL_4.30.13.016_US_EN_code.
     
  93. dingmel

    dingmel LI Guru Member

    Anyone got the IMQ script working with this? I only seem to get IMQs 0 and 1. the rest aren't showing
     
  94. Victek

    Victek Network Guru Member

    gogubeb, do a 30-30-30 reset sequence and nvram erase to be sure that no variables are in nvram, I have no comments about this problem with this version since we applied new contrack patches from 2.4.35 kernel
     
  95. gogubeb

    gogubeb Addicted to LI Member

    ok thanks i will do that.

    LE: I did what you say but that message is still appear .
     
  96. Toastman

    Toastman Super Moderator Staff Member Member

    gogubeb, your router is trying to open thousands of connections over a very short period of time. Often this will cause the router to reboot . This is sometimes known as a "connection storm". As Victek says, it isn't so easy for normal P2P to open this many connections so here are some pointers:

    1) Are all your conntrack settings set low to quickly time out unused connections?
    2) Are you using QOS to limit P2P applications to sensible amounts of bandwidth?
    3) Did you set any limit on TCP and UDP connections per user?
    4) Did you turn off DHT in P2P software (uTorrent etc) ?
    5) If you are using Bit Torrent, you must remove BT DNA (use google to see why).
    6) Do you have a virus on any machine causing it to open thousands of connections to some distant server? You can get a clue by looking to see what port number(s) these connections are trying to open. Often it will be an SMTP port, when malware tries to use your machine to send spam mails. If so, you can limit numbers of connections to that port.

    Hope this helps !
     
  97. teddy_bear

    teddy_bear Network Guru Member

    You can specify the number of devices - from 1 to 16, default is 2 - when loading imq module, i.e.:
    insmod imq numdevs=10
     
  98. dingmel

    dingmel LI Guru Member

    Thanks!
     
  99. dingmel

    dingmel LI Guru Member

    Where am i supposed to insert that line? I tried under the init and firewall tabs. It still shows only IMQ0 and IMQ1.

    insmod imq numdevs=10
     
  100. phreshanova

    phreshanova Addicted to LI Member

    From a thread I started here but might be better placed in here;

    I installed the latest Victek non-ND firmware on my WRT54GS last night and i've got what appears to be a rather unusual problem. WPA Personal works fine on the various devices i've tried it with (apart from the hacked Fonera but that's for anther time).

    WEP and security disabled will let me connect but with limited access such that I can't access the web interface and there is no internet. Initially I thought it was a problem with the DHCP server as Windows was assigning the machines APIPA IP addresses but even setting a manual IP resulted in the same problem. Could it be a problem with resolving DNS addresses?

    Does anybody have an idea why WPA works and the others don't? Searching here and elsewhere I can only find people with working disable/WEP security but not WPA!

    I did an NVRAM erase on upgrade so I don't think it's an issue with previous settings.
     

Share This Page