1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

NSLU2 Backup: Cannot connect to file server

Discussion in 'Cisco/Linksys Network Storage Devices' started by cosmic, Apr 26, 2005.

  1. cosmic

    cosmic Network Guru Member

    I run Windows 98SE (a few weeks more).
    I log into Windows without password.
    Firmware V2.3R.29

    Despite the confusing interface I finally got the NSLU2 up and running. Only, backup doesn't work. I have read most of the messages here but found no solution.

    I can save a Backup Job, but no matter what syntax I use to enter info in Backup Job, the Backup feature refuses to backup my local C disk.
    I have specified to backup from C to NSLU2.
    I specify to share ADMIN 1 in NSLU2. (I even created and specified a separate share "test" in the root, with same result.)
    At Other Device I specify my computer name Cosmic in the network.
    As shared folder I specify /C since I want to backup the entire disk.

    When trying to backup this message shows up in the log and no files are backuped:
    04/22 18:59:59 Backup: Job 'Backup_C' started.
    04/21 20:01:53 Backup: Job 'Backup_C' ended.
    04/21 20:01:50 Backup: Job 'Backup_C' failed, cannot connect to file server '//Cosmic/C'.

    I also tried to backup another computer's disk. Same result.
    I also tried to backup only a folder. Same result.
    I CAN write files manually to the NSLU2, and read files, without problem.

    I spent 20 minutes with Linksys support. He said everything seemed to be correctly configured and had no clue why backup didn't work!

    What is really wrong here?
    Do I have to log into Windows WITH a password?
    Doesn't NSLU2 like Windows 98?

    Very grateful for any help.
  2. mapper

    mapper Network Guru Member

    similiar problem

    I am getting a similar problem.

    I have a win2K domain controller, that the nslu2 runs backup jobs on ok, providing I am using a wired connection.

    when I change the DC to a wireless connection, the same backup job fails with
    Job 'accounts' failed, cannot connect to file server //servername/sharename'.

    This shows that the backup job is not at fault and it must be something else. Which is what your message indicated.

    Are you using a wired or wireless connection. I have checked the setup of each connection and they are identical. so I would expect it to work.

    I am using a dlink 604T wireless router. I have checked the configuration of this and cannot see anything that should cause a problem.

    With a wireless connection I can see and use the nslu2 fine.

    If I had to guess, I would say that the nslu2 is not able to see the server as \\servername, hence the job is failing.

    The response from the nslu2 with a ping is 10-20ms as opposed to the wired connection which is <10ms, is it possible that the connection is timed out by the nslu2 backup job before the server can respond.

    There are some other threads in this forum, that are suffering the same error, I suspect that these are all the same issue.
  3. cosmic

    cosmic Network Guru Member

    Hi mapper

    I run wired (a D-Link DI-804HV router).
    Response time is <10 ms when pinging.
    The NSLU2 and all folders are seen in Network Neighbourhood just fine, and I can read and write files on the attached USB disk.
    It is "only" the ?)&¤"!! backup routine which just refuses to do anything.

    This is really annoying isn't it.

    I have checked all other threads, but really didn't find any similar experiences. Is it just you and me??

    I have now unplugged all cables to the NSLU2 and will let it rest for 24 hours as a last resort.
  4. brunodiaz

    brunodiaz Guest

    I'm having the same problem on a wired connection.

    I had very bad luck twice with Linksys chat support.

    Any news on this?
  5. cosmic

    cosmic Network Guru Member

    New findings:
    I connected a laptop loaded with Windows XP SP2 to the same workgroup as the two Windows 98SE machines which couldn't initiate a backup job. Lo and behold, now the backup job was carried out. It seems that the NSLU2 backup software can't handle Windows 98 at all.

    But, another problem now: All folders and files on the disk were backuped, EXCEPT folders Programs and Windows. For these two, only the folders were backuped, without any files in them.
    Why is that?
  6. mapper

    mapper Network Guru Member

    Initiating backup jobs

    It is the NSLU2 that initiates the backup jobs, I suspect that the NSLU2 is not able to make a connection to the win98se machines.
    you could try making a backup with the target machine turned off, you will probably get the same error message.

    can you add users to win98, if so try adding a user and using that to authenicate.

    This does not help with my problem at all though, as it works with a wired connection but not with a wireless connection.
  7. jigsaw_tech

    jigsaw_tech Network Guru Member

    Re: similiar problem

    Hello there,

    I was wondering how you managed to get it to work in a domain? Did you just add the domain name to the workgroup input field within the GUI? I am rebuilding a webserver now and it will be in a domain this time. However, I want to make sure that this thing will work in a domain before I switch over.

    I appreciate your time.
  8. mapper

    mapper Network Guru Member

    working with a domain

    Initially I left the NSLU in the 'workgroup' domain and it worked Ok (wired), I only changed the NSLU domain to My domain name to try and get the unwired connection working.

    I don't think the workgroup makes a lot of difference, if you have eveyone permissions on the share/files Windows will give them to a SMB client (the NSLU), if the files have specific permissions a login will have to be provided.
    This works on my domain.

    windows can be a pain in the backside whens if comes to finding clients, even clients within it own domain, there are occasions when I cannot see clients in network neighbourhood. I think windows rechecks every 45 minutes.
    This is why people people talk about restarting/waiting 24 hours and things like that.
    not the best news you want to hear.

    If the NSLU and the servers are on the same switch/subnet it should be fairly reliable.
  9. jigsaw_tech

    jigsaw_tech Network Guru Member

    Thanks Mapper.. I feel better about it now.. I figured that since it was basically an open share, then why would it not work as long as it is on the same network segment.

    I appreciate the response. Thanks for your time.
  10. cosmic

    cosmic Network Guru Member

    One problem solved:
    Backup on the Windows XP now works. After some configuring in WinXp ALL folders are now backed up.
    It turned out that I had to create a user "All" and enable all rights for this user. This is probably not very clever in a security view, but that is the prelimanary solution anyway.
    Linksys have still not come up with a solution for the Windows 98 backup problem.
  11. mapper

    mapper Network Guru Member


    glad to see you got your nslu to see your workstation.

    I hve finally got mine working 2 days ago, I reloaded the tcpip and MS client, after that both winxp laptop and nslu could see the win2K machine.

    Regarding opening up your machine there are some things you can do to make it a bit more secure.

    By the way have you noticed the bug in the Backup|Modify page where if a field is incorrect the form resets the data to flow from the NSLU to the computer. This is quite bad if you do not notice, the NSLU will copy the old data over the new data when in synchronise mode.

    The share that the NSLU sees can be made hidden by adding a $ to the sharename.
    Also change the share permissions to read only, this will prevent the above problem, as the NSLU cannot write the the share. If you have created a user All, you can change the NTFS permissions to read only as well.
  12. cosmic

    cosmic Network Guru Member

    Thanks for tips, mapper. I'll look into that.

    And yes. I noticed that bug also. Nasty one, indeed.
  13. RichieHindle

    RichieHindle Guest

    I had the same trouble, and worked around the problem by using the IP address of the machine in the "Other Device Name:" box rather than the machine's name. (The NLSU is correctly set up with the address of my DNS server, so I don't know why the name didn't work).

Share This Page