1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nvram commit stopped working

Discussion in 'Tomato Firmware' started by sputnik, Mar 9, 2012.

  1. sputnik

    sputnik Networkin' Nut Member

    Hi. I've had this problem for some time now, hoping someone may know what to do.
    Running Toastman V. 1.28.7628 ND USB standard on an Asus WL520U, great combo until this. Well, still great but...
    I have Exactly the same problem as this fellow: http://tomatousb.org/forum/t-433246/vsftp-setup-file-setfile2nvram
    Guess I should have signed up there long ago instead of just lurking. Tried to respond to that posting but the forum states that "low karma members are not allowed to post links", I posted NO links, but...
    I'm trying to make persistent changes to the /etc/vsftpd.conf file and they are gone after reboot. I have also had the problem in the past with other files as well, either worked around it or wasn't as concerned with them. But this time I really do need the changes.
    I do understand the drill: nvram setfile2nvram /path/filename ; nvram commit ; reboot. Nvram reports 72% used, even with this file in there.
    The changes are obviously made as I can see after rebooting the changed file(s) in "nvram show" or a listing of nvram from the web GUI. But apparently some pointer, reference should give this file saved in NVRAM priority over the original? and is not.
    This is about a 6 month old installation and Toastman gives great directions (as always) in restoring nvram parameters in another thread, so I guess I could just nuke it and start over. But have some optware and just general apprehension, if someone has a magic bullet I would be grateful. Thanks.
  2. Planiwa

    Planiwa LI Guru Member

    Perhaps the files were restored from NVRAM and later their processes wrote to them, clobbering that.

    BTW, where is the manpage for this nvram command?

    And documentation about the relationship between the NVRAM flash and the working NVRAM.

    (I have some ideas and tools if there's interest.)

    (And I have related questions about wl, wl0, and wl1, as they appear in the NVRAM.)
  3. sputnik

    sputnik Networkin' Nut Member

    Well, so I just did the obvious fix, use my wanup script to kill vsftpd, copy the new config file to /etc and restart it. Works fine and not TOO ugly, in fact, I think I like this method better than packing up NVRAM with a bunch of ASCII. Buys a little time before I upgrade to a newer version.
    Thanks for your comments, as far as a manpage for nvram, from what I've read, nvram is "tweaked" by the developers of different flavors of embedded software for their purposes, not sure if there is a "one size fits all" manual. Of course, nvram -h is fairly informative. It doesn't seem to be a part of busybox.
    Edit: Hmm, well wikipedia entry on busybox does list nvram as part of busybox.
    However, busybox.net does not. You got me.
  4. Planiwa

    Planiwa LI Guru Member

    nvram lives here:
    :; l $(which nvram)
    -r-xr-xr-x    1 root    root        41120 Jan 16 12:21 /bin/nvram*
    But I'm not interested in invocation parameters -- I'm interested in the question:
    "What were they thinking?!?"

Share This Page