1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nvram reset?

Discussion in 'Tomato Firmware' started by Homeless2, Oct 28, 2007.

  1. Homeless2

    Homeless2 LI Guru Member

    For some reason my router no longer allows me to login through http using the correct password. I've been trying to use the SSH daemon and telnet to try and get access to the router but have not found any success.

    I was wondering if there's any way I can either reset the nvram to clear everything or even reflash the router so that I can access it again. Thank you for your time.
  2. roadkill

    roadkill Super Moderator Staff Member Member

  3. Homeless2

    Homeless2 LI Guru Member

    Unfortunately for me that didn't work. I can now access the router via telnet, however I have no idea what to do from here.
  4. u3gyxap

    u3gyxap Network Guru Member

    Via telnet, type:
    nvram set http_passwd=admin
    nvram commit

    And you should be good to go with user "root" and password "admin"
  5. Homeless2

    Homeless2 LI Guru Member

    Just tried and those don't work either. I also tried nvram get http_passwd which didn't work either. Is there a way I can clear the nvram?
  6. u3gyxap

    u3gyxap Network Guru Member

    Sure, just power on the router and hold down the reset button for 30 seconds. Not the AOSS button, but the small reset button. Then release the button and wait for another 30s. Then power-cycle the router.
  7. Rafatk

    Rafatk Network Guru Member

    What router do you have? If it is a WRT54G(S or L), did you try to reset with the button on the back of the router?
  8. Homeless2

    Homeless2 LI Guru Member

    30 second reset worked, thanks

Share This Page