1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Official Tomato v1.17 released

Discussion in 'Tomato Firmware' started by jeradc, Feb 27, 2008.

  1. jeradc

    jeradc LI Guru Member


    * Fixed PPPoE connect on demand.
    * Fixed DHCP not passing current DNS address.
    * Fixed TZO external IP check results in chopped address.
    * Lenghtened DDNS hostname field.
  2. danix71

    danix71 LI Guru Member

    What are exactly those *fixes*? I mean, they are important things or just cosmetic ones? Does anybody know? It doesn't suppose to flash every month our routers...
  3. Kiwi8

    Kiwi8 LI Guru Member

    Well, the first three fixes are important ones for those who use them, for example those who use PPPoE will need to have that fixed if they want to use "Connect on Demand".

    As for the last one (lengthening) yah it is mostly cosmetic.
  4. danix71

    danix71 LI Guru Member

    The last six-thousend-and-seven :) versions have their 'PPPoE fixed'. Why not once it for all? Will reach v.2008.2008 soon, and all with PPPoE stuff...
  5. LucasMoon

    LucasMoon Network Guru Member

    No difference for me from 1.16 to 1.17 at all. It does not want to connect pppoe at all. Staying alive or by demand only .....it wont connect at all.
    I am sticking with 1.15 that is the only one that work so far.
  6. danix71

    danix71 LI Guru Member

    I have one WRT54GL v.1.1. with an ''rotten'' :) Tomato v.1.07 that it's perfect for my PPPoE connection. Missing alotta of the others gimmicks but this is super oke. So in the 'upper' versions of the firmware you add, I don't know...scripts&tricks but you mess up the PPPoE section?
  7. LucasMoon

    LucasMoon Network Guru Member

    No idea what happen from 1.15 to the next 2 version but seem like pppoe has been modified to a point that WRT54GS does not work with both latest versions of Tomato. Tested on 3 different routers of 1.4 of WRT54GS and fat chance that they actually want to work.

    Would be nice to know what happen....any drivers missing on those latest bins for WRT54GS to make pppoe to work?
  8. DeCex

    DeCex LI Guru Member

    Sorry if this might be a st00pid question but you do erase NVRAM after upgrade and restore config + another reboot of router after flashing?

    1. Backup settings
    2. Upgrade firmware
    3. Erase NVRAM memory
    4. Restore settings from backupfile
    5. Another reboot just to be sure.

    After those 4 line above still not working ?
  9. LucasMoon

    LucasMoon Network Guru Member

    First try I do just an upgrade over what I have. When this does not work then I do the baby steps.
    1. erase nvram
    2. upgrade firmware
    3. erase nvram again to make sure.
    4. config and reboot

    And in this case for the past 2 versions no show. I am not the only person having this issue also.

  10. Rafatk

    Rafatk Network Guru Member

    LucasMoon is not on the boat alone!
    I am in the same situation.

    What DeCex suggested works. I did it myself, because everytime I setup a new Tomato firmware I always backup the config.
    I was using Tomato 1.14 and then jumped straight to 1.16, what happens is if you restore the config from a previous version of Tomato, the PPPoE works. But if you start from scratch it will not work.
    I guess I will stick with 1.15 if it is the last one that works.
  11. der_Kief

    der_Kief Super Moderator Staff Member Member

    New version works fine here :wink:

    For all of those who have troubles with pppoe please remeber that Jon implemented a newer pppoecd since ver. 1.16 ! I had a big problem with my pppoe connection and Jon was very helpfull with fixing these problems. So you have to contact Jon and he will find a solution, i'm sure. To get the new pppoecd work stable Jon needs your help !!!

  12. GhaladReam

    GhaladReam Network Guru Member

    Version 1.17 working flawlessly on my end :)
  13. Sopmod

    Sopmod Network Guru Member

    Looking at the fixes, I can't see any that addresses the issue I was having regarding my PC seemingly disconnected from the world. No Port Forwarding to my Bittorrent application, unable to browser to the WRT54G, however when I rebooted my PC all things worked and the router seemed "normal".

    Dropped back to 1.15 and the issue is resolved. No problems at all.

    Still looking for an answer if anyone can provide one.
  14. kmindi

    kmindi LI Guru Member

    Just one question, is it possible to avoid a reboot of the router.
    For example if Jon gives us a patch file or something like this.
    And with that we can ssh into our wrt54* and overwrite the new files.
    Or is this way of thinking wrong?
  15. LucasMoon

    LucasMoon Network Guru Member

    I just did that....backup my 1.15 settings.
    1. clear nvram
    2. upgrade to 1.17
    3. clear nvram again
    4. upgrade 1.17 again
    5. rebooted
    6. RESTORED my backup settings from 1.15

    NO SHOW!

  16. Low-WRT

    Low-WRT LI Guru Member

    Are you working on an uptime world record?:wink:
  17. kmindi

    kmindi LI Guru Member

    Yes of course.
    No not really but I like to have a long uptime
    and I don't want to disable and enable the jffs2 partition everytime.

    So if its possible, I would prefer it.
  18. Toxic

    Toxic Administrator Staff Member

    have you reported your problems to the author and given him your wan settings? unless HE can duplicate a problem it is very hard to fix.

    this is to all.....

    if you dont contact him well.... the problem wont be fixed.
  19. Toxic

    Toxic Administrator Staff Member

    I would strongly advise not to restore if you are having problems. contact the author and ask him will the 1.15 config affect the 1.17 if you restore if from an older firmware. my guess is it might if your having problems.
  20. c007c

    c007c LI Guru Member

    I'm a long time user of DD-WRT, and recently switched a WHR-G125 to take advantage of the better QoS for a Skype dualphone. What a difference in the quality, incredible!!! One strange difference though, the phone no longer keeps correct time. If it sits idle, it falls behind till I use it then it catches up. I left NTP with defaults other than using the US servers.

    Also, I'm thinking about switching more gear. Is it possible to add USB and print drivers for a WL-500gp? Thought I read somewhere thats not possible.
  21. Sunspark

    Sunspark LI Guru Member

    I must confess I am puzzled at the problems some of you are having. I do not say they don't exist as they are real to you, but I am uncertain as to why it is happening.

    For me on this WRT54GL it has always 'just worked'. Here was my upgrade process on this router:
    1. Original stock Linksys
    2. Reset all to factory settings from within Linksys firmware
    2. Install Tomato, I THINK I did a full nvram erase from within it.
    3. New version of Tomato is out, reboot router, I then flash it in through the web interface, but wirelessly (I am lazy and live dangerously).
    4. It reboots after the flash, and then just works.

    mstombs: I looked at the logs with this new version, I don't see any change from what I pasted you before on the dns stuff. How is it on your end?
  22. njeske

    njeske Network Guru Member

    i'd really like to keep my router going with the latest tomato, but i'm still running 1.15 on both of mine at home. i use PPPOE for my WAN connection, and i'm not willing to upgrade when so many people seem to be having issues with 1.16 and 1.17.
  23. pharma

    pharma Network Guru Member

    Thanks Jon for the great firmware! I've had no issues with the 1.16 or 1.17 New Driver Experimental versions.

    Version 1.17ND (New Drivers) working fine on my WRT54G's. :biggrin:

  24. Kiwi8

    Kiwi8 LI Guru Member

    I have no issues so far with the current issue, even when not doing a thorough NVRAM reset (though I would strongly suggest those having problems, to at least try the thorough NVRAM reset first).
  25. Merlyn_3D

    Merlyn_3D Network Guru Member

    My wireless still only remains spotty and about 1/2 as fast even after an NVRAM reset on the WHR-HP-G54. I'm going back to 1.15 again.
  26. Moombas

    Moombas Network Guru Member

    No problems with PPPoE here on a WRT54Gv2. In fact, I've never had a problem with PPPoE and Tomato for some strange reason.

    Bug with the ND build: The "Model" listed under Status -> Overview on a WHR-G125 is incorrect. It is listed as "Broadcom 5/0x048e/00/0x11/0x750"
  27. mstombs

    mstombs Network Guru Member

    This version 17 now works for me the same as 15 or below [and no I didn't clear nvram or reset to defaults, and the WRH54G.bin has wrong code pattern for my wrt54gsv1.1 via web upgrade!] dnsmasq is restarted when the WAN dhcp reconnects and re-reads the dns servers etc.

    Tomato only supplies 3 DNS servers to dnsmasq, via resolv.dnsmasq, so if you specify 3 static dns the "use supplied dns in addition to static" has no effect.

    I get 2 dns servers via dhcp, so I add one opendns server, and dnsmasq gets them all.

    I believe the 3 servers limit is a Tomato restriction, not dnsmasq, so I'll have a further look and see if there is a workaround via the conf file, or submit a feature request.

    Edit:A workaround is to not enter your additional (open)dns servers in the static dns fields, but to add them to the web gui "Dnsmasq Custom Configuration" with

    For more info see,


    and other posts in that thread re dnsmasq and OpenDNS - not specifically a Tomato 1.17 issue
  28. LucasMoon

    LucasMoon Network Guru Member

    not the problem.

    I tried numerous ways ..even did a fresh install and a fresh nram reset and did everything back manually.

    has you can see I am not the only person having issues with the same type of router I have.

    If you look not one member came out saying they have no issues at all with the router version we got.

  29. Odin-60

    Odin-60 LI Guru Member

    Huh? No.

    Did you send a proper bug report (including the configuration
    and a log file showing the bug) to Jonathan, as suggested?
  30. dvaskelis

    dvaskelis Network Guru Member

    No issues on my WRT54GS v2. Did not try the "ND" version.
  31. Rafatk

    Rafatk Network Guru Member

    I contacted Jon about the PPPoE problem.
    And I sent all the things he asked for.
    Now let's see what happens, I will let you know when I got an answer from Jon.

    Another question for those experienced ones, I have a WRT54GSv4, can I load a WRT54G firmware? Or is it not recommended? I am suspecting maybe the WRT54GSv4 firmware is the problem.


  32. pharma

    pharma Network Guru Member

    I had no problems with 1.17, or 1.16 ... :)
  33. pharma

    pharma Network Guru Member

    The firmware is all the same, the only thing that is different is the header that distinguishes since each router model individually. The firmware is all based off the WRT54 GL firmware. You best go to Jon's site and read the FAQ which will give the specifics. :)
  34. LucasMoon

    LucasMoon Network Guru Member

    ADSL or Cable?

    People that has cable...have no problem.

    And yes I have send all infos, no response yet.

  35. tstrike2000

    tstrike2000 Network Guru Member

    I thought the ND versions would only flash on and are made for the Buffalo routers?
  36. szfong

    szfong Network Guru Member

    ND releases works on WRT54G v2.0 and higher, including the Buffalo Routers. I wouldn't try it on anything lower than a bcm4712 (eg. WRT54G v1.0 or old asus routers).

    Also, the Broadcom 4.130.XX Wireless Drivers used in the ND release does not seem to be very stable OR as stable as the Broadcom 4.150.XX Wireless Drivers. Wireless Survey will cause it to suddenly disconnect. Not sure why he chose the 4.130.XX release.

    I hope Jon will upgrade the Broadcom Wireless Driver to v4.150.XX in the next ND release. The other 3rd party firmware that I have going on a couple routers use Broadcom Wireless Driver v4.150.10.5 appears to be VERY STABLE!!! No "RANDOM REBOOTS WHATSOEVER" that had plagued those routers w/ Tomato v1.16 std drivers. Site Survey does not cause disconnects. And most importantly, more than two months worth of uptime (24/7) traffic at a constant rate of about 2-3Mbps UP and 300-400Kbps DOWN in AP+WDS mode with no issues whatsoever.

  37. TexasFlood

    TexasFlood Network Guru Member

    I was thinking the same thing. After I read pharma's post and looked at the tomato FAQ, I decided to give it a go. I loaded Tomato_1_17_ND WRH54G.bin on my WRT54G (V2) and WR850G (v2). No problems, everything went fine. Not sure what it did for me, if anything, but everything seems to be working now. I can always fall back if I need to, like I fell back to 1_13 for a bit when I was having DHCP problems.

    *Update: DHCP problems seemingly back, don't have time to analyze it now, just falling back to 1_13 which I've had good luck with.
  38. sheerspt

    sheerspt LI Guru Member

    I am testing the 1.17 firmware and have noticed problems with the PPPoE connection when I am surfing the connection goes below in net during the night by this time is below the link go to the web panel and see that my connection but I is established by moments (some seconds) without connection but as I said if the panel's web router says that the connection is established in PPPoE.

    My router: Asus WL500GP

  39. Sunspark

    Sunspark LI Guru Member

    Your message is very hard to understand. If english is not your first language, try writing it in your native language. Someone here might understand it.
  40. Sunspark

    Sunspark LI Guru Member

    I think I might have crashed the router.. I changed the static DNS entries while a bittorrent d/l was trucking away, hit save.. got the yellow settings changed, services restarted, and then it locked up solid.. Had to power cycle the router to get it back.
    This never happened before if no transfers were happening.
  41. myersw

    myersw Network Guru Member

    I have used SBC now AT&T ADSL for 5 years. Have never had a ppoe disconnect issue with linkys firmware or Tomato. Have used Tomato since version 1 which would not work on a WRT54G v1. Sent Jon my version 1 so he could fix the problem.
    Cannot guess what your problem is. My guess it has something to do with the individual provider since only some folks have issues.
  42. sparcx

    sparcx Guest

    I upgraded from DD-WRT v23 SP2 to tomato 1.17 without any issues on my WRT54G v2.

    I did the "nvram get http_passwd" as stated in the instructions to get my password. Everything completed smoothly via the web interface.

    Setup was very easy. Great experience so far with tomato.

    Hope that support for this firmware stays consistent. :)
  43. pharma

    pharma Network Guru Member

    After using this for a few days, I decided to go back to Tomato version 1.17 using the Older Drivers.

    While I had no major issues with 1.17ND,I find the 1.17OD version to be faster and more responsive when accessing and downloading stuff from the internet. I know it's a subjective thing, but something you can definitely notice. :)
  44. StevenG

    StevenG LI Guru Member

    I'm still running 1.11. I've been nervous to mess with it as it seems like the last few releases have been inconsistent with results. Is this the case or am I reading too much into a few issues here and there?

  45. Gewehr98

    Gewehr98 LI Guru Member

    Another data point...

    Tomato v1.17 runs just fine on an older WRT54G v1.0. I just updated it tonight from the v1.14 it had been running previously. :biggrin:
  46. sheerspt

    sheerspt LI Guru Member

    I have a ASUS WL500G PRemium with firmware DD-WRT v23 SP2 (09/15/06) I can make upgrade for the tomato firmware 1,17 through the DD-WRT Firmware? After installing firmware tomato password does not get excited?

    Regards sheerspt. :smile:
  47. der_Kief

    der_Kief Super Moderator Staff Member Member


    please read the FAQ -> http://www.polarcloud.com/tomatofaq#installing_from_ddwrt_hyperwrt

  48. M_ars

    M_ars LI Guru Member

    updated from 1.13 and everything works fine. Good work
  49. sheerspt

    sheerspt LI Guru Member

    der_Kief, thank you Works 100% :D.

    Regards sheerspt.
  50. der_Kief

    der_Kief Super Moderator Staff Member Member

    No problem at all :)

  51. BassKozz

    BassKozz Network Guru Member

    Ditto, I am sticking w/ 1.11 for now, I haven't seen much as far as added features that I would need since 1.11, except for L7 filters...
    Is there a way to upgrade the L7 filters w/out having to upgrade to newer FW revision?
  52. szfong

    szfong Network Guru Member

    I recommend trying the newest version, I usually perform a router swap. I have more than 1 of same router, upgrade old router, swap it, do not upgrade the recently swapped router, test it for a week if it's ok, keep it, if not swap it back, once a new firmware is released I upgrade the the non-connected one on hand and perform the swap all over again. That way I have virtually no downtime, all leases gets renewed automatically.
  53. njeske

    njeske Network Guru Member

    despite my concerns with pppoe, i went ahead and upgraded to 1.17. i'll post if there's any issues.
  54. TexasFlood

    TexasFlood Network Guru Member

    It's looking like I may have been wrong about it being a DHCP issue with the 1_17ND version. I'm not sure what it was, but I was losing wireless connectivity consistently after a while. However I was able to get right back in by plugging in directly with a cat6 cable. I went back to 1_13 for that day but since upgraded back to regular 1_17 and it seems to be working fine after a couple of days. So it must have been something related to 1_17ND that isn't happening with 1_17. Hopefully I don't have to come back right away and correct myself on this again, :-D
  55. StevenG

    StevenG LI Guru Member

    I so would love a whitelist filter feature though. That's the one stupid feature I really like about the ActionTec Verizon Fios router.

    I love Tomato though.
  56. PARC

    PARC Guest

    Runs smoothly on my WRT54G V4 :)

    Just sharing how to upgrade and restore config when doing a firmware upgrade.

    1. Backup Config (from old firmware)
    2. Erase NVRAM
    3. Upgrade Firmware
    4. Restore Config (using old config backup)
    5. Backup Config again (from new firmware)
    6. Erase NVRAM
    7. Restore Config (using new config backup)

    The point of doing another backup using the new firmware is so that a config backup is created using it and not with the old firmware. Works fine with me for the past upgrades :)

    Hope this helps :) This is just my way but I'm sure others have a different take.

  57. cpgbg

    cpgbg LI Guru Member

    I'm using Tomato since version 1.13 and I never had to Erase NVRAM and restore config after upgrade. I just flash the new version and everything works fine. Of course I always make backup of config before flashing so I can restore it if something goes wrong.
  58. szfong

    szfong Network Guru Member

    On two separate WHR-HP-G54 (Tomato v1.17), bought about 3 months apart, and were brand new, experienced "a random" reboot yesterday, after setting and using AP+WDS w/ WPA/WPA2(mixed)+AES. They ran for about 12 hours before randomly rebooting, detected from the low uptime. My client was running WPA2-PSK.

    One other WHR-HP-G54, in AP+WDS w/ WPA+AES ran perfectly w/ an uptime of weeks now. Client of course was running WPA+AES. Is there an issue w/ AP+WDS using WPA/WPA2(mixed)+AES as opposed to regular WPA Only+AES? Is anyone else experiencing this issue?

    I figure there isn't much advantage between the two anyways, so I'm inclined to switch my network to use WPA Only when coupled with AP+WDS if this issue isn't fixed. This issue seems to only crop up in AP+WDS mode, though.

  59. eRd12

    eRd12 LI Guru Member

    Is there any possibility to contact with Jon? Email or something? Because from couple of versions (I remember that 1.07 was ok) after watching for example "last 24 hours" and change to "QoS graphs" the router is rebooting and for a while the connection with it is lost (what is normal while rebooting). Could somebody get this info to Jon? I'm from openlinksys (polish forum) and not only me get such problem :(
  60. LLigetfa

    LLigetfa LI Guru Member

  61. szfong

    szfong Network Guru Member

    Hi eRd12,

    It's best to contact Jon, if you can re-create the "exact" circumstances which results in the reboot or else he won't be able to help you.

    But, it's a common occurrence that every once in a while Tomato will auto reboot itself. It's happened in several of my Tomato routers. It's not a power issue because the exact same router models running a different 3rd party firmware has not rebooted itself in over 2 months, given by their uptimes. I've even swapped firmwares w/ a couple of known good routers to eliminate possibility of hardware irregularities and Tomato still randomly reboots sometimes. Tomato v1.17 appears to do it more frequently, though. I'll just call the random reboots a feature for now. hehehe :)
  62. pharma

    pharma Network Guru Member

    I get NO random reboots on my routers, for the current 1.17 or past Tomato software. So I would not call it a "common occurance" in Tomato.

    If you are getting "random reboots" I'd say it's more a function of what settings you or your IP are using, or the type of router you are using and whether it's truly compatible with the WRT54GL base firmware. Just an observation, but it seems to me most people having the problems are NOT using stock Linksys WRT54G, WRT54GS or WRT54GL routers.

    Once Tomato became available, the only time my Uptime changes is when I upgrade to a newer version, or when I have a power outage. :)
  63. eRd12

    eRd12 LI Guru Member

    Pharma to be precisely I have no reboots just as, it isn't (WRT54GL) rebooting itself and sometimes, it is rebooting in such situation - I'm watching "last 24 hours" and I click the "QoS graphs" button and it would not show, the screen freezes and router is rebooting. This is going like that just sometimes and only in such situation. If I wouldn't touch my router it would be stable as rock.
  64. szfong

    szfong Network Guru Member

    It's true, that "certain" setup will cause Tomato to behave less reliably than others. Such as AP+WDS. You may try a reset to defaults/nvram erase and then a "clean" re-flash to see if it helps.
  65. pharma

    pharma Network Guru Member


    What browser are you using? I know there is a special download for people using Internet Explorer to get the graphs to work. You might also want to check the Tomato FAQ on Jon's website or the readme included with the download to see if there are special instructions if you are using another browser.

    There is also a FAQ on this forum that has a section devoted to Web Browsers. It might be worthwhile to take a look to see if anything matches your situation.

  66. eRd12

    eRd12 LI Guru Member

    I'm using FF but the same thing is on IE, it must be problem with tomato. I was flashing router and clearing nvram, it doesn't help. Maybe such situation make very high usage cpu in a bit of second, I don't know :confused:
  67. szfong

    szfong Network Guru Member

    I had strange lockups on a few routers a couple years ago after flashing between Tomato, OpenWRT, DD-WRT, Stock, and HyperWRT on the same router. Following these 6 steps may help, I believe it causes it to revert back to "factory" defaults that are stored in the CFE bootloader:

    1. unplug router,
    2. wait 1 minute,
    3. depress reset button and hold,
    4. plug power,
    5. continue holding reset for 1 minute,
    and finally,
    6. release reset button.

  68. pharma

    pharma Network Guru Member

    @eRd12 ...

    Follow szfong's instructions with regard to resetting your router. Also after resetting, manually set the Tomato parameters/settings -- do not use an old config file from a previous firmware version.

    If this does not work, try the Tomato version you said that worked (1.07) and see if this issue happens. If the same thing happens with your old version then the problem might not be Tomato, but something else may have changed. It might be with your IP provider, maybe a computer program or setting, or maybe your router doesn't function correctly any more.

    The only way to determine this is to try a different Tomato version that worked (1.07) or different firmware (DD-WRT). There are too many people using Tomato on WRT54GL routers, and it this was really a big Tomato issue you would see thousands of messages from people with the same disconnect problem. :)
  69. Jonny_doe

    Jonny_doe Network Guru Member

    With tomato 1.17 i can't get any wireless to work , (psp, phone, etc)
    i've reflashed 1.17 , and cleared nvram , but still no wireless , any ideas ??
    I'm using a WRT54GS

    Edit : don't worry it looks like my wrt54gs can't do wireless now with any image
  70. kzrssk

    kzrssk LI Guru Member

    I have a server that's connected via ethernet, and just remote into and use it whenever I want to upgrade the router.
  71. averylinden

    averylinden Addicted to LI Member

    I am also having some problems with my WRT54Gv4 rebooting with 1.17.

    I never saw these problems with 1.15, so I tried downgrading but the reboots continued. I also tried a thorough NVRAM erase and entered my configuration in again by hand but that didn't seem to help matters.

    The only major change that I've made on my side is that I've gone from using just 1 of the 4 ethernet ports to all 4 (I consolidated my network and moved a switch), so the load on the router may be higher than it was before.

    Are there debugging settings I can turn on to see why the reboot is happening? I forwarded syslog to another server on the network but there are no relevant messages to help track down the problem.

    Thanks for any advice. I love Tomato and I hope I can get it stable again.
  72. scolbeck

    scolbeck LI Guru Member

    I am getting regular reboots on my WRT54GL v1.1 approximately every 2 days with 1.17. I don't think it is load related as in at least a few occurrences, there was little to no activity on the router prior to the reboot. I also tried a variety of debugging setting in order to catch the problem in the logs with no luck.
  73. szfong

    szfong Network Guru Member

    It is probably wireless driver related, try the "new driver" version and see if it helps.

  74. pharma

    pharma Network Guru Member

    Try a different version of the Tomato firmware, like 1.15 and see if you still get the problems. I don't think it's your wireless driver because: 1. You are rebooting once every 2 days 2. The base Linksys firmware used in Tomato is from the same router you use.

    Since our models are basically the same (54G v4 & GL 1.1), I'd stay way from the "New Driver" versions - very unstable on my routers. I'm currently using 1.17 with no issues.

    Anything special in your setup? What parameters are you changing after you install the firmware? - the last question is probably the most important.
  75. Harry100

    Harry100 Addicted to LI Member

    Hi my first post here, but I have used Tomato some months now. I have some issues with random reboots. The Uptime counter starting on 0 again after 3-4 days.

    My question is, can the wireless card on my computer make the tomato firmware reboot? I use a Intel ‎Intel(R) PRO/Wireless 2200BG card on a HP laptop. (with Linux as OS).

    I get random reboots on a WRT54G ver 2.0 With both 1.15 and 1.17 version.
    I also got reboot with a WRT54GL ver 1.1 in a other house with a different modem from the ISP.
    Both places I used the same computer.

    On the WRT54G I didn't use my computer for 5 days, and it hadn't rebooted. Then I connected my computer and it was up for 2 more days before a new reboot.

    I use default settings, except from a simple WEP key on my wireless.

    EDIT: and yes, I did a complete NVRAM reset before and after the upgrade, did also a couple of reboots manual.
  76. szfong

    szfong Network Guru Member

    Yes, the client adapter driver CAN cause random reboots, as well as someone performing packet injection whether accidentally or on purpose. Newer wireless drivers seem to be more immune to such behaviors. 1st upgrade client drivers to see if it helps and 2nd try using new driver release of Tomato. 3rd check if it's a power issue, connect to UPS. Anyhow, high connectivity count by different wireless clients can also cause reboots. Perhaps, Cisco/Linksys released the binary drivers to be less reliable than their commercial/expensive offerings in order to avoid cannibalizing their lucrative corporate/campus wide installations.
  77. scolbeck

    scolbeck LI Guru Member

    I moved to the 1.17_ND version and so far, it seems to resolve my reboot problem. On 1.17 I never had more than 2 days of uptime. Now on 1.17_ND, it is still going strong after 5 days.
  78. szfong

    szfong Network Guru Member

    It's good to hear that!! Honestly, overall Tomato "old drivers" are quite reliable. But you must be living in a place w/ relatively high concentration of wi-fi users. One of them may be "ethically" challenged :-( and doing packet/arp injection on you incorrectly. Since your using wpa, all he can do is crash the old drivers.
  79. nvtweak

    nvtweak LI Guru Member

    I reported this to Jon. Fixed for next release, along with the AOSS button :cool:

    BTW. Can anyone that is NOT using OpenDNS test for me the following link? My clients are having troubles accessing it through the router.


    I wonder if it is a firmware issue or just something wrong with my ISP DNS servers..

    Thanks for your help.
  80. LLigetfa

    LLigetfa LI Guru Member

    Link opens fine for me.
  81. szfong

    szfong Network Guru Member


    Link opens fine for me also, but every once in a while they go on a long maintenance cycle.
  82. nvtweak

    nvtweak LI Guru Member

    OK. Thanks guys.

    I don't know what is going on then. I just tried connected directly to cable-modem (no router) and still cannot access that link.

    If I set up the router for OpenDNS, it works. But I used to get problems with Google thinking I'm some sort of bot... so I hope this is not final/long term solution.

    My ISP is Charter 5mbit.
  83. cpgbg

    cpgbg LI Guru Member

    I didn't upgrade to 1.17 because I don't have problems with it and I was tired of flashing. Here is what I see in the Overview page:
    I don't use the wireless much, so I didn't have any unexpected reboots.
  84. LLigetfa

    LLigetfa LI Guru Member

    You know, there are other DNS servers you can test.
  85. nvtweak

    nvtweak LI Guru Member

    I can handle Googling for popular DNS servers, thanks. I was just concerned that it could be a firmware issue. But it clearly wasn't.
  86. nobugme

    nobugme Network Guru Registered

    If i have a strange problem, that did not occur in 1.15:

    When connected with PPPoE, the PPPoE session does not go down, when the physical WAN Link goes down (e.g. cable disconnected).

    This is very annoying, since when the WAN port comes up again, the old PPPoE session is still alive, but doesn't work. I have to manually shut down the PPPoE session.

    Its probably related to some PPPoE Keep-Alives issues.

    Can someone confirm this problem?
  87. F157

    F157 LI Guru Member

    Yes, I can confirm this.
    I had 1.17 installed and noticed this behaviour after taking my modem off the power, an then on again. looking into the routers webpage it said, that it has been online for about 12 hours, which could not be true.
    I don't know if this did happen with older versions of tomat.

    A few days ago I installed the ND version, I'll check again as soon as I'm at home.
  88. cpgbg

    cpgbg LI Guru Member

    Finally decided to upgrade to 1.17 because there is no new version for a long time.
    Before I do that I want to show my uptime with 1.16:
  89. modis

    modis Network Guru Member

    i have installed tomato 17nd on two my linksys 54gl. Both works in WDS mode. Distance ~9 km (city)
    Status page:

    Model Linksys WRT54G/GS/GL

    Time Sun, 13 Apr 2008 22:54:32 +0300
    Uptime 38 days, 08:51:12
    CPU Load (1 / 5 / 15 mins) 0.00 / 0.02 / 0.00
    Total / Free Memory 14.15 MB / 1,036.00 KB (7.15%)

    Data speed ~ 3,5-4 MBps

    Very stable !
  90. joeyford1

    joeyford1 LI Guru Member

    super long thread and nobody will prolly even read this but I have the same issue except that rebooting the router is the only thing that works... for about an hour. Its the same bug with the DHCP that caused the net to stop working. The bug is still there. im back to 1.15 too. its the only one that works. I wish I could find 1.07....

    EDIT: I am using a WRT54G v2. 1.17 actually worked for a while with an automatic reboot every sunday at midnight. It just stopped working properly one day. I have DSL. the modem automatically connects and gets the IP. Tomato gets the IP just fine and will work for about an hour then the net totally drops out requiring a router reboot for about another hour of net use. We have 2 Vista comps and 3 XP pro comps, non which are able to connect to the net.

    The only way I was able to solve this was to load a different firmware! (DD-WRT) and then go back to 1.15. I assumed it was a problem with my router but it seems that I am not the only one still having problems. Please note that this is after a ton of reboots and nvram clears and using default settings. Nothing worked except for switching back and forth between firmwares.

    To bad there isnt anywhere to submit a bug report.
  91. Kiwi8

    Kiwi8 LI Guru Member

    Bug report can be sent to Jon's email address at his website http://www.polarcloud.com/tomato
  92. joeyford1

    joeyford1 LI Guru Member

    Thank you. I don't know why I didn't think of that.

Share This Page