1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ok! I am enough with WAG54G V2!!!! (Now It works!!!)

Discussion in 'Other Linksys Equipment' started by newaol, Mar 27, 2005.

  1. newaol

    newaol Network Guru Member

    So many bugs!!!!!!!!

    I got these problems and other people share them with me!

    My post with bugs found by myself:

    Only bugs!!!!!!!

    Other's reports

    1. Microsoft Web sits not accessible when use AOL BroadBand
    No hotmail, not messenger, only webpages - so more or less my computer looks like a TV!!

    Check out this, unlucky buddy, I am on the same boat with you!
    Can't Connect to MSN Sites

    Try open hotmail in AOL's software, this works for me. AOL uses hidden proxy in their own soft?


    2. Windows Network connections shows Internet Connection but marked "disabled"

    disabled connection

    This seems to be correlated with WAG's buggy UPnP functionality



    3. Router's Current Time Not Available

    NTP daemon on this router seems not work!

    Current time is unavailable



    Finally, anyway it is on Linux, but Linksys CLOSED the open source softs(GPL...) on it from us! Linksys someone will sue you!

    So, I am going to use this below to hack it:

    WAG54G V2 is a Linux Box

    see the post near the end of page

    Thanks PinPin for pointing out this page for me!!

    please pray for me, I will post here my results if I could make it working.

    Thanks everyone.
     
  2. Toxic

    Toxic Administrator Staff Member

    BTW UPNP has neverw worked well on any router i have used. disable it. and use port forwarding

    As i have stated time and time again in this thread

    http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=602

    report the faults to linksys.

    sharing your problems and issues on the forum is good, but there has never been any sign or indication that linksys themselves read these forums. To that I must strongly suggest you need to report these findings to linksys, and ask that the email is sent to R&D so they can deal with the issues you and many others have.

    the email addresses you should use are listed on the link above.

    btw FYI the main domain is linksysinfo.org and not linksysinfo.com

    .com and .net are both parked domains pointing to linksysinfo.org
     
  3. newaol

    newaol Network Guru Member

    Thanks.

    I did email them one day before I posted this post, and sorry, my fingures added the .com themselves.

    I had announced my workmates that there probably will be a router smash show in office.
     
  4. newaol

    newaol Network Guru Member

    It works!!!

    First, Linksys did not reply my e-mails. They are supposed to reply some useless answers at least!

    Anyway,

    1. for AOL users We need to use 2nd ScreenName for router! The main ScreenName does not work!

    2. MTU of the router have to be changed to 1200 !!!!

    3. I also changed to PPPoA (Aol requires PPPoE but this works. forgot to say this before edit this post)

    The screen name thing does not impact the performance at all, but the MTU does!

    But it is not all, there are still problems!

    1. NTP on the router still does not work!

    2. Someone reported that the NAT in the router has time out problem which will cut up your SSH connections after you left it 1 hour or so. My SSH connections had been cut up a few times showing "connection closed at peer". I am not sure whether it is a setting of our server or WAG54G V2 bug. I need to talk to admins of our company.

    3. UPnP seems fine but the p2p soft Azureus reprted errors twice. I have not tried this so much as I am working DMZed. But the Internet Gateway in WinXP alwasy labled as "Disabled"


    BTW, the firmware of WAG54G V2 comes with a root file system in squashfs. I downloaded the source which only works in Linux but I am using FreeBSD. So have not done any hack work yet.
     
  5. CaltorStorm

    CaltorStorm LI Guru Member

    WAG54Gv2 = Dodgy Model

    I realise this is an old topic but just wanted to give some feedback here.

    I too had the FTP upload problem with my WAG54G v2 so I upgraded the firmware to 1.02.00. However this caused my ps2 (Playstation 2) to stop working online which it did before. I then tried various other firmware versions none of which would allow my playstation to work online. I therefore contacted Linksys via Livechat on their website and after explaining the full situation to the engineer they have agreed to replace the router. I think that the WAG54G v2 is fatally flawed. Not sure if it is the hardware or the firmware but I don't think it is possible to get everything working on that model. :wall: As that model is now end of life the replacement router will hopefully be a more stable model that actually has a firmware that works.
     

Share This Page