OpenVPN Server: Port keeps being reset to 0.

Discussion in 'Tomato Firmware' started by YeOldHinnerk, Sep 24, 2013.

  1. YeOldHinnerk

    YeOldHinnerk Serious Server Member

    Dear all,

    I use a WRT54GL with the following firmware:
    Tomato Firmware 1.28.0005 112 ND VPN

    I'm trying to set up a VPN server. I have followed the tutorial (crosschecking several), imported keys, certificates and DH parameters, saving after the configuation of each tab in the tomato GUI.

    However, when I click "Start now", I find the following error message in my Logs:
    Sep 24 21:40:26 adr2 daemon.err openvpn[607]: Options error: Bad port number: 0
    Sep 24 21:40:26 adr2 daemon.warn openvpn[607]: Use --help for more information.

    Please give me so much credit to believe that the port was NOT 0. When I check, the port field is empty. Well, try again, enter a number, say 1194, save, wait a moment, hit start. Same error.

    I rebooted the router and tried again, didn't help.

    Any ideas?

    Thank you,

    YeOldHinnerk
     
  2. YeOldHinnerk

    YeOldHinnerk Serious Server Member

    Apparently, this was a memory problem. When I removed my adblock script, the service was able to start.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice