1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

owncloud and xupnpd mount

Discussion in 'Tomato Firmware' started by devlin016, Sep 10, 2013.

  1. devlin016

    devlin016 Addicted to LI Member

    is it possible to mount a webdav directory and have xupnpd server host all the music in the owncloud directory.
    I cant seem to mount webdav google or the forum search tells me nothing besides I need to use davfs2 but its not under my repo im using a Netgear WNR3500L with shibby tomato
     
    Last edited: Sep 10, 2013
  2. ryzhov_al

    ryzhov_al Networkin' Nut Member

    Hi.
    WebDAV shares may be mounted with davfs2 package. This is example of mounting Yandex.Disk cloud storage:
    Code:
    $ opkg install davfs2
    $ mkdir /tmp/yandex_disk
    $ mount -t davfs https://webdav.yandex.ru /tmp/yandex_disk
    Google drive can be mounted as WebDAV with free third-part service — the DAV Pocket:
    Code:
    $ mount -t davfs https://dav-pocket.appspot.com/docso /tmp/gdrive/
    xupnpd is a UPnP/DLNA server. You may use djmount package for that. Type:
    Code:
    $ mkdir /tmp/av
    $ djmount /tmp/av
    and wait couple of minutes. The names of local UPnP AV servers will be appeared in /tmp/av folder. UPnP content will be available as local files.

    All this possible with Entware repo. Optware contains only cadaver — a command line WebDAV client, last updated in Feb 2008.
     
  3. devlin016

    devlin016 Addicted to LI Member

    but I use the optware repo aswell theres things I need in that repo that entware doesnt have. is it possible to have entware and optware? because I only need entware for davfs2
     
  4. ryzhov_al

    ryzhov_al Networkin' Nut Member

    Which ones? Just curious.
    No.
    With Optware, the old cadaver is all you have:)
     
  5. devlin016

    devlin016 Addicted to LI Member

    I cant remember to be 100% positive but I remember trying to switch to entware and I was having problems with my custom scripts I need to have running. I think it might of been links or elinks.

    and cadaver is just a client right? that wont work I need a mount point.
     
  6. devlin016

    devlin016 Addicted to LI Member

    is it possible to switch to entware and have my old installed optware packages still working?
     
  7. ryzhov_al

    ryzhov_al Networkin' Nut Member

    elinks 0.12pre6 [2012-10-30] is here. I think there may be some differences with Optware's elinks 0.11.7 [2009-08-22].
    Unfortunately, no other Optware's package can work with WebDAV shares.
    It's like a firmware update. Some settings may be renewed, so it's strongly recommended to set it from scratch.
    BTW, I've got corrupted files when put them directly to OwnCloud folder. I think the right way to add it from WebUI or desktop client only.
     
  8. devlin016

    devlin016 Addicted to LI Member

    I wasnt going to add anything only have xupnpd stream the owncloud music directory. my owncloud server is hosted offshore not localy. what would you suggest I do? switch to entware?
     
  9. ryzhov_al

    ryzhov_al Networkin' Nut Member

    There is another issue I faced when tried to use xupnpd with djmount. When xunpnd is used to "convert" IPTV udp raw streams to UPnP source, djmount shows "0" for content length. Well, it's not an issue actually, content length can be determined for streams.
    Just make sure all packages you are using are present. Feel free to request new ones.
     
  10. devlin016

    devlin016 Addicted to LI Member

    I dont think I even need djmount for what I want.
     
  11. devlin016

    devlin016 Addicted to LI Member

    I need netio lol :p
     
  12. devlin016

    devlin016 Addicted to LI Member

    I dont understand what the problem is now I switched to entware.

     
  13. ryzhov_al

    ryzhov_al Networkin' Nut Member

    Please make sure:
    1. fuse kernel module is loaded,
    2. /tmp/cloudmusic folder exists,
    3. webdav URL is right.
     
  14. devlin016

    devlin016 Addicted to LI Member

    1. lsmod says fuse is loaded
    2. directory exists
    3. webdav url is correct verified it in firefox
     
  15. devlin016

    devlin016 Addicted to LI Member

    I think maybe theres and issue with my owncloud instance. my server returns this to tomato
    and its the correct user name and password

    also davfs reports
    when I use an alternate webdav url http://cloud.****.net/files/webdav.php
    but that url works in firefox as good as the first url I tried

    wdfs reports the same for both urls
     
    Last edited: Sep 10, 2013

Share This Page