1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

owncloud

Discussion in 'Tomato Firmware' started by were55, Nov 28, 2012.

  1. were55

    were55 Addicted to LI Member

    Hi,

    Has anybody try to run owncloud in tomato router? can someone give me some directions? I've lighttpd, mysql already running, also I installed Python3 but giveme errors about missing libraries...any clue if this can be work?

    thanks
     
  2. Chief of Awesomeness

    Chief of Awesomeness Serious Server Member

    Have you tried entware?
     
  3. samwathegreat

    samwathegreat Serious Server Member

    Chief of Awesomeness is right. Owncloud requires php version 5.3 or above. Those of us using optware are only blessed with version 5.2.17

    The alternative is to use entware instead, which has available php > 5.3 (I think its 5.4?).

    I started to use this approach, but found that the asterisk package in entware (version 1.8) had serious problems with IAX2. version 1.4, available from optware worked fine. For this reason, I abandoned entware in favor of optware (my asterisk server is more important than getting owncloud to run).

    I'd LOVE to be able to install owncloud, however. Maybe the maintainer of optware will finally update PHP for us?

    I believe that there are conflicts (something about headers) when using both entware and optware. I was told that you should only use one or the other.

    Anyways, just google entware and that should put you on the right path. Please let us know of your progress.
     

Share This Page