1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

P2Partisan [v5.14/v6.08] mass IP blocking - peerblock/peerguardian for tomato

Discussion in 'Tomato Firmware' started by rs232, Oct 11, 2013.

  1. rs232

    rs232 Network Guru Member

    I think Windows telemetry works on port 80 so no much you can done a port basis nor you want! But you canblock the IPs/FQDNs. All you need to do is to add them into the blacklist-custom file and restart p2partisan.
    As I can see from your screenshot you have 71 black references already and 14628 (?) white references + the public level1 black list is that right?
  2. glennsamuel32

    glennsamuel32 Network Newbie Member

    That is the confusing part...
    My custom-Blacklist with 17,000 ranges + the level1 = Black-ip of 323 ??
    And my whitelist has just 3 domains but White-ip shows 30,290 ??

  3. rs232

    rs232 Network Guru Member

    The references are what ipset tells


    ipset -L blacklist-custom 2> /dev/null | grep -E "(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])" | wc -l
    public lists are not included in the calculation. Also a reference can be a subnet and not necessarely an individual IP number.
    Last edited: Jun 21, 2017
  4. rs232

    rs232 Network Guru Member

    Inbound and Outbound are used for packets sourced and addressed to the router only. Forward catches (v)LAN activity.
  5. glennsamuel32

    glennsamuel32 Network Newbie Member

    Thanks for the explanation...

    Also in the level1.cidr, the first line starts with :
    create level1 hash:net family inet hashsize 131072 maxelem 4096000

    Is there anyway to customize the hash size ?
    What are the maximum sizes allowed ?
    I use the R8000 with 128 mb nvram...
  6. glennsamuel32

    glennsamuel32 Network Newbie Member

    On the ipset man page...

    This parameter is valid for the create command of all hash type sets. It defines the initial hash size for the set, default is 1024. The hash size must be a power of two, the kernel automatically rounds up non power of two hash sizes to the first correct value. Example:
    ipset create test hash:ip hashsize 1536
  7. rs232

    rs232 Network Guru Member

    That's right so the hash size is automatic, nothing needs to be tweaked.
  8. rs232

    rs232 Network Guru Member

    1 hashsize != 1 element

    P2Partisan does work out of the box no need to modify anything at the ipset level.
  9. glennsamuel32

    glennsamuel32 Network Newbie Member

    Thanks for your help !!
  10. Bird333

    Bird333 Network Guru Member

  11. rs232

    rs232 Network Guru Member

    As mentioned multipe times this is bottom of my list. Nothing personal trust me but I truly believe the download from iblocklist to be very reliable. I'm way more concerned about filtering VPN traffic which at the moment works only outbound and can't understand why.
    If you're keen into this requets of your, why don't you give it a go yourself modifying the scriopt and perhaps posting here your achievement/issues you run into so that we can get there together?

  12. NutsN'bolts

    NutsN'bolts Network Newbie Member

    Wow, ill give this a try. Sounds very usefull !!
  13. glennsamuel32

    glennsamuel32 Network Newbie Member

    Everything works well now...
    But there are constant connections on port 80 and 443...

    Can you think of a way to block these connections ?

  14. rs232

    rs232 Network Guru Member

    You do not want to filter at port level when it comes to 80 and 443.
    So add the IPs or even better FQDNs in the blacklist-custom file and run ./p2partisansh restart
    NOTE: is these are the windows10 default connection they are very likely to change throughought time.
  15. Bird333

    Bird333 Network Guru Member

    I wouldn't have a clue how to do this. Just looking at this script gives me headaches. :) I understand it's a low priority, but it's been over a year since it was brought up. Do you think you can look at it after you solve the VPN issue? Thanks!
  16. glennsamuel32

    glennsamuel32 Network Newbie Member

    Is it correct that only lists compressed in gz are valid under "blacklists" ?
    If so, will you consider lists in plain / raw text also ?
  17. rs232

    rs232 Network Guru Member

    Blacklists are the public blacklists and they are pretty much always provided in .gz format.
    What are these others clear tex lists you're referring to? Do you have an example?
  18. glennsamuel32

    glennsamuel32 Network Newbie Member

  19. rs232

    rs232 Network Guru Member

    I'm not aware of the iblocklists being outdated, regardless: no, P2Partisan does assume a specific format to be fed to it.
    This format being a text file compressed in .gz and the text organised in the format:


    China Internet Information Center (CNNIC):

    I'll see what I can do to add support for the the raw and netset formats out of the box as it seems like a good idea.
  20. rs232

    rs232 Network Guru Member

    Pulled out due to a bug

    v6.10 is out

    NOTE: this is a consistent modification from the previous version.
    A reinstallation is suggested, but if you don't want to do that, make sure you run the following commands from within the current p2partisan folder:
    rm /tmp/deaggregate.sh
    ./p2partisan.sh upgrade
    2) [optional] wget -O blacklists "https://pastebin.com/raw/ARx7NAYz"
    or add the relevant new lists e.g. raw/netset format manually before starting p2parisan again
    3) ./p2partisan.sh

    - corrected list update minor issue
    - support for raw and netset style lists (thanks @glennsamuel32 )
    - introduced control to avoid updating lists the the list URL becomes unavailable or the URL simply doesn't exists (thanks @Bird333 )
    - optimisations where possible
    - added extra tutor control against empty primary lists (tutor will try to populate the ipset)
    - modification to allow similar named lists to cohexists (e.g. "level1" and "superduper_level1")
    - adjustments to the deaggregate.sh procedure

    As usual let us know if any issue/bug
    Last edited: Jul 15, 2017
  21. sszpila

    sszpila Reformed Router Member

    Is this normal? p2partisan cannot populate blocklists?
    login as: root
    root@'s password:
    Tomato v1.28.0000 -132 K26ARM USB AIO-64K
     Welcome to the Asus RT-AC56U [Pomidor]
     Uptime:  12:45:47 up 41 days, 21:11
     Load average: 0.11, 0.13, 0.13
     Mem usage: 13.6% (used 33.88 of 249.64 MB)
     WAN : ##.##.##.##/22 @ ##:##:##:##:##:##
     LAN : @ DHCP: -
     WL0 : I czego tu?! @ channel: SG8 @ ##:##:##:##:##:##
     WL1 : I czego tu?! @ channel: SG153 @ ##:##:##:##:##:##
    root@Pomidor:/tmp/home/root# cd /cifs1/p2partisan/
    root@Pomidor:/cifs1/p2partisan# ls
    blacklist-custom     list.advertisement   list.edu             list.level1          list.spywere         whitelist
    blacklists           list.dshields        list.firehol_level1  list.level2          p2partisan.sh
    root@Pomidor:/cifs1/p2partisan# ./p2partisan.sh
    +------------------------- P2Partisan --------------------------+
    |                 _______ __               __
    |                |     __|  |_.---.-.----.|  |_
    |                |__     |   _|  _  |   _||   _|
    |                |_______|____|___._|__|  |____|
    +--------- PREPARATION --------
    | Loading the ipset modules
    +---- CUSTOM IP BLACKLIST -----
    | preparing blacklist-custom ...
    | Loading Blacklist_00 data ---> ***Custom IP blacklist***
    +--------- GREYPORTs ----------
    |  TransmissionBT:  Off
    +--------- WHITEPORTs ---------
    | Loading white TCP ports 80,443,3658,8080,5939
    | Loading white UDP ports 1194:1197,53,123,1723,3658,5939,67,68
    +--------- GREY IPs ---------
    | preparing IP greylist ...
    | Loading IP greylist data ---> ***IP greylist***
    +--------- WHITE IPs ---------
    | preparing IP whitelist ...
    | Loading IP whitelist data ---> ***IP Whitelist***
    +------- IP BLACKLISTs -------
    ./p2partisan.sh: line 1892: file: not found
    | Async loading [computed/slow] Blacklist_01 --> ***level1***
    ./p2partisan.sh: line 1892: file: not found
    | Async loading [computed/slow] Blacklist_02 --> ***level2***
    ./p2partisan.sh: line 1892: file: not found
    | Async loading [computed/slow] Blacklist_03 --> ***edu***
    ./p2partisan.sh: line 1892: file: not found
    | Async loading [computed/slow] Blacklist_04 --> ***spywere***
    ./p2partisan.sh: line 1892: file: not found
    | Async loading [computed/slow] Blacklist_05 --> ***advertisement***
    ./p2partisan.sh: line 1892: file: not found
    | Async loading [computed/slow] Blacklist_06 --> ***dshields***
    ./p2partisan.sh: line 1892: file: not found
    | Async loading [computed/slow] Blacklist_07 --> ***firehol_level1***
    | P2PARTISAN: ... P2Partisan started
    +------------------------- Controls ----------------------------+
    | P2PARTISAN: log-async found under dnsmasq -> OK
    +------------------------- P2Partisan --------------------------+
    |                _______         __
    |               |_     _|.--.--.|  |_.-----.----.
    |                 |   |  |  |  ||   _|  _  |   _|
    |                 |___|  |_____||____|_____|__|
    +-------------------------- Scheduler --------------------------+
    | P2PARTISAN: P2Partisan tutor is ON
    root@Pomidor:/cifs1/p2partisan# ./p2partisan.sh tutor
    | P2PARTISAN: P2Partisan found the list level1 empty. Forcing ipset population
    +------------------------- P2Partisan --------------------------+
    |  _____   __         __                         __         __
    | |     |_|__|.-----.|  |_ ______.--.--.-----.--|  |.---.-.|  |_.-----.
    | |       |  ||__ --||   _|______|  |  |  _  |  _  ||  _  ||   _|  -__|
    | |_______|__||_____||____|      |_____|   __|_____||___._||____|_____|
    |                                     |__|
    |            background updating list: level1
    ./p2partisan.sh: line 1890: file: not found
    +------------------------- P2Partisan --------------------------+
    |                _______         __
    |               |_     _|.--.--.|  |_.-----.----.
    |                 |   |  |  |  ||   _|  _  |   _|
    |                 |___|  |_____||____|_____|__|
    | P2Partisan up and running. The tutor is happy
    root@Pomidor:/cifs1/p2partisan# ./p2partisan.sh status
    +------------------------- P2Partisan --------------------------+
    |            _______ __          __
    |           |     __|  |_.---.-.|  |_.--.--.-----.
    |           |__     |   _|  _  ||   _|  |  |__ --|
    |           |_______|____|___._||____|_____|_____|
    | Release version:  v6.10 (13/07/2017)
    |         Running:  Yes
    |         Autorun:  Yes
    |           Tutor:  Yes / 0 problems in the last 24h
    |        Debugger:  Off
    | Partisan uptime:  0d - 00:00:45
    |    Startup time:   seconds
    |      Dropped in:  0
    |    Rejected out:  0
    |       Black IPs:  0
    |        Grey IPs:  0
    |       White IPs:  2 / 2 LAN IP ref defined
    |  TransmissionBT:  Off
    | White ports TCP:  80,443,3658,8080,5939
    | White ports UDP:  1194:1197,53,123,1723,3658,5939,67,68
    |    Blacklist_01:  [e] [e] [e] [o] -    8 KB - level1
    |    Blacklist_02:  [e] [e] [e] [o] -    8 KB - level2
    |    Blacklist_03:  [e] [e] [e] [o] -    8 KB - edu
    |    Blacklist_04:  [e] [e] [e] [o] -    8 KB - spywere
    |    Blacklist_05:  [e] [e] [e] [o] -    8 KB - advertisement
    |    Blacklist_06:  [e] [e] [e] [o] -    8 KB - dshields
    |    Blacklist_07:  [e] [e] [e] [o] -    8 KB - firehol_level1
    |                    ^   ^   ^   ^
    |      maxload: 2 - pri sec cid ipt - [e]mpty [l]oading l[o]aded [p]artial [q]ueued
    |    Consumed RAM:  116 KB
    +----------------------- Logs max(1/hour) ----------------------+
    | Jul 13 12:27:51 I=vlan2 O=br0 S= D= UDP S=12773 D=46882
    | Jul 13 12:23:12 I=br0 O=vlan2 S= D= UDP S=46882 D=6881

    Nevermind, that was an old version of deaggregate.sh file. I deleted /tmp/deaggregate.sh file and run p2partisan.sh update.
    But still, blacklists are loaded, but size each of it is 8 KB and every cidr file contains "add {list name}"
    Last edited: Jul 13, 2017
  22. rs232

    rs232 Network Guru Member

    That shouldn't happen. Is this an upgrade or a fresh installation you did?
  23. sszpila

    sszpila Reformed Router Member

    First upgrade, second fresh install. And still p2partisan reports blocklists size 8 KB after p2partisan update and p2partisan tutor.
  24. rs232

    rs232 Network Guru Member

    hum, can you try to remove "/tmp/deaggregate.sh"
    If you still experience the issue it might be a bug.

    BTW in your post above it complaines about a file: not found I'm wondering where's that coming from as it works fine here.
  25. sszpila

    sszpila Reformed Router Member

    Yes, I removed one more time this file. The "file not found" disappeared, but blacklist's cidr files contains only one line : "add list name"

    Wysłane z mojego 2014811 przy użyciu Tapatalka
  26. rs232

    rs232 Network Guru Member

    Ok let me take the safe approach here.

    I'll revert the publich back to 6.08 and publish this version under the beta (so available under upgrade-beta) until this is resolved.

    Thanks for the feedback!
  27. Bird333

    Bird333 Network Guru Member

    I'm not sure based on your description. Is there some kind of error message displayed on the status page if a list didn't download or if a rule didn't get created for a list? Just curious, did you figure out your vpn issue?
  28. rs232

    rs232 Network Guru Member


    I've rolled everything back to v6.08 and modified that version. The latest stable is now v6.09 which has the following modification only:

    - introduced control to skip list update when the URL becomes unavailable or it simply doesn't exists (thanks @Bird333 )

    I'll see when I can track the bug in the new list types later on. I bet it's nothing serious but need time to troubleshoot.
    No news on the VPN side and I will need some help to fully understand what's going on. Just waiting for some expert to get involved...
  29. sszpila

    sszpila Reformed Router Member

    Everything works fine with this version except one thing. I must comment firehol_level1 blacklist, because with this list enabled the level1 blocklist displays red "e" in ipt column on status display.

    Wysłane z mojego 2014811 przy użyciu Tapatalka
  30. rs232

    rs232 Network Guru Member

    Correct that's because the new blacklist still has references to raw and netset which are not supported on 6.09. As mentioned in the above post of mine I will reintroduce shortly, for the time being comment out any list that is not from the iblocklist provider
  31. jimford

    jimford Reformed Router Member

    Very satisfying to install this script - thanks for providing it 'rs232'.

    I installed it on a USB stick on an Asus rt-16, running Shibby Tomato 1.28.0000 MIPSR2-132 K26 USB AIO.

    The installation proceeded without errors and <sh p2partisan.sh status> showed that it was running.

    A question:
    If I run <p2partisan detective>, I get:
    After an investigation it appears that the following socket/s
    should be considered a greyports candidates. Consider adding the
    ports under greyports_tcp & greyports_udp.
    | 51413 - 189 Sessions
    | 53 - 134 Sessions

    I've tried creating to above files with the port numbers, but I still get the same result

    What exactly is meant by 'greyports'? (The 51413 one is the transmission port on my NAS.)

    Thanks again for the script.

  32. rs232

    rs232 Network Guru Member

    Remember P2Partisan was originally creatd to filter P2Pactivities so a torrent client per se, to avoid communicating with unwanted IPs (read monitoring devices/bots)

    The additional filtering capabilities came later.

    So let's say you have a whiteport "80" because you don't want P2Partisan to interfer with you normal browsing activity, if a remote torrent client decides to talk on port 80 P2Partisan would be bypassed because the whiteport implication.

    As you can see in the original post there's a simple flowchart that tells you what has precedence on what.

    Greyport is just above whiteport so if you specify your torrent port in the greyport any communication from e.g. 80<->your torrent port will be P2Partisan monitored/filtered

    greyport and whiteports are not defined in any file but rather on top of the P2Partisan script itself within the configuration area.

    Now going back to your detective question (still a beta function btw) the output tells you what devices have a large number of connections opened on the very same port. The second record only tells me you have lots of DNS queries toward tomato which is normal and you should ignore, but the first one I would investigate.
    According to this page https://www.adminsub.net/tcp-udp-port-finder/51413
    I suspect you either run a torrent sort of client on that port or rather your NAS has an itune style software running. If neither is the case chances are that your NAS is doing something else in Internet you probably are not aware/happy about it.

    As a parallel activity check if the NAS managed to upnp a port on tomato, if so (my opinion) you should prevent tomato's upnp from accepting port mapping requests from your NAS unless there's a very valid reason for it.
    On this topic check this out: https://www.linksysinfo.org/index.php?threads/miniupnpd-custom-config-syntax.70863/

  33. jimford

    jimford Reformed Router Member

    Thanks for the reply - I'm going to need to spend some time to digest it!

    ( I printed out the thread, so I could read it away from the computer. Unfortunately the flowchart printed as a thumbnail, so I missed it!)

  34. jimford

    jimford Reformed Router Member

    In the configuration part of the script, the example given for greyports states: "greyports=22008,6789", yet detective mentions "greyports_tcp" and "greyports_udp". If I put 53 (my DNS port) and 51413 (my Transmission torrent client port) in lines with or without the tcp and udp, I still get the message "Consider adding the
    ports under greyports_tcp & greyports_udp." from detective. Which is correct - greyports or greyports_tcp and greyports_udp?

    Also, I've tried blocking periscope.tv (also pscp.tv) into blacklist-custom, but can still access the app on a tablet. Not sure what is going on here!

  35. rs232

    rs232 Network Guru Member

    Yes greyports is a generic term, the config understand the optional variables greyports_tcp/greyports_udp.
    Detective has no understanding of the current P2Partisan config it's like a standalone tool doing som sort of investigation when called. Having the ports added to white/greyports will not affect the detective output.
    Transmission running on the router itself is automatically added to the greyports (hardcoded) as it uses many more ports (look for the transmission modification back few pages ago on this thread)
    Most likely you want port 53 udp to be whitelisted (as per default config) and not greylisted.

    About Periscope, I suggest you give it a go with the P2Partisan debugger to see what traffic periscope is actually generating (domain/IPs ,etc). I'm intrested myself to hear about your findings.
    Last edited: Jul 31, 2017
  36. jimford

    jimford Reformed Router Member

    As I mentioned, I have a tablet, with the only connection being through my router. I've installed 'Periscope' on it in order to test blocking.
    I ran p2partisan debug while Periscope was running on the tablet, but the only debug activity I could see was typically:
    Aug 1 11:57:43 I=br0 O=vlan2 S= D= TCP S=60581 D=443
    Aug 1 11:57:43 I=br0 O=vlan2 S= D= TCP S=42043 D=443

    The two IP above appear to be connected with Amazon Cloud Hosting - which I don't use!

    Still baffled!
  37. rs232

    rs232 Network Guru Member

    We're getting there don't worry. I might have mislead you slightly. Let me explain:
    Debug as it was designed allows you to get full logging for all the drops/rejection (by default only very few drops are logged not to flood the syslog, e.g. 1/hour). With this in mind all debug does is to remove the limitation for the given IP. What debug is not doing though is to tell you what actually was allowed through the router. Debug was designed to understand what/why the communication dind't happen where you're looking for the opposite.

    I have an idea though, never tested before but on paper it should work.

    Try the following:
    - add in your blacklist-custom (this will block any Internet traffic)
    - ./p2partisan.sh restart
    - enable debugging for the tablet IP
    - open perhiscope on the tablet

    at this point debugging can be stopped (./p2partisan.sh debug off) as the periscope attempt to establish a communication has been prevented and fully logged.

    NOTE: do not disconnect your SSH session! if this happen you would have to remove the USB and power cycle to prevent p2partisan from running

    Once you have the naughty IPs identified:
    - Remove from balckist-custom
    - add the periscope IPs to the blacklist-custom
    - ./p2partisan.sh restart

    At this point the Periscope traffick should be prevented.

    Final thought, debugging will tell you the IP but if the APP points to FQDNs (very likely) the DNS binding to the target IPs might be modified in the future and the block suddely not performing any more. To prevent this unwanted situation you can try to reverse lookup IPs into FQDN (sometime a google serarch helps too) or if you have time and are feeling adventurous you might want to try some sort of packet sniffing on your tablet directly to capture the DNS query called by Periscope.
    Last edited: Aug 1, 2017
  38. jimford

    jimford Reformed Router Member

    Thanks for the reply.

    I won't be at the computer for a few days, before I can give it a try.

  39. jimford

    jimford Reformed Router Member

    I think it was more that I didn't understand, rather than you misleading me!

    At this point p2partisan hung and I needed to do a Ctrl C to get back to the prompt. It would also hang if instead of a 'debug' command I did 'status'. From this situation, whilst I was back to the command prompt, I couldn't restart p2partisan with a ./p2partisan.sh command. I needed to reboot the router from the web interface.

    I've been wondering about the above. I'm guessing that the FQDNs would be of the form 'fred.periscope.tv', 'mary.periscope.tv' etc.. If this is so, and the blacklist-custom used regular expressions, then simply 'periscope.tv' should block them all, but as this doesn't work, I'm guessing that the blacklist-custom file doesn't use regular expressions.

    Not sure where to go from here!

  40. rs232

    rs232 Network Guru Member

    Ok no problem, as mentioned the solution proposed was untested. I believe it hangs due to the amount of logging involved. Can you confirm you had shutdown/disconnected any other network device?
    If not I would give it a go again with only the tablet connected (no other app running) .

    If you did try alrady with tablet only generating traffic we need a different approach which involves some sort of packet sniffing. you must stop p2partisan while you run the below 2 steps:

    A) Identify FQDNs used by Periscope (if any)

    0- make sure your client uses tomato as DNS server
    1- stop p2partisan
    2- Add this to the Advanced/DHCP/DNS page
    3- save
    4- try using periscope
    5- check the syslog, you should find here all the DNS resolution requests. You'll haveto work out the unwanted FQDNs skimming through the syslog. All the finding will have eventually to go into the blacklist-custom of P2Partisan, but not until B) is completed. So keep p2partisan off for now.

    B) IP communication

    This is in regard the bottom part of my prev message. Periscope might use domain names only, a mixture of domains and IPs or IPs only. I really don't know. A) allows you to identify any DNS resolution involvement. To identify potential direct IP communication you'll need to do some packet sniffing on tomato itself. you have 2 options
    x- (easier?) get hold of a working tcpdump which you can run directly via ssh, with the correct parameters to e.g. filter yor tablet IP as a source only IP only e.g. tcpdump 'src and (dst port 80 or 443)'
    y- you could run rpcapd within tomato and sniff packets remotely via e.g. wireshark on any of your LAN clients

    According to the Periscope twitter support account, tha app uses only port 80 and 443. You might hence filter your sniffing (either ways) by source IP (tablet) and desintation port tcp 80 or 443.

    Any unwanted IP is again to go into the blacklist-custom of P2Partisan.

    I know this might sound a lot of running around but please stay focused and get to the bottom of this, you're not far away at all. :)
  41. calcousin55

    calcousin55 Network Newbie Member

    Just wanted to say thanks for all of your hard work in creating this awesome script. Keep up the good work.
  42. jimford

    jimford Reformed Router Member

    Thanks for the extensive advice 'rs232'. I've not forgotten about it, but been diverted by other problems (setting up a VPN) - so the 'periscope problem' is on the back burner for now.

  43. skupi

    skupi Networkin' Nut Member

    I have problem with p2partisan, try install it again after some time. Iam on tomato-RT-AC68U-ARM--2017.2-kille72, after start, script downloading list, but status "running" nothing show. I add some ip to blacklist-custom to check is it working, but i can still ping added ip, so i think not.

    I install fresh install tomato tomato-RT-AC68U-ARM--2017.3b12-kille72 set all fresh settings install p2partisan and still the same.

    Is p2partisan is compatible with shibby dual wan version and later killer72 fork versions or only with shibby 128 version?

  44. rs232

    rs232 Network Guru Member

    I´m away for a couple of weeks I´ll have a look once back home.
    In the meantime I suggest you go through th troubleshooting part of the OP.
  45. rs232

    rs232 Network Guru Member

    I'm not sure what this is about but I did find regardless an unwanted behaviour introduced by the list checking before download function that was introduced with 6.09.

    Long story short I've rolled back the latest version to 6.08 as it's stable and well tested.

    Try to use the "upgrade" function to install "6.08 24/11/2017"

    Everybody please switch to v6.08 !
  46. jimford

    jimford Reformed Router Member

    When I start or update P2partisan I get the error:

    "wget: can't open 'dshields.gz': Input/output error"

    It looks like dshields.gz is not being downloaded and consequently the above error is followed by:

    "gunzip: dshields.gz: Input/output error"

    Any ideas, pleas?

  47. rs232

    rs232 Network Guru Member

    Can you doublecheck the URL? e.g. If you paste it in the browser does it download?
    As an additional check verify the filesystem permission e.g. P2Partisan needs write permission on the folder and its files.
  48. jimford

    jimford Reformed Router Member

    Yes, I tried that and it downloaded and opened in an archive manager.

    Yes, that appears to be OK, as the other blacklists download and unzip into the p2partisan folder OK.

    Thanks for the reply.

  49. rs232

    rs232 Network Guru Member

    This is my dshields and it works fine:
    dshields http://list.iblocklist.com/?list=xpbqleszmajjesnzddhv&fileformat=p2p&archiveformat=gz

    What version are you running?

    What does the ./p2partisan.sh status dshields output tell you?

    Not sure i will do anything but try to delete the dshields.cidr file
  50. jimford

    jimford Reformed Router Member

    Yes - it's the same as mine, if I download it 'manually.

    v5.14 (21/05/2016)

    wc: /tmp/tutor.temp: No such file or directory

    The really odd thing is that if I do a <ls> in the p2partisan directory, I get "ls: ./dshields.gz: Input/output error"
    The same if I do '<ls -a> to see hidden files. Yet if I do <find . -name 'dshields*'> it returns './dshields.gz'

  51. rs232

    rs232 Network Guru Member

    Apologies I assumed you were running v6 so the command I gave is not working on v5. You are the first person (as far as I remember at least) that experienced this problem. Also v5 hasn't been updated for ages and this is a good input in your scenario. Supposed you've already tried to reboot the router I can only suggest (in order):

    - check the filesystem of the device where P2Partisan is installed
    - try a fresh P2Partisan install
    - if you have you recently upgraded your router without clearing the NVRAM try a fresh tomato install
  52. jimford

    jimford Reformed Router Member

    I'm using Shibby's 1.28.0000 MIPSR2-140 K26 USB AIO-64K on an Asus RT-N66U (clean install).

    I'm always confused at Shibby's release numbers - is the above commonly referred to as 1.28 or 1.40? If it's 1.40 then I ought to update to P2Partisan v6.

    Thanks for the reply.

  53. rs232

    rs232 Network Guru Member

    140 for Shibby, however if you're running MIPS then it would only run P2Partisan v5.x
  54. ravenise

    ravenise New Member Member

    Amazing script!; OMG I didn't notice this at first, its nice to see it automates whitelisting ports! WOW
    Last edited: Jan 18, 2018

Share This Page