1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please Help ! Can't upgrade firmware

Discussion in 'Other Linksys Equipment' started by Jeff7506, Oct 8, 2004.

  1. Jeff7506

    Jeff7506 Network Guru Member

    Hi all,

    I got a wag54g with firmware.
    Ecah time i try to upgrade, after 20 seconds i got a blank page in IE and nothing happen. The website is no more avialable and i have to switch off the modem to get the site back. An of course the firmware stay

    Help are more than welcome.

    Thanks for your time guys
  2. Toxic

    Toxic Administrator Staff Member

    are you sure this is firmware?

    I thought 1.02.5 was the latest.

    make sure that IE is not yusing a proxy cache setting in the options of IE.

    try downloading the new firmware again before upgrading you may have a corrupt file.

    firmware is here. make sure you have the correct firmware version (AnnesA or AnnexB)

  3. Jeff7506

    Jeff7506 Network Guru Member

    Hi toxic,

    You are right my current version is 1.01.6.
    I try 3 different bin files and with 2 different browser (ie and firefox) and the firmware never upgrade. :( :( :(

    is it possible to upgrade using telnet ?
  4. Toxic

    Toxic Administrator Staff Member

    obviously there is some sort of firewall blocking or browser problem with your system.

    try using tftp and the binary file to upload the file to the router



    put both files in the same folder run tftp and then then the Server ip to the WAG54G, select the niary file and enter the password of the router. the click on upgrade.

    is your wag54g playing up and you NEED to upgrade?
  5. Jeff7506

    Jeff7506 Network Guru Member

    Thanks Toxic

    if works fine with tftp, but i syill have my port forwarding issue on 113 vene with the last firmware. what is the difference betwwen Annex a and annex B ?
  6. Toxic

    Toxic Administrator Staff Member

    one is for ISDN the other is not....

    what port forwarding issue do you have?

Share This Page