1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PLEASE HELP MY WRT54GS IS DEAD!.. nvram set sdram_init

Discussion in 'DD-WRT Firmware' started by didan, Nov 24, 2005.

  1. didan

    didan Network Guru Member

    hi all,
    please help me...
    my wrt54gs v1.1 is dead
    power led to blink nonstop..

    i dont ping my router (192.168.1.1)


    my router dead after this settings..

    # nvram set sdram_init=0x0008
    ~ # nvram set sdram_ncdl=0x0000
    ~ # nvram commit
    ~ # reboot

    my older settings

    sdram_ncdl=0xfe0008
    sdram_init=0x010b

    please help me.
     
  2. robmack

    robmack Network Guru Member

  3. __nbd

    __nbd Network Guru Member

  4. 4Access

    4Access Network Guru Member

    Did you try simply holding the reset button for 30 sec to reset to defaults? HyperWRT Guide: RecoverFromABrick (BTW the multiple cross-posts are a bit annoying.)
     
  5. BeHappy

    BeHappy Network Guru Member

    Since you are here I assume you know how to make pins-short according to http://www.linksysinfo.org/modules.php?name=Content&pa=showpage&pid=33. (the guide is good enough, but can't erase nvram values as you want immediately, must use - unplug power; hold reset button down - not 100% "water proof") :cry:

    Here is my methode, it works 100% (have revived my WRT54G after my modding on bad sdram values, experimental firmwares, etc.)

    1. Follow the most part from revived guide (fix IP address, 10Mb half duplex, cmd - ping -t 192.168.1.1 -, pins short). Please read it carefully, these actions isn't for dummies :eek: .
    2. Prepare your media;
    2a. Download WRT54GVxx_US_code.exe according to your model
    2b. Download a tftp.exe to upload your new, useable firmware
    (2a and b from Linksys ftp)
    2c. Download tofu firmware (because small size approx. 3 MB)

    Here is the upload processes
    3. After successfully cmd - ping - then run 2a
    4. After automatically reboot try cmd -ping - again
    5. After successfully cmd - ping - then run 2b + 2c
    6. After automatically reboot try cmd -ping - again
    7. After successfully cmd -ping - then enter GUI/web on WRT54G
    8. Activate telnet from Administration site
    9. Open telnet consol then make
    9a. erase nvram
    9b. reboot
    (9a and 9b to clear all your "bad" initial values)
    10. You're done. End of your successfully reviving proces :drinking: .
     
  6. didan

    didan Network Guru Member

    :(( ...
    i make jtag cable for wrt54gs 1.1
    but dont work..

    ====================================
    WRT54G EJTAG DeBrick Utility v2.2
    ====================================
    Reading the configuration file.

    =======================================
    Using the pin configuration:
    TCK = 1
    TMS = 2
    TDI = 0
    TDO = 4
    Invert TDO = FALSE
    =======================================

    Probing bus...
    CHIP ID: 00010100011100010010000101111111 (1471217F)
    *** Found a Broadcom BCM4712 Rev 1 chip ***

    and i try shortpin method .. but useless .
     
  7. BeHappy

    BeHappy Network Guru Member

    You wrote
    ... and i try shortpin method .. but useless

    It means you never get an useable result from cmd - ping -?
     
  8. cgondo

    cgondo Network Guru Member

    why did you say jtag did not work? what happen after it found the chip ID?

    I reckon it finding the Chip ID a one step closer...
     
  9. didan

    didan Network Guru Member

    i use wrtjtag (for windows or for dos..)
    cfe.bin download from web .. for wrt54gs 1.1
    from http://lonewolf.hacker-nin.com/wrt/cfe/

    Probing bus...
    CHIP ID: 00010100011100010010000101111111 (1471217F)
    *** Found a Broadcom BCM4712 Rev 1 chip ***
    Issuing Processor / Peripheral Reset...
    Done

    Issuing JTAGBRK / Hammering Watchdog Off (80 iterations)...
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    Done
    Probing Flash...
    FLASH VENDOR ID: 00000000000000000000000010001001 (00000089)
    FLASH DEVICE ID: 00000000000000000000000000010111 (00000017)
    *** FOUND FLASH CHIP: Intel 28F640J3 4Mx16 ***

    found flash chip ..

    i try erase commands.. erase kernel nvram wholeflash cfe...
    and re flashing but my router is more dead..

    Pinging 192.168.1.1 with 32 bytes of data:

    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    ......
    .....
    ...
    :(((
     

Share This Page