1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please help, stuck with WAG54G

Discussion in 'Other Linksys Equipment' started by Anonymous, Nov 11, 2005.

  1. Anonymous

    Anonymous Guest

    I am trying to configure WAG54G as a normal switch / access point (not use dsl link) plus DHCP server, because my network gateway is another router on the LAN side.

    I want DHCP clients to use another router (in LAN) as the default gateway. But the WAG54G always point DHCP client's default gateway to itself. How can I change that?

    So I tried another method, adding static routes. If the unit allows me to define default route, I would be able to point it to my network gateway. Unfortunately, I could not configure default route.

    My WAG54G has firmware version 1.00.19
     
  2. 7ttman

    7ttman Network Guru Member

    First I would suggest that you update the firmware.... there are several versions of WAG54Gs and I've been using them since they first came into the country (that means I'm not using the latest V2 versions... so my comments may not be applicable).

    You should login into the administration screen ... and you'll see a setting towards the bottom of the screen DHCP enabled, disable or DHCP relay.

    Set it to DHCP relay and then set the IP address of the DHCP server on your LAN.

    The other thing to watch is the IP address of the WAG54G. It should really be in your subnet of your LAN, so you can fiddle around with your subnet mask should you find yourself in different subnets. But I'd recommend trying to stick everything into the same subnet. And make sure you don't have two or more device setup with the same IP address because things just won't work.
     
  3. Anonymous

    Anonymous Guest

    Thank you for your quick answer.

    But I don't have any other DHCP server, and I also use WAG54G that act as DHCP server.

    My real problem is that my router gateway is in LAN side (opposite to DSL interface), and I can't add default route to point to router gateway in LAN side.

    Are there any methods to solve this??
     

Share This Page