1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Port 20 blocked by ISP ?!

Discussion in 'Tomato Firmware' started by ulyan, Jun 25, 2012.

  1. ulyan

    ulyan Networkin' Nut Member

    Hi again.

    I am trying to open port 20 for my ftp connection. I see that tomato opens port 21 by default when we enable the checkbox. Anyway I don't know if my ISP is blocking this port or not. When I add this iptable input :
    iptables -I INPUT -p tcp --dport 20 -j ACCEPT
    https://www.grc.com/port_21.htm shows my port closed. If I remove that input the port changes its state to stealth.

    I have a pppoe adsl connection. Thank you.
  2. shibby20

    shibby20 Network Guru Member

    no need to open port 20 for FTP working in active mode.
  3. ulyan

    ulyan Networkin' Nut Member

    Ok, thanks. But does this behaviour means my ISP blocks it ? :rolleyes:
  4. shibby20

    shibby20 Network Guru Member

    not. FTP doesn`t listen on port 20 :) This is why port 20 is closed.
  5. zong

    zong Serious Server Member

    I have internal FTP running (on usb stick) with standard Port 21. However want to shift this to 5x21 to hide a bit.
    1) I tried to change in FTP settings to 5x21 - but no longer was available from outside LAN (WAN)
    tried also a PORT FORWARD from 5x21 (ext) to 5x21 (internal) on
    2) I let this on 21 on FTP settings but on top did a PORT forward to 5x21 (ext) to 21 (internal).
    This works -however have now 2 PORTS open (5x21 and 21)

    so how to close the 21 from outside LAN (WAN)
    or better how to config this internal FTP server right to run on 5x21 ???

Share This Page