1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ppp-compress-18 for PopTop

Discussion in 'Tomato Firmware' started by i1135t, Jun 10, 2010.

  1. i1135t

    i1135t Network Guru Member

    Hey all, I was wondering if anyone had a compiled kernel module for tomato called "ppp-compress-18"? I installed poptop through ipkg and it needs this module to function properly according to the documentation. Any help would be appreciated. Thanks!
     
  2. i1135t

    i1135t Network Guru Member

    Okay, sorry to bring up an old thread, but I am still struggling to get pptpd, "poptop" working natively on tomato. I have managed to get it installed through IPKG package and configured properly. However, for some reason, tomato is missing the encryption module for the kernel. I tested the connection without encryption and it works great, but when I enable it through the settings, it give me an error 714: The local computer does not support the required data encryption type. I have set pptpd to "128-required" and only accept MS-Chap V2, but it will not fully establish a connection when encryption is enabled. I am using TB_v1.128.51_USB_VPN build. Reading the changelog, I assumed that since WAN PPTP was supported, the modules would be present?

    I have no problems with OpenVPN, but would like to have PPTP VPN available for instances when I need to VPN quickly through a Windows machine without having to install OpenVPN. If I can get this encryption module somehow, it would help not just me, but many other users as well.
     

Share This Page