1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PPPoE ramdom disconnects - Tomato Log inside

Discussion in 'Tomato Firmware' started by Nox997, Mar 29, 2008.

  1. Nox997

    Nox997 LI Guru Member

    Hello!

    Since a few weeks, I got the problem of seldom random disconnects with my PPPoE ADSL-Connection.

    The Modem is a T-Com Teledat 302 LAN, the Router is a WRT54GL 1.1 with Tomato Mod 1.16, the 24h-reconnect is set.

    here is the Log of a occuring reconnect:

    Is it possible that the modem is the problem? If i remember correctly, with a different modem (a WLAN-Router set to modem functionality only) worked quite well.


    Thx in advance for any help!


    Cya,
    Nox
     
  2. Larix

    Larix LI Guru Member

    When the internet connection is lost, is the power led flashing?

    Wenn die Internet Verbindung verloren geht, blinkt dann die Power LED?
     
  3. Nox997

    Nox997 LI Guru Member

    I don't know - The Router is located at my neighbour's house ;-)

    I thought the router cannot be the problem, as the log file says it "receives" a termination request
     
  4. der_Kief

    der_Kief Super Moderator Staff Member Member

    Hi,

    i had the same problem for the last few weeks! After a lot of testing and having contact with my ISP it turn out that the problem was my ISP ! They not only disconnect after 24h the also disconnect after 15min of inactivity ! So maybe you should ask your ISP

    der_Kief
     
  5. LLigetfa

    LLigetfa LI Guru Member

    Exactly. ISP is booting you.
     
  6. Nox997

    Nox997 LI Guru Member

    lol

    so I could just add a cron-ping-job at www.google.com and the problem might be gone?
     
  7. LLigetfa

    LLigetfa LI Guru Member

    Maybe, if it only happens when the link is idle. I once had an ISP that booted me on a regular cycle, even if I was using it. I could set my watch to it. They sometimes do it to combat P2P. Every time they boot you the sessions die and when the link comes back up you get a different IP. They also do it to free up IPs for their DHCP pool.
     
  8. der_Kief

    der_Kief Super Moderator Staff Member Member

    Hi,

    in my case that worked ! I scheduled a cron job which pings a adress every 15min (thats the ISP timeout for inactivity). Since i do that i only have the 24h disconnects. FYI my ISP is german ARCOR.

    der_Kief
     
  9. polilla

    polilla LI Guru Member

    I have same "problem" here like your log shows. After changing to ADSL2+. ISP is german T-Online.
    They said 24-hours without disconnect, ok, but they make disconnects from time to time. I don't know why and they make it randomly. Changed modem and yes changed router with a 10MBit WAN-side for my 16MBit-connection and have had same problem.
    So the Linksys-Router and Tomato are ok.
    Only wondering that i cannot read something about that in forums here in Germany. How it shows do other ISP same things like der_Kief tell us.

    Greets, polilla.
     
  10. der_Kief

    der_Kief Super Moderator Staff Member Member

    Hi,

    for all the germans here the following site could be interesting -> http://forum.mhilfe.de/
    There are some people with the problem discussed here.

    der_Kief
     
  11. polilla

    polilla LI Guru Member

    Thanks der_Kief for the link.

    Now i send a ping every 15 minutes from my router like you.

    cru a ping "0,15,30,45 * * * * ping -c 1 -q www.google.com"

    And i have no more disconnects from ISP, only after 24h.

    Greets, polilla.
     
  12. der_Kief

    der_Kief Super Moderator Staff Member Member

    no problem at all :)

    you can also do a:

    cru a ping "*/15 * * * * ping -c 1 -q www.google.com"

    der_Kief
     
  13. LLigetfa

    LLigetfa LI Guru Member

    I wonder if setting your NTP to update every hour would achieve the same result or do you need 15 minute intervals?
     
  14. polilla

    polilla LI Guru Member

    Hello LLigetfa,

    der_Kief wrotes that they disconnect him every 15 minutes so NTP min. 1h dont help us in this problem here.
    The idea that Jon makes it possible to send a ping in the next version of tomato is by my side.

    Greets. polilla.
     
  15. edgecrusher666

    edgecrusher666 LI Guru Member

    Thanx,


    i inserted a ping in my crontab
    cru a ping "*/15 * * * * ping -c 1 -q www.google.de"

    i don't know why, but my disconnects are now gone.
    my isp is congster(Congstar) in germany, it looks like they disconnect randomly, when i'm
    idle.

    who cares now every thing works fine for me.

    cu
    edgecrusher
     
  16. polilla

    polilla LI Guru Member

    Hallo edgecrusher,

    now we have disconnects here in Germany by the providers when we are idle.
    At Arcor, der_Kief said every 15 minutes, T-Online my experience and their daughter Congster your experience disconnect randomly.

    >i inserted a ping in my crontab

    In the actual version of Tomato you can do this under Administration->Scheduler

    Greets.
     
  17. Low-WRT

    Low-WRT LI Guru Member

    Like this?
    BTW-I realize it shouldn't be set to every minute:)
    Untitled.jpg
     

Share This Page