1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PPPoE won't connect, unless I erase NVRAM

Discussion in 'Tomato Firmware' started by Germanninja, Sep 3, 2014.

  1. Germanninja

    Germanninja Network Newbie Member

    Hey guys, I've googled enough and found nothing relevant.

    I've had this problem with WRT54GL (tomato 1.28) and with Asus RT-N10P (Shibby MIPSR2-117 K26).

    Both routers were previously able to connect to a Huawei HG-530 (in bridge mode of course) through PPPoE just fine. I only use one router (the Asus replaced the Linksys).

    Both the Linksys and Asus have worked for over 4 years straight (Asus last 4 months). Yesterday I was not able to connect to the internet. I restarted both modem and router, no luck.

    The modem always connects when I factory restore it (as a modem router, not in bridge) but if I put it in bridge mode, the router (none of both, I still own them) can connect.

    The ONLY way I can connect via PPPoE is by erasing NVRAM and only loading PPPoE settings (with custom DNS servers) and it connects almost instantly.

    If I load any backup .cfg (my custom QoS settings for example) it WON'T WORK, none of both routers running on different Tomato builds.

    Am I crazy????????????? I don't know what's wrong!
  2. Siff

    Siff Reformed Router Member

    Assuming that you haven't changed anything - did your ISP made some changes on their side?
  3. Germanninja

    Germanninja Network Newbie Member

    I can't say, plus if i was to call them they wouldnt know/say. Their troubleshooting always is "how many lights are lighted on on your modem?" Thats like 99% if it.

    Also, the routers do connect via pppoe as long as I erase nvram. Why would my perfectly fine .cfg files stop working?

    Thx for replying :)
  4. Siff

    Siff Reformed Router Member

    Have you upgraded the firmware on the routers? If you have, you shouldn't be using a saved .cfg file after the upgrade.
  5. Germanninja

    Germanninja Network Newbie Member

    Nope, nothing was changed. And the odd thing is that i have vainilla 1.28 on WRT54GL and 1.28 shibby on the asus one, both have the same problem. Also, the modem was never flashed either.

    I really miss my custom QoS rules and would hate to change them and then having the router not connect again :(.
  6. Siff

    Siff Reformed Router Member

    Are you sure it is because of the QoS rules? Have you tried to make the settings one by one and find out which one causes the problem? I know that it is a lot of work, so you can try some of the methods described here and here.
  7. Monk E. Boy

    Monk E. Boy Network Guru Member

    When you restore the configuration file, you are basically restoring all your NVRAM settings. If one of those NVRAM settings is causing your problem, then restoring the configuration is going to bring you back to square one.

    There is a way to perform an NVRAM dump and then selectively restore lines from it, which is how some people restore QoS rules (not to mention other settings) without having to walk through the website and recreate them.

    The script I use to dump settings is:
    nvram export --set >config.txt
    Which exports the contents of your nvram to a file called config.txt in the current directory. If you stick config.txt in /jffs/ it should be able to survive a long nvram wipe (though probably not a firmware upgrade). You'll need to flip jffs support back on after the reset, obviously, otherwise /jffs/ won't exist.

    What you do after a factory reset is go through config.txt looking for settings you want to restore. This typically is accomplished using grep and a string you're looking for.

    My google searching powers are apparently not working today, I can't find the thread on this site that describes exactly how to do this...
    Last edited: Sep 4, 2014

Share This Page