1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PPTP client failing v23 SP2

Discussion in 'DD-WRT Firmware' started by g18c, Jun 28, 2007.

  1. g18c

    g18c LI Guru Member

    I am trying to set a default route to run all my traffic through the vpn with DD-WRT v23 SP2. The route is bought up ok (the pptp clients details are entered via the web admin page). After rebooting the ppp0 link comes up without problem and is listed in the routing table ppp0.

    ~ # route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    10.19.0.190 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 br0
    10.19.0.0 0.0.0.0 255.255.255.0 U 0 0 0 ppp0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 br0

    I then add a route to the pptp server in anticipation of setting the default route to the ppp0 interface.

    ~ # route add -host 200.200.100.100 dev br0
    ~ # route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    10.19.0.190 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
    200.200.100.100 0.0.0.0 255.255.255.255 UH 0 0 0 br0
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 br0
    10.19.0.0 0.0.0.0 255.255.255.0 U 0 0 0 ppp0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 br0

    All is well, until i go and remove the default route br0. For some reason as soon as i do this the ppp0 interface dies, even though i have the host route to the server entered above.

    ~ # route del default br0
    ~ # route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    200.200.100.100 0.0.0.0 255.255.255.255 UH 0 0 0 br0
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 br0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

    Can anyone kindly tell me if this is a problem i am creating or if this is a bug? I have tried the latest v24 beta build (20/06/07)but that doesnt even list the ppp0 interface under ifconfig (even though running pptp from the shell i can see the link coming up).

    Thanks
     
  2. g18c

    g18c LI Guru Member

    i found the issue to be the latest 20/06 firmware, using 14/06 fixed this.

    thnx
     

Share This Page