1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PPTP Routing Issue

Discussion in 'DD-WRT Firmware' started by bisk, Oct 9, 2008.

  1. bisk

    bisk Network Guru Member

    I'm having an issue with the PPTP network that I've setup. Everything appears to be working except that I can't ping the devices that are behind the PPTP Client DD-WRT router. I am able to ping the IP Address of PPTP Client Router ( from Desktop1, Desktop2 and XP VM. From Remote1 I can pint Desktop1 and Desktop2, as well as the PPTP IP of XP VM (, but not the internal IP (; which isn't a huge deal. Also, I've found that I can't ping using the host names of remote devices, how can I get this working? I've read though so many different how to's and forum threads, that I"m not even sure where to look now...I've been trying to get this working since Saturday.

    Thanks in advance for the help!

    Attached Files:

  2. deursen

    deursen Addicted to LI Member

    enable ip_forward
  3. bisk

    bisk Network Guru Member

    How do I do that?

    Here's what I have in the Firewall startup script now. It works, but if there's something a little more dynamic, I'd rather use that.


    echo "if [ $CLIENTIP == \$6 ]; then" >> /tmp/pptpd/ip-up
    echo " /usr/sbin/ip route add $CLIENTNETWORK dev \$1" >> /tmp/pptpd/ip-up
    echo "fi" >> /tmp/pptpd/ip-up

    echo "if [ $CLIENTIP == \$6 ]; then" >> /tmp/pptpd/ip-down
    echo " /usr/sbin/ip route delete $CLIENTNETWORK dev \$1" >> /tmp/pptpd/ip-down
    echo "fi" >> /tmp/pptpd/ip-down

Share This Page