1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

prefinal 5 will not work on MOST wrt54g V2

Discussion in 'DD-WRT Firmware' started by dellsweig, May 26, 2005.

  1. dellsweig

    dellsweig Network Guru Member

    This is a repeat post but important enough to start its own thread (my opinion)

    I could NOT get the latest build to work on a V2 WRT54G

    I flashed from the May 18 build, the reouter went into a reboot loop - it would come up, then all lighs flash, then reboot. I finally got Stock Linky firmware on it but could not flash back ANYTHING - not the May 18 build, not Alchemy. I could only flash stock Linky and hyper. I gave up on my WRT54G V2.

    It works FINE on a 2.2 and 3.0 54G

    Could there be a nvram clear neeed??

    Any ideas?? I have V2 we can experiment with now!!!!

    BTW: The serial number on the WRT54G indicates it is a 2.0

    CDF5xxxxxx = WRT54G v2.0 = ADM6996L Chip
     
  2. zgamer

    zgamer Network Guru Member

    Have you tried the May 24 build? I didn't have much luck with the build from the 18th
     
  3. dellsweig

    dellsweig Network Guru Member

    I was running the May 18 build with no problem on the V2 router. I flashed it up to the May 24 and that was the end of it.

    I was able to get the Stock Linksys firmware back on the router but even the May 18 build, which WAS working on the router, would not come up.

    I suspect there is an nvram value which needs to be cleared out....
     
  4. jagboy

    jagboy Network Guru Member

    i have had no luck with flashing with dd-wrt pre 5 at all. i had no good flashes that last long enough with out problems
     
  5. dellsweig

    dellsweig Network Guru Member

    As I said in my post. I had NO PROBLEM flashing the May 24 pre5 build into both my 3.0 and 2.2 versions of the WRT54G. Both were running the May 18 build of pre5.

    The only problem I have had is flashing the V2 54G. It was also running pre5 May 18. After the failed flash, I was able to restore it to stock Linksys firmware but cannot even flash older DDWRT versions into it where the older versions were previously running. There is something in the May 24 pre5 build that is leaving something in nvram cauing these problems on the V2 only

    EDIT:

    I got an answer from Brainslayer that suprised the crap out of me... He said let it reboot - that is normal..., Well I let it in this re-boot state for an hour while I went out and bought a new WRT54G V3, it did not settle down and come up. It is stuck in a re-boot loop. I re-flashed stock firmware into the V2, it comes up fine. I re-flash hyperwrt into the V2 - it is fine. I put DD_WRT (May 18, May 24) it will not come up. This router (V2) was previously running the may 18 Pre5 build. There are no 'extras' configured, plain vanilla setup.

    Brainslayer needs to address this issue. Many are reporting this SAME problem with V2 routers. At issue is his credibility as a developer. If he gives good answers to problems, folks will continue to respect him. If he gives half baked answers like "let it reboot a while - it will settle down", the respect for DDWRT will diminish.

    Lets find this problem - remember, bad news (V2 bricks) travels fast!!
     
  6. gotamd

    gotamd Network Guru Member

    Don't be so hard on him. This is really a beta firmware and there are no claims made about its stability. You can't even get it off the dd-wrt.com site. If it was a "final" release it'd be different.
     
  7. XCOM7

    XCOM7 Network Guru Member

    I just understand what part most people dont understand from "Internal leak Use at your OWN RISK" I flash to pre5 05/05/22 and it worked fine besides some small problems and mem leaks so I switch back to pre4 and everything ok.. I made some post addressing the bug and dun.... No nead to rase hell and make out of the way comments like "Respect" Reboot issue is true when I flash to pre5 my GS rebooted 3 times in a period of about 2 min each before it seattle down I was starting to think I bricked my router but than it seattle down it didnt end there I rebooted the router and the same thing happen after that the reboots where normal reboots no more waiting...

    Bad or Good, Broken or Fix my props go to Brain Slayer for taking the time in hes life and provide us with a grate firmware for FREE.
     
  8. jagboy

    jagboy Network Guru Member

    say what you want about brainslyer but he is a good progamer. i dont think that anyone will lose repect for him and his firmware. as it si said a million times in this forum this is a internal leak. if you dont like it or it is giving you problems go with pre 4. like i did.
     
  9. u3gyxap

    u3gyxap Network Guru Member

    Don't bite the hand that feeds you :)
    BrainSlayer is a capable person. He knows about the problem and he will address it. There is no need of getting electricity in the air - it is pointless and helpless. And, most of all, will not help any developer in being "user friendly" ;)
    If you want support - pay $20 to $vea$oft, they will provide it :lol:

    Keep in mind - it is NOT a final release, it is not even a Release Candidate. You USE IT AT YOUR OWN RISK
     
  10. dellsweig

    dellsweig Network Guru Member

    No problem here - I have been using "At You OWn Risk" firmware for some time.. No blmaes, no electricity...

    I just want to know how to un-do whatever pre5 May 24 did to my V2 router..

    Since the failed upgrade, the ONLY firmwares I can load onto it are the Stock Linksys and the HyperWRT 2.1. I cannot load ANY of the DDWRT released 2.1 or 2.2, I cannot load any of the Alchemy releases. I have not tried Satory.

    Apparently, the DDWRT Pre5 load set a NVRAM value to something MOST other firmwares cannot deal with. I need to clear this out so I can at least load DDWRT 2.1 onto the box.

    Any ideas??
     
  11. jagboy

    jagboy Network Guru Member

    did you try to telnet to the rotuer and do a "nvramerase;reboot", i think is the commmand. post a nvram dump of the router with hyperwrt.
     
  12. BrainSlayer

    BrainSlayer Network Guru Member

    you may also 28. may build. i removed some stupid linksys code and replaced it again with my own one which was included in earlier prefinal5 versions.
     
  13. samueldg

    samueldg Network Guru Member

    Sebastian, I have the same problem with WRT54G V2 units.

    I flash them with 5/28 pre5, one of them apperar to upgrade fine, but don't reboot well.

    I allways have to tftp with satori4 to debrick them.

    As I said on another post, one have always the default settings and the other have an esablished settings. One is allways reflashed with pre and post manual reset, the other always flashed without any settings changes.

    Any idea?
     
  14. BrainSlayer

    BrainSlayer Network Guru Member

    and which one wont work?
     
  15. samueldg

    samueldg Network Guru Member

    The 2 units breaks.

    I'll test the 6/1 version later (this evening).
     
  16. samueldg

    samueldg Network Guru Member

    Bad news, the 2 units breaks with 6/1 prerelease 5 version (basic & normal).
    Good news, the basic tftp fine in g and gs units.

    The prerelease 4 works fine in WRT54G v 2.0 units.

    Any Ideas?
     
  17. BeefStu

    BeefStu Network Guru Member

    Both the 5/24 and 5/28 builds (both basic and full) brick my v2. In each case, I have no trouble flashing back to Linksys 2.04.3 and from there, to Freeman 1.04.
     

Share This Page